Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Looping Trails along Curve with MASH problem

5 REPLIES 5
SOLVED
Reply
Message 1 of 6
Anonymous
2249 Views, 5 Replies

Looping Trails along Curve with MASH problem

Hi guys,

Having a bit of an issue with MASH trails. I'm animating some shapes along a curve that emit some MASH trails and I need it to loop. All works fine except when the shapes reach the end of the curve and reset to the start of the curve and the MASH trails don't quite know what to do with themselves so you get a glitch as the trail jumps from the end to the start of the curve. I've attached a screengrab to illustrate the issue.


Does anyone know of a magical checkbox I'm missing to prevent this from happening or is it not possible? I know you can stop the objects moving once they reach the end of the curve but I do need them to loop.

 

Cheers

Tags (3)
5 REPLIES 5
Message 2 of 6
sean.heasley
in reply to: Anonymous

Hi @Anonymous

 

I believe this is happening because your curve isn't a loop. The trails basically want to stay attached the the object at all times so when your object jumps back to the opposite side the trail is going to do the same.

 

I don't believe there's a check box toggle to fix this but there are a few workarounds.

 

1. You could make the curve an actual loop so where it ends is also where it begins.

 

2. You could create a falloff object at the very end of the curve so the tail sort of vanishes at the last second before starting again.

 

3. Finally if its a short animation, you could key the trail length to be 0 at that point so it disappears similarly to how it does with the falloff.

 

Please let me know if this helps or if you need any more assistance!

 

 

Message 3 of 6
Anonymous
in reply to: sean.heasley

Hi Sean

 

  Thanks for the suggestion and it was a nice idea! Unfortunately I can't create a falloff directly with the trails themselves. I can create one on the objects themselves but once they pop off when they're in the falloff and pop back on again outside of the falloff we have the same problem as before...the trails try to appear out of nowhere and glitch when they try to jump from their previously known position to the new one. 

Keying the trail length sort of works but its very abrupt as all trails disappear at once when they should disappear one by one as they reach the end  at different times. 
We're currently using 2017 in production and the trails themselves are very stepped looking, there seems to be no way to change their resolution along the length, is this correct or is there a resolution slider hidden somewhere? The Sampling accuracy slider is only for the input profile curve resolution it seems.

One solution is to export to alembic and loop the alembic but it's not ideal.

 

Cheers

Message 4 of 6
sean.heasley
in reply to: Anonymous

Hi @Anonymous

 

For the quality I believe it may depend on your render settings a bit.

 

This is a really handy tutorial on trails/particles and he gets a really nice looking render at the end despite the curves initially looking somewhat stepped like you said. This video might help you as well with the looping issue.

 

 

 

Please let me know if anything changes!

 

 

Message 5 of 6
sean.heasley
in reply to: sean.heasley

Hi @Anonymous

 

I'm just checking in again to see if you need more help with this. Did the suggestion I provided yesterday work for you?

If so, please click Accept as Solution on the posts that helped you so others in the community can find them easily.

 

 

Message 6 of 6
Anonymous
in reply to: sean.heasley

Hi Sean, 

 

Sorry to leave you hangin' there! I'm afraid this isn't really a solution as the trails that MASH outputs is physical geometry, its not a rendertime trick with curves so it's not up to the renderer (in my case, Redshift) to subdivide it. You can of course subdivide the result at rendertime (using smoothmesh) but since the input geo is so lo-res (vertical subdivisions) it doesn't work properly around bends as it's not subdivided enough to give a nice result. As far as I can tell this isn't as big issue in 2018 as the vertical subdivisions are higher so you get a nicer result. 
I'm not sure there is a resolution to this in Maya 2017 unless there is a hidden slider or some way to access how mash draws the geometry. 

Cheers for all the suggestions though! You can mark this as solved if you like unless we can find a MASH dev to answer outright. 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators