Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

keying color of some nodes gives constant error/spam in script editor

2 REPLIES 2
SOLVED
Reply
Message 1 of 3
nobody_b
440 Views, 2 Replies

keying color of some nodes gives constant error/spam in script editor

I was making a light rig when I found that setting animation keys gave me a constant spamming error in the script editor (with echo all commands on). It spams:

timeField -edit -value `currentTime -query` TimeSlider|MainTimeSliderLayout|formLayout8|timeField1;
// Result: TimeSlider|MainTimeSliderLayout|formLayout8|timeField1 // 


it slowed down Maya enough to make it unusable
I cut down the nodes to get the minimum amount of nodes necessary to reproduce the issue:
key the green channel of one of the colors of a blend color that's going into the color of a sky dome light
please take a look at the attached file

2 REPLIES 2
Message 2 of 3
mspeer
in reply to: nobody_b

Hi!

Please report this problem (bug?) to Autodesk.
In Maya main menu:
Help -> Speak Back -> Report a Problem

(You can add a link to this thread, for the file.)

 

This bug is related to EM "Parallel".

As a workaround:

a) Switch Evaluation Mode from "Parallel" to "DG" (in Preferences > Settings > Animation > Evaluation).

b) You can also set Idle Action to anything else than "Idle Rebuild and Prepare for Manip" in Evaluation Toolkit -> 01)Modes -> ...

(Please add this information to the bug-report.)

Message 3 of 3
marie-jeanne_leduc
in reply to: mspeer

Hello,

 

Thank you for reporting this issue.

We can reproduce it and it has been logged as MAYA-112315.

 

Regards,

Marie-Jeanne



Marie-Jeanne Leduc
Senior QA Analyst

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report