Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Invert Selection broken across all maya versions on new PC

Message 1 of 3
448 Views, 2 Replies

Invert Selection broken across all maya versions on new PC

I got a new PC and I started using maya on it, however Invert Selection seems broken and I can't find any info about this online.  Basically IS command effects only parent objects in the scene and ignores all child objects.  Here are a couple examples.




I can't find any settings related to it and I tried copy the settings folder from old PC to new with no effect (C:\Users\****\Documents\maya\2018\prefs).  Old PC has maya 2014 and 2018 where IS works just fine.  New PC I tried this in Maya 2014, 2018, and 2020 witch are all broken in same way.  Old PC is Windows 7 vs Windows 10 on new one, and pretty different hardware.

Any help much appreciated, thanks!

Tags (1)
Message 2 of 3
in reply to: Anonymous

Hi @Anonymous,


I think the behavior is by design. From your example, if pSphere3 is selected and the selection is inverted (Ctrl+Shift+I), then this will result in a selection of pSphere1, since it is the same hierarchy level. pSphere2 is already selected as a child, but won't be highlighted since it is a lower hierarchy.


The same is valid for the example when pSphere2 is selected and the selection is inverted: pSphere1 and pSphere3 is selected in addition to pShpere2, since pSphere2 is the selection hierarchy level and will still be selected as a child if pSphere1 is selected by inversion.


Hope this helps!

Best regards,

Message 3 of 3
in reply to: patrick.schock

It might seem like it's by design from my simple example, but Invert Selection completely breaks when working with a complete scene with tons of child objects.  I work with characters and have to keep exporting animations for testing.  Before it took me seconds to Invert Selection and delete everything that's not bones (after baking), now it would take me many minutes manually select everything per export.  It also doesn't explain how this function changed simply moving from one PC to another.  I made some scripts to work around this issue but it's still a pain.


Extra Note:  I also discovered "Select All" command is broken in same way, that it only selects parent objects in the scene and ignores children.  I want to believe that it's just an option somewhere that I'm not seeing, but to no avail.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report