Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Interactive xgen serious BUG

8 REPLIES 8
Reply
Message 1 of 9
Bruce.Lee.
1649 Views, 8 Replies

Interactive xgen serious BUG

I found that maya2017 update3 xgen has 3 bugs.
Two bugs are not very serious, they will not affect the production.
But there is a bug that it causes Arnold to render xgen.

When I add this Clump modifier and change the density of the Clump modifier, Arnold will render the error. I cached and will render the error. When I cancel this Clump modifier you can render it normally.
Arnold rendering tips: [curves] xgenProcedural_334E871F432BC31AE5_curves: invalid number of points (found 0, expected 284394).

This bug leads to the inability to complete the rendering of xgen interactive hair, it makes me very sad 😞

8 REPLIES 8
Message 2 of 9
Michael_Todd
in reply to: Bruce.Lee.

This has been fixed internally and should be in a future release. As a workaround, add a cut modifier and give it very low values. The error should go away.

 

The error should only affect Arnold. Mental Ray and V-Ray should not have the same problem.

 

What were the other two issue? 

 

Cheers



Michael Todd

XGen Product Owner and Designer

Message 3 of 9
Bruce.Lee.
in reply to: Michael_Todd

1, my scene in the hair is very much, there are already more than one million hair. When I reopen the maya's project file, Maya will crash. However, I can import Maya's hair with the project file, the import is no problem.
2, the number of hair is very much, the density is very high. When my object is in motion, sometimes the hair does not follow the situation of the object. I will change the density is very small, the hair will follow the movement of objects, and then I change the density back to the original size, hair will follow the movement of the object.

Message 4 of 9
Michael_Todd
in reply to: Bruce.Lee.

The interactive grooming system is not dependent on projects settings. The older XGen system was, but the new system does not need sidecar files so it's not as dependent on the Maya project being set. 

 

Maya crashing when you set the project is not because of XGen, it can happen with an empty scene. It's a UI issue, I believe, and I have run into it a lot lately.

 

The new system is GPU accelerated so your video cards specs are a factor in how much density it can handle in the VP. You can groom with a lower density via the density mask or density multiplier and render at a higher density. The more memory and the faster the video card, the more hairs it will be able to handle in the VP. My quadro M6000 can handle millions of hairs quite easily.

 

Cheers

 



Michael Todd

XGen Product Owner and Designer

Message 5 of 9
Bruce.Lee.
in reply to: Michael_Todd

I think you misunderstood what I mean. I'm not talking about the project of Maya. I am talking about maya's mb file, which is the .mb file.
When I open the mb file, Maya will crash. But I import mb file, it is no problem.

Message 6 of 9
Michael_Todd
in reply to: Bruce.Lee.

That could be a prefs issue. Try deleting or moving the existing prefs aside and relaunching maya and load the scene. 

 

 



Michael Todd

XGen Product Owner and Designer

Message 7 of 9

The crash when setting the project file happens when you use the native windows version of the file system. If you use the maya version (which lacks many simple and useful abilities that are already in the windows system), it works without crashing.

Message 8 of 9
teemu
in reply to: Bruce.Lee.

Thank you SO much for the workaround. This was driving us INSANE. We were using a 3rd party cloud rendering service and their end we had this problem with Xgen - never would've thought it was the clump nodes. 

We also had file textures masking few attributes on the clump nodes. Deleting the connection made it working again but we then lost the masks. 

Thank you - any idea when this fix is implemented and to which version / service pack?

Message 9 of 9

Hi @Michael_Todd , I was searching for a solution for this bug, Im having it right now with maya  2020, is there any way to get rid of this weird fur behavior using clumps? I´m using a cut modifier but is not solving the problem, just hiding it. I´m attaching a image of the bug. Thank you.

 

Bug04.jpg

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report