Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Image Sequences are not working in Maya 2018

29 REPLIES 29
SOLVED
Reply
Message 1 of 30
sara.perez2284
40528 Views, 29 Replies

Image Sequences are not working in Maya 2018

I tried to import a video .mp4 to maya and I couldn´t soy I tried to import as a .mov and I couldn´t. In both cases appears the error ``is not a supported movie file type and/or codec on this platform´´ so I tried to import the video as a image sequence and I could only saw the first frame and not the video.

Please help.

29 REPLIES 29
Message 2 of 30

Hi @sara.perez2284 and welcome to the community!

 

Do you have the image sequence named accordingly with no weird characters?

 

Also, in the Attribute Editor, did you turn on Use Image Sequence?

This automatically enters an expression (=frame) into the Image Number attribute. The Image Number is equal to the Time Slider’s current frame.

 

 

Message 3 of 30

There isn´t any weird character and I have the Image Sequence turn on.

Message 4 of 30

In fact when I pick ``use Image Sequence´´ in a camera and I add the photo. automaticaly the option ``Use Image Sequence´´ is turned off.

Message 5 of 30

Hi @sara.perez2284

 

Did you try changing the Image Number value?

 

You might want to following this tutorial:

 

If that doesn't help, try deleting your settings/preferences and making sure your GPU drivers are up to date!

Steps to update your drivers can be found here!

 

 

Message 6 of 30

I have follow the video and this is what happened.Captura de pantalla (49).pngCaptura de pantalla (50).png

 

 

Message 7 of 30

I changed the preferences and it still happening. And I have windows full updated.

Message 8 of 30

Hi @sara.perez2284

 

Its a bit hard to tell but it looks like it loaded normally in the first screenshot.

 

What happened in the second screenshot? Did you try to move along the timeline?

 

When you get a chance, can you please zip and attach the folder with the image sequence here or via dropbox/google drive or another file sharing program so I can take a look at it?

 

 

Message 9 of 30
sean.heasley
in reply to: sean.heasley

Hi @sara.perez2284

 

Just wanted to check in to see how things were going. Are you still having this issue?

 

If your issue is resolved, please click Accept as Solution on the posts that helped you so others in the community can find them easily.

 

 

Message 10 of 30
zerone_mel
in reply to: sean.heasley

I had the same issue. Maybe it depends on the resolution of the sequence. Try to lower the resolution and use png-sequence without any underline: [name][####].png 

Hope it helps.

Message 11 of 30
anna_chan
in reply to: sara.perez2284

Hi Sara, 

 

Not sure if you're still experiencing the issue, but I found the solution when I watched that video tutorial he posted. The mistake I made was having 5 #'s instead of just 4 #'s when naming the png sequence. 

 

So maybe try re-saving the sequence and make sure to give it a simple name (without any characters) and only give it 4 #'s (the default will give you 5, so in my case I had to delete one)

i.e. Try simplename####.png instead of simplename#####

 

Hope this helps and you find a solution

Message 12 of 30
anna_chan
in reply to: sean.heasley

Thanks Sean! Following this tutorial was exactly what helped! Thanks again!

Message 13 of 30

was having the same issue, didn't try .png but .tga worked for me. You can also render image sequences in photoshop btw. 

Message 14 of 30

Hello Sean, 

 

I'm experiencing the same issue and it looks like Sara's screenshot in the Attr Editor. I'm using a different workflow from the tutorial you posted:

I'm creating a camera>image plane>image; link the first image in the sequence and then check the box below, 'Use Image Sequence'. It only reads the first image and inserts the number '1' into Image Number. 

 

I checked the file names, they look like MVI###.jpg all named without skipping any numbers. I don't have the original movie to re-export as .png as I am using files from a tutorial on Pluralsight and this image sequence is the only thing included. I am using Windows 10, just updated, and renamed the pref folder as well as per your previous suggestion. 

 

Anything else you could think of I could try, please? 

Many thanks, 

Hana

Message 15 of 30

Try to put the images called with numbers. Instead of be named as "video of
anything" try to rename the images as "1", "2" or the number that you
prefer. But use only numbers, not letters.
Good luck.
Message 16 of 30

I figured out something interesting about imagePlane as well. If you write out your mov files as just ####.jpeg, the image sequence will Not play even with the box checked. It has to have alphabets followed by ####.jpeg. ie, xxxx0001.jpeg. And also I'm not sure if jpg files play as I stuck with what worked for me, which was .jpeg instead of .jpg. Hope that helps someone having the same issue. 

Message 17 of 30

hi there 

this problem has a simple solution as maya faces some issues in reading the image sequences starting with numbers, it means that your sequence should have a suffix without any Special characters (!,@.#,<,etc).

 

Give it a shot, it works fine with me .

 

Thanks,

 

Message 18 of 30

It helps!! Thank you @arshkumarmishra !!

 

I tried:

    1,2,3,4,...

    0001, 0002, 0003, 0004, ...

    000001, 000002, 000003, 000004, ...

None of them work.  Then I tried a random character like

   test_0001, test_0002, test_0003, test_0004,... 

It works.

 

That sounds a bug in Maya as it should be fixed with a simple regular expression. Hard to believe this bug still exists after a long time.

Message 19 of 30
anishm5FV4R
in reply to: titanriver

Hi Guys,

The real issue behind image sequence not working is the naming convention..

Your sequence name should be "name.#.ext".   Example if image name is ABCD,format is 'jpg, Then the sequence name should be" ABCD.0001.jpg"..Important is there should not be any space or underscore in the name...Just "name.sequencenumber.imageformat."...It will work for sure....

Message 20 of 30
fxnayeem
in reply to: sean.heasley

Thanks 😊

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report