Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Help! cannot open file contains unknown nodes or data. and maya crushes

4 REPLIES 4
Reply
Message 1 of 5
moti80
800 Views, 4 Replies

Help! cannot open file contains unknown nodes or data. and maya crushes

Hey all.

i have an .MB file, of a massive scene (about 12GB).

computer crushed during rendering, and since i can't open the file any more. i get the massage about unknown nodes or data, and immediately after i get a fatal error massage- and maya crushes.

so i can't open the file.

 

tried to import the scene into a new one - same results.

i use maya 2019 on a mac.

what can i do with this situation?

4 REPLIES 4
Message 2 of 5
daunish
in reply to: moti80

This may be really bad for you. A big crash with a binary Maya file could mean it's corrupted. In the future, I recommend working with MA files (even though it's a bigger file). That way you can open it in a text editor and start unloading things to get the strain on Maya down.

 

Try freezing your viewport when opening. Freeze the viewport then open your scene. Once open try unloading files. Or run a optimize scene on just unknown nodes. I've included a screenshot of where to find both options just in case.

 

If neither of those work you may just have a corrupted file and will have to fall back to an earlier version, sorry.

Message 3 of 5
moti80
in reply to: daunish

Thank you daunish  for your answer.

i tried many things and came to this:

the project open with maya 2018, but not with maya 2019.

even after i fixed all unknown nodes and data, and saved it to a .MA file.

for now, i use maya 2018 - but i really want to figure out why can this happen?!

 

Share me if you have any thoughts

Thanks again

Message 4 of 5
daunish
in reply to: moti80

The main logical reason I find this happens with incompatible nodes and more importantly plugins. Plugins will create shapes and objects that can be readable with one version but not the other. Were you able to clean the file at all in 2019? Is there anything you have installed that would lead to this?

 

I said this is the most logical reason for this. Its Maya, and while it is a powerhouse, bugs, and glitches do happen that are unpredictable

 

It's also important that in general, you don't switch versions mid-project. This is one of the biggest reasons why. Sometimes it can be unavoidable, but that's pretty unlikely.

 

To put it into context, the studio I'm at had 4 versions of Maya installed on every computer, because some properties were in 2016, and on the very very rare chance we have to open one, we need to do so in the correct version. Another studio I was at was using an incredibly outdated version of Maya, even for new projects. 

 

Thankfully it doesn't sound like you have a serious problem, as you can open and keep working with your file. The improvements they made to 2019 over 2018 are basically negligent, so stick with 2018 while you wrap up this project.

Message 5 of 5
moti80
in reply to: daunish

thanks again :]

the problem did not accord because of a version switch - it was the solution, this time...

actually i had only 2019 installed, and i installed 2018, as a long shot to try specially for this. both installs are "out of the box" maya, with no extra plugins at all.

unfortunately, i can't open the project  in maya 2019 to fix the nodes inside. so for now, till the end of this project ill continue to stick to the 2018 verssion. still i don't understand why it opens in one version, and in the other - not 😞

lucky me to have this solution.

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report