Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Grid became massive, all of a sudden!

Message 1 of 5
376 Views, 4 Replies

Grid became massive, all of a sudden!

So I opened a scene I've been working on for a while. And I needed to enable the grid for some snapping. I turn it on and see this:



I haven't changed any settings on my grid. And I'm working in UE4 units, so with my settings it's supposed to be 1 square == 1 meter.

Here's the same human scale model and one of the elements of the scene exported to a new scene with THE SAME grid settings:



As you can see, it's fine here.


What is this bug and how can I fix it? Do I have to export my entire scene just to fix the grid?

Tags (2)
Message 2 of 5
in reply to: Kligan


Grid lines are related to the units setting used on the scene.

Just adapt the division settings of your Grid.

Message 3 of 5
in reply to: mspeer

Well yes, that is one of solutions, but I still don't understand why did it happen in the first place!


I went ahead and checked the units in preferences, and it was set to meters instead of centimeters. How did it change by itself? No idea...

Message 4 of 5
in reply to: Kligan



It's unlikely that the units changed by itself.

Message 5 of 5
in reply to: Kligan

I came to the Support Page to place a bug about this myself, but after googling I discovered your post and I see that you've already reported it here.

From what I've discovered, there could be two possible causes.

A) You mentioned that your scene has changed from cm to metres. This happens to me a lot too. Preferences can sometimes be wiped by a Maya crash, or by opening someone's scene that has different units m/cm/mm.

B) The other thing I get a lot with Maya since 2019, every time I open a scene, Maya multiplies the grid square's size by x10.
So, if you set your square size to 1m, the next time you open the scene, your squares will be 10m. After opening the scene ten times, an individual grid square will be 1000000000m.
grid x10 bug GOB.jpg
You can see it's doing it to the grids' Length and Width too. At a certain point, Maya doesn't know how to draw grid planes of this size in a scene: it creates draw issues 😄

A workaround for both issues: You can correct the values in your Grid Options Box and your scene units in Preferences at any time, but you shouldn't have to spend your time managing it. Until Autodesk fixes these, you could create a MELscript shelf button that returns your scene to your favourite Grid and Unit settings.
Start out by looking at the helpful Grid Options Script Examples I found in this guide.

Script Example, modified for your purposes, including quasi-code in comments:
// I want to set my grid length and width to 5x5m, with
// major grid lines every 1 unit, with 1 division between
// major grid lines. This can be done with the following command.
grid -size 1m -sp 5.0m -d 5 ;

Next, you could google up a sample MELscript that forces your scene to your favourite Units.

Good luck!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums