Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

FBX Converter and Maya 2018 issue

13 REPLIES 13
SOLVED
Reply
Message 1 of 14
Anonymous
3252 Views, 13 Replies

FBX Converter and Maya 2018 issue

So im exporting a rigged mesh as fbx out of maya 2018, i bring it into the 2014 fbx converter (this is the most recent version i could find) and anything that i select for export it keeps populating a txt file that says: Call to FbxImporter::Import() failed. Error: File is corrupted

 

I've created a new scene with only a simple box to see if it was anything in my model and the same thing is happening. Can anyone tell me why this is happening? Does it matter that i'm still in my trial phase?

13 REPLIES 13
Message 2 of 14
sean.heasley
in reply to: Anonymous

Hi @Anonymous and welcome to the community!

 

I'm a little confused by your issue. Are you trying to convert your rigged mesh to an FBX or convert from an FBX to another format?

 

As for the issue, it may be because the fbx converter is outdated that going from 2018 to it may not work as expected.

 

That said, if you can let me know what you're trying to accomplish I would be more than happy to work with you to find a workaround or solution to this!

 

 

Let me know if anything changes!

Message 3 of 14
sean.heasley
in reply to: sean.heasley

Hi @Anonymous

 

Just wanted to check in to see how things were going. Are you still having this issue?

 

If your issue is resolved, please click Accept as Solution on the posts that helped you so others in the community can find them easily.

Message 4 of 14
Anonymous
in reply to: sean.heasley

i solved the issue, it did relate to the outdated converter. I just changed the output to an older fbx format before exporting and it worked fine.

Message 5 of 14
Anonymous
in reply to: sean.heasley

Sorry to hijack this thread, but I'm having an FBX issue where I'm trying to export selection of a camera and import it into EU4, but when I use Export>selection no animation keys show up.  If I use export >all to fbx, then I get animation keys in EU4.  

 

Has anyone else had this problem?

Message 6 of 14
sean.heasley
in reply to: Anonymous

Hi @Anonymous

 

I don't believe cameras can be exported to UE4 as it has its own camera system.

 

 

Message 7 of 14
Anonymous
in reply to: sean.heasley

Message 8 of 14
sean.heasley
in reply to: Anonymous

Hi @Anonymous

 

Ah cool this must've been added with a UE4 update.

 

When you go to export the camera, do you have the all of the proper fbx settings enabled like animation, baked keys and the key frame range etc?

 

Also you mentioned export all showing keys, is that working for you?

 

 

Message 9 of 14
sean.heasley
in reply to: sean.heasley

Hi @Anonymous

 

Just wanted to check in to see how things were going. Are you still having this issue?

 

If your issue is resolved, please click Accept as Solution on the posts that helped you so others in the community can find them easily.

 

 

Message 10 of 14
Anonymous
in reply to: sean.heasley

I have gone through and used all the same settings on the export. If I do it by selecting the camera and do export selection, when I pull it into UE4, I get no animation. When I use all the same export settings and do export all, the animation transfers over.

 

Still not fixed.

Message 11 of 14
sean.heasley
in reply to: Anonymous

Hi @Anonymous

 

So when you do export all, the camera and the animation gets exported properly. Does that not work for you?

 

Also is your UE4 up to date?

 

 

Message 12 of 14
Anonymous
in reply to: sean.heasley

Yes, if I do an export all, the animated camera gets exported. BUT if I select the camera and do an EXPORT > SELECTED , the animated camera isn't animated (it has no keys) when imported into UE4. Yes, latest unreal version. 

Message 13 of 14
sean.heasley
in reply to: Anonymous

Hi @Anonymous

 

Hmm ok. You could try unloading the fbx and plugin then reloading it.

 

If that doesn't work you might want to try deleting your settings/preferences.

 

Finally if that doesn't work, can you try creating a new scene with a basic camera animation and then export it to UE4 to see if anything changes?

 

 

Message 14 of 14
sean.heasley
in reply to: sean.heasley

Hi @Anonymous

 

I'm just checking in again to see if you need more help with this. Did the suggestion I provided yesterday work for you?

If so, please click Accept as Solution on the posts that helped you so others in the community can find them easily.

 

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums