Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Everything vanishes when clicking Viewcube projection

3 REPLIES 3
SOLVED
Reply
Message 1 of 4
Henrik_Cederblad
335 Views, 3 Replies

Everything vanishes when clicking Viewcube projection

Maya 2022.3 on Windows 10:

 

I'm experiencing a very weird issue where everything vanishes from the view if I click any of the Viewport's sides, if have nothing selected when doing so. What happens is, the view animates further and further away until I see no objects.

 

Selecting some object in the outliner and hit F, or selecting nothing and hit A, does nothing. The only solution is to choose Default View from the Viewcube.

 

This is true for all view projections, even perspective. Difference being that, in Perspective, if I click e.g. Front (everything disappears), I can then select the object in the Outliner and hit F to bring it back. Whereas if I do this in e.g. the Front view, I can not select in outliner and hit F nor deselect everything and hit A.

 

I'm attaching the .mb with the offending phenomeon and also a video demonstration:

 

https://youtu.be/ei3GjcxJ-3U

 

3 REPLIES 3
Message 2 of 4

Uh, is it available in M2022? My Help says, not supported with Viewport2.0 for M2018 and later, can't test.

Ortho cameras are tricky, select the camera in and see what is going on with its translate, what numbers.

Basically, you can live without that viewCube, as holding <Space> brings up the marking menu from where you can select which way to look.


,,,_°(O__O)°_,,,
Maya2019.1 @ Windows10 & GeForce GTX1080Ti

If the post was helpful, click the
 ACCEPT SOLUTION  button, so others might find it much more easily.

Message 3 of 4
mspeer
in reply to: Henrik_Cederblad

Hi!

 

It just frames the content of the scene, so also hotkey "A" works, which also tries to frame all content.

Just hide the aiSkyDomeLight1 and you will get a much better result.

(This sort of scene framing ignores visibility settings in a Display Layer. I can't say if this intended or not, it's just how it works.)

Message 4 of 4

mspeer's answer solved the issue (thanks mspeer). As maybe mspeer also alluded to, I think it's debatable whether it's intuitive to ignore display layer visibility in this case. Hiding the aiSkyDome (H) rather than hiding it via display layer removed the problem.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report