Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error: Failed to get layer data plug as object

1 REPLY 1
SOLVED
Reply
Message 1 of 2
regan.the.jackson
648 Views, 1 Reply

Error: Failed to get layer data plug as object

So, I’m animating a short scene for a class, and I’ve referenced in a background and character. This was working fine in class, but I’ve had a couple issues at home. The references didn’t show up at first, but I just told maya where to find the files for the character, and I think I ended up just re-referencing the bg.

It seems fine now, unless it somehow has to do with this error. It just says “Error: Failed to get layer data plug as object” and I have no idea what it means. I’ve tried looking it up both on google and here, and have found nothing. I would just ignore it, since I don’t think anything’s too broken, but I get multiple of the error message when I do literally anything. Like, even just moving around the scene or selecting something will give me around six of the error messages, all saying the same thing.

Please help me either figure out how to fix this, or tell me how to turn off error messages because it’s really annoying and distracting.

1 REPLY 1
Message 2 of 2

Well! I figured it out, and figured I’d mention it here. Turns out I hadn’t saved my blue pencil drawings, and deleting the blue pencil item in the outliner fixed it. I think the issue is that I made them on a different computer, and they couldn’t be transferred to this one without me exporting them? Anyway, I’m pretty sure the error was that Maya couldn't find a file containing the blue pencil drawings and stuff.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report