Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Diffuse baking gives very strange results

8 REPLIES 8
SOLVED
Reply
Message 1 of 9
sofiane_09
1894 Views, 8 Replies

Diffuse baking gives very strange results

Hello,

 

So i have my character UV mapped and i want to bake a Color ID map to texture it on Quixel suite.

 

As you can the mesh group is correctly UV mapped, but this i what i get when the texture is baked ( second image )

 

I've tried many settings. It doesn't work with the default bake settings anyway. I have even installed maya 2016 ( i'm on maya 2017 ) to try it on and it didn't work Does somebody knows how to fix this ?

 

Note that the baking doesn't work for very simple meshes such as a mere cube.

8 REPLIES 8
Message 2 of 9
mspeer
in reply to: sofiane_09

Hi!

 

You may check the normals.

For further help, please upload the scene-file.

Message 3 of 9
sofiane_09
in reply to: mspeer

Thank you for responding.

 

There were indeed a problem with normals, we can see this with smooth mode disabled.  (1st image)

 

I was able to fix this with set normal to faces (img 2)

 

However, i still have the same problem. the resulting baking failed. (img 3) The baking also doesn't work even if i do it with a simple freshly created cube. This is depressing.

Message 4 of 9
mspeer
in reply to: sofiane_09

Hi!

 

Please upload a scene-file (keep at least one of the meshes that fails when baking).

Message 5 of 9
sofiane_09
in reply to: mspeer

Oh yes i'm sorry, i've prepared the scene file but forgot to send it. Here

Message 6 of 9
mspeer
in reply to: sofiane_09

Hi!

 

It seems you forgot to tell Maya that the objects are not at the same position.

 

A) Transfer Maps -> Maya Common Output -> Transfer In "Object Space" (instead of "World Space"), or

B) move one object above the other (for example set both to Translate [0 0 0]).

Message 7 of 9
sofiane_09
in reply to: mspeer

Thank you very much, it works now !

Message 8 of 9
haiqalfitri345
in reply to: mspeer

Im also have the same problem and already tried your suggestion but it's not working. Im new in texturing. 

Message 9 of 9
smsheard
in reply to: haiqalfitri345

I did the opposite of the advice above to fix this problem, IE I changed the setting from object space to world space. Hope this helps.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums