Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't save weight paints

4 REPLIES 4
SOLVED
Reply
Message 1 of 5
Anonymous
492 Views, 4 Replies

Can't save weight paints

Hello everyone,

 

This is a long shot as I've come across many forums on this subject but none were helpful so thought I'd try asking myself. I've binded the skin of a character in Maya (Geodesic Voxel) and am now trying to weight paint it. Problem is it refuses to remember where I've painted. I'll paint one joint, move onto the next, then the joints I've previously painted are randomised.

 

I've turned off max influence.

I've removed/added influences in all sorts of ways.

I've unbinded then rebinded the skin.

I've tried only using "add" while painting.

There are no overlapping UVs.

None of these have many any difference whatsoever.

 

Can anyone help me???

 

Also, I'm still learning Maya so if there's any settings I need to go to or anything you may need to tell me where to find them.

4 REPLIES 4
Message 2 of 5
hamsterHamster
in reply to: Anonymous

Still sounds like you have Max Influences enabled, disable. In the PaintWeights tool make sure that no joints have locked (lockpad button). Yes, it is safest to use the Add in the areas that are (or near to) total white, 1.000. Otherwise, the weight is split evenly between all unlocked influences.


,,,_°(O__O)°_,,,
Maya2019.1 @ Windows10 & GeForce GTX1080Ti

If the post was helpful, click the
 ACCEPT SOLUTION  button, so others might find it much more easily.

Message 3 of 5
Anonymous
in reply to: hamsterHamster

Well I went to Edit Influences in the Skin menu and set Max Influence to 0. Unless there's another way to disable max influence that I'm missing then it's already disabled. Still no difference.
Message 4 of 5
hamsterHamster
in reply to: Anonymous

... which is an indication that you still have it enabled. You should disable the Maintain Max Influences checkbox, then it is impossible to enter anything into grayed-out Max Influences field.

hamsterHamster_0-1614440811707.png

Now try to paint the weights.


,,,_°(O__O)°_,,,
Maya2019.1 @ Windows10 & GeForce GTX1080Ti

If the post was helpful, click the
 ACCEPT SOLUTION  button, so others might find it much more easily.

Message 5 of 5
Anonymous
in reply to: hamsterHamster

Aha! ok so it's still a tad weird but that seems to have made a big difference. Thanks loads!!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report