Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't save my scene in Maya and can't export animation clip

10 REPLIES 10
Reply
Message 1 of 11
Anonymous
6202 Views, 10 Replies

Can't save my scene in Maya and can't export animation clip

I've started using Maya 2015 (student license) on my Macbook Pro with OSX Yosemite today.

After doing a lot of work when I try to save my scene in .ma or .mb it gives me the message "Error: line 0: Could not save file.

I've already saved 3 scenes today without any problem..I don't know how something as simple as this wouldn't work.

 

Also I've tried to export the animation I have done in the 3 scenes I have already saved to blend them in 1 scene using the Trax Editor but it doesn't work either.

I create the animation clip in the Trax Editor and I try to export it: File - Export Animation Clip but it gives me the message "Error: file: /Applications/Autodesk/maya2015/Maya.app/Contents/scripts/others/doExportClipArgList.mel line 132: Could not save file"

 

Can someone help me for one or both problems?

Thanks

10 REPLIES 10
Message 2 of 11
Anonymous
in reply to: Anonymous

I have had the same problem, and I have tryed the regular fixs with Deleting unknowen nodes... its messed up I tell ya.

Message 3 of 11
mindsong
in reply to: Anonymous

Im haveing the same issues, once i create a clip in trax editor I am unable to save the scene or export the clips. 

 

Charles Kinter

Message 4 of 11
Anonymous
in reply to: Anonymous

Count me in as well. I have been trying to figure this out for days now! Please Autodesk some help please!

Message 5 of 11
TwiliChaos
in reply to: Anonymous

I've done a little bit of testing with the Trax editor to see at what point it stops saving.

Using Maya 2016, Service Pack 6

Opened file with animation, Maya can save the scene successfully.

Opened Trax editor, Maya can still save.

Trax Editor > Create > Animation Clip (using default settings), Maya can still save.

Selected the clip, Trax Editor > File > Export Animation Clip... and made sure I was exporting to .mb since my file is .mb and Export Animation Clip's default file type is .ma

// Error: file: C:/Program Files/Autodesk/Maya2016/scripts/others/doExportClipArgList.mel line 132: Could not save file "C:/Users/Username/Documents/maya/projects/Projectname/clips/clip1.mb". // 

 

Attempted to save scene,

// Error: line 0: Could not save file "C:/Users/Username/Documents/maya/projects/Projectname/scenes/scene.mb". //

 

Reopened the scene, rotated the camera, attempted to save.

// Error: line 0: Could not save file "C:/Users/Username/Documents/maya/projects/Projectname/scenes/scene.mb". //

 

Created a new scene, attempted to save scene as a new scene

// Error: line 0: Could not save file "C:/Users/Username/Documents/maya/projects/Projectname/scenes/testsave.mb". //

 

Closed Maya and reopened it, and it could save properly.

It appears that specifically attempting  Trax Editor > File > Export Animation Clip... breaks the saving functionality of Maya until it is closed and reopened.

After looking up some solutions, I seen that using the doExportClipArgList.mel and doExportClipArgList.res.mel from Maya 2012 could possibly fix the problem. Since I couldn't get the 2012 version I tried for 2014. I received the same error message, so 2014's script didn't work, or weren't compatible with Maya 2016.

I switched back to the 2016 scripts just in case, and converted my scene from .mb to .ma. Afterwards I tried the Trax export again, and got the same error.

The error refers to doExportClipArgList.mel line 132, which is: 

file -f -type $fileType -exportSelected -channels true -constructionHistory true $fileName;

I don't know if that's correct or not, since I know nothing about MEL, but that's the line that always comes up.

After commenting out lines 119 through 139 of doExportClipArgList.mel, I had no errors and could save my scene normally after the script ran, but nothing exported (I didn't expect anything to export), so I'm guessing something in there is the problem.

Message 6 of 11
TwiliChaos
in reply to: TwiliChaos

I don't know how to edit my post, so apologies for the double post. Maybe I don't have the option to? Anyways...

 

I think I found a fix. After comparing the 2011 version of the file and 2014, checking between the two, I think I figured out what the problem was.

 

 

On line 137, paste the following right after the bracket (don't forget the spacebar):

 else {
		select -r $sel;		
		error( (uiRes("m_doExportClipArgList.kUnableToExportErr")) );
	}

 I tested it a few times and it's working perfectly. Trax Editor > File > Export Animation Clip should now work without problems.

Message 7 of 11
Anonymous
in reply to: TwiliChaos

I owe you a six pack
Message 8 of 11
Anonymous
in reply to: TwiliChaos

Can you give a better example of where to paste the added code in context? I feel like based on your description the line numbering on my end is slightly different and it's not working.  I'd love to fix this animation clip export issue.  It's driving me crazy that it's not working in any version of 2016 or 2017.

Message 9 of 11
adriandesignsoffice
in reply to: Anonymous

same here, really frustrating that no one at autodesk is addressing this issue, obviously many users suffer from this issue... I can just imagine the lost hours that make a user want to uninstall and move on to another 3D app..

ridicules 

Message 10 of 11
pixonti
in reply to: Anonymous

For anyone ever stumbling upon this thread, that started back in 2015, and is still apparently an issue, I discovered a solution that works for me. Hopefully, it will help anyone else with the same issue.

 

Message 11 of 11
lynn_zhang
in reply to: pixonti

Hi @pixonti 

 

Glad to hear you fixed the problem and thanks so much for sharing the solution! This will benefit other users in the community with the same issue.





Lynn Zhang
Community Manager


Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report