Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Auto keying not setting frames at all

5 REPLIES 5
SOLVED
Reply
Message 1 of 6
lebert823
6493 Views, 5 Replies

Auto keying not setting frames at all

I was just about to finally start animating in Maya 2016 and i clicked the auto keying button and moved my character. When i moved him i looked and no keyframe was set. I made sure it was on, turned it off and on again and still no keyframes. Any reason why it shouldn't work? Thanks everyone in advance!

5 REPLIES 5
Message 2 of 6
Roland.Reyer
in reply to: lebert823

Hi,

 

Auto Keyframe will only keyframe those channels that already have a keyframe *OR* the channels in the current character set.

 

You need to either set an initial keyframe for the channels that you want to animate *OR* define and set a "Character Set" (Animate->Key->Create Character Set).

 

 

Message 3 of 6
mspeer
in reply to: lebert823

Hi!

 

Auto key only works for channels/attributes that already have at least one key.

Message 4 of 6
lebert823
in reply to: lebert823

I just set key frame in all channels and everything is working. Thank you both!

Message 5 of 6
benjaminc404
in reply to: lebert823

I have set a key for every channel, still not working.

 

Restarted maya, not working still.

 

Reset preferences, STILL not setting any keys.

 

I don't know what I need to do to fix it. 😞

Message 6 of 6
eweissU28PA
in reply to: lebert823

Same results here. Keys set in desired channels but auto key is not updating all channels correctly. Maya V2022.4

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report