Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Arnold Rendering ncloth Issues

5 REPLIES 5
SOLVED
Reply
Message 1 of 6
Anonymous
2104 Views, 5 Replies

Arnold Rendering ncloth Issues

 

I've been having an issue with Arnold lately that I can't seem to figure out. I have an ai standard material with a transparent background, I have loaded in the alpha channel and everything seems to render out fine in Arnold until I put ncloth on the object, this seems to be cancelling out the alpha channel somehow and causing the object to render with a black background.

 

Any ideas?

5 REPLIES 5
Message 2 of 6
mspeer
in reply to: Anonymous

Hi!

 

nClothShape seems to override setting in the originalShape settings, so your Arnold settings in the originalShape are ignored and "Opaque" is enabled and can't be disabled in nClothShape.

A workaround could be to use 2 shapes, one for simulation and one for rendering or use an other renderer.

 

Please report this problem (bug?) to Autodesk.
Help -> Speak Back -> Report a Problem

Message 3 of 6
Stephen.Blair
in reply to: Anonymous

After you convert to nCloth, you have to set the Arnold properties (like Opaque) on the outputCloth mesh



// Stephen Blair
// Arnold Renderer Support
Message 4 of 6
Anonymous
in reply to: Anonymous

I thought I had tried that but I tried it again and it worked, thanks!
Message 5 of 6
mspeer
in reply to: Stephen.Blair

Hi!

 

Thanks, i was just looking at the nClothShape and missed outputCloth, so yes, using the attributes in outputCloth works.

Message 6 of 6
mspeer
in reply to: Anonymous

Hi!

 

Please mark the answer from @Stephen.Blair as solution.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report