Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Alembic caches losing connection after move

12 REPLIES 12
SOLVED
Reply
Message 1 of 13
Parmenides
4283 Views, 12 Replies

Alembic caches losing connection after move

I have a file with many alembic caches. They are kept in the project/cache/alembic folder. If I move the entire project to another computer to render, when I open the scene, all of the alembic caches are missing in the viewport but are still showing in the Outliner.  If I click on the file in the outliner and then go to attributes and try to update the cache (which is showing the correct location for the cache) it says "Alembic cache re-pathing is not supported" and it doesn't show up even though I am not really re-pathing.  

 

I can re-import the cache but I lose the textures, start point, weeding of un-needed items, etc.   I have tried this with two different outside computers and also tried it with a simple test project with one alembic file and I get the same issue when opening scenes that have been moved to another computer even though the correct project has been set.

 

I saw that others have had the problem but they just imported it again. I don't have that option when I send it somewhere where they can't do that.  https://forums.autodesk.com/t5/maya-forum/change-pc-alembic-missing/m-p/7357345#M46575 

 

Is there a workaround for this? Maybe something I am supposed to do before moving the project?  Thanks. 

12 REPLIES 12
Message 2 of 13
mspeer
in reply to: Parmenides

Hi

I have also seen this with a project sent to me.

Because of lazyness i saved the file as ASCII and edited the file path in the Maya file with a Text Editor, that worked fine. As this never happened again i did not spent more time on this.

 

Maybe i try this again when i have some spare time and see if there is an other solution .

Message 3 of 13
Parmenides
in reply to: mspeer

Thanks. So I saved the file as ascii/.MA and opened it in a text editor but couldn't find a reason for the alembic files to not load. I also have 2 bifrost alembic files also but those load and render fine. I don't see why some load and some don't as the file path seems to be exactly the same. 

path.png

erroropening.png

Message 4 of 13
mspeer
in reply to: Parmenides

Hi!

 

In the last line the string is empty (""):

setAttr ".fns" -type "stringArray" 1 ""  ;

add the file path there too, but without the double slash for relative path (".../cache..." instead of "...//cache...")

Message 5 of 13
Parmenides
in reply to: mspeer

You got it. I filled in the double quotes as you suggested and it all the caches showed and and rendered correctly.  I closed and saved/reopened and it still worked. I had tried earlier without the // and it changed them back when I saved it.  Thanks!   Now to figure out why its doing it in the first place...

 

Message 6 of 13
mspeer
in reply to: Parmenides

Hi!

The first path can have double slashes // that's totally correct.

Message 7 of 13
rymerkm
in reply to: Parmenides

Hi, 

 

I'm having the exact same problem and I'm trying to follow your suggestions but I don't quite understand. Could you relay how to save the project and open up as a script in text editor? 

Message 8 of 13
Parmenides
in reply to: rymerkm

Hi, basically you need to do a reserve of your file but instead .mb you save it as .ma which creates a human readable text file instead of a binary file. It makes the file considerably larger but you can read it in any text editor.  

Message 9 of 13
rymerkm
in reply to: Parmenides

Thank you! I Downloaded sublime text and have fixed my files. This commission was largely alembic information so I appreciate your help!!!

Message 10 of 13

Why in gods name is this a problem in this day and age that a perfect copy of a project to a different drive can't repath properly. This is ridiculous. Why are the paths not relative. This is a HUGE problem for me and I can't find an easy way to fix it beyond editing a .MA file in notepad? For REAL? Am I missing something here?

Message 11 of 13
rconn
in reply to: everyonediesfilms

Mate, I feel your pain. You are perfectly correct; this is the kind of thing that autodesk/maya is seriously deficient in..... the seemingly simplest, most logical issues, are, well ...... issues... and shouldn't be. 

Message 12 of 13
ashwithullal
in reply to: Parmenides

I have Edited the file in the text editor .It works lika a charm.Why do this keep happening ? how can i avoid the same in the future? Plz suggest....

Message 13 of 13
20016784
in reply to: ashwithullal

I found this solution when I ran into the same issue. I really didn't want to mess with changing file types and code editing if I didn't have to. So I tried something else. I went into File>Project Window and down at the bottom under Custom Data Locations, I opened the file folder, then selected Cache>Alembic and clicked Select. Accepted the Project Window changes, and voila, everything was relinked. So I'm not sure what goes haywire, but relinking it directly in the file solved the issue.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums