Community
Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Alambic importing Partical erro! Error: line 1: particleShape1: -object flag

9 REPLIES 9
SOLVED
Reply
Message 1 of 10
vfxronin
2925 Views, 9 Replies

Alambic importing Partical erro! Error: line 1: particleShape1: -object flag

Im going to be honest this bug has got me Completely stumped!

 

I have a Houdini artist how has generated some particles sims that i would like to use in maya to render and shade.

 

the moment i try to import the abc file i hit with a error msg 

 

"// Error: line 1: particleShape1: Object not found for -object flag."

 

 i presumed that was a error during the ABC file. after testing the Abc file in V-ray proxy in maya, nuke, modo, blender! they all can import the file perfectly fine! i tried generating particles in nuke and import in maya via ABC file and same error!

 

 

is this a bug or am i doing something wrong here?

 

p.s. Maya ABC importer is out of date as well! could this be a issue?

 

 

9 REPLIES 9
Message 2 of 10
jordan.giboney
in reply to: vfxronin

Hi @vfxronin

 

Thanks for posting! I am sorry you are having difficulties importing Alembic particle files.

 

I did some research and found that this is a defect and logged in our developers database. Alembic does not support particles. They are working on it, but for future reference the defect number is BSPR-13752; you can use that number to cross-check with updates/version releases to see if the issue has been resolved. 

 

For the time being, I would encourage you to go to our Maya development Feedback Forum where you can vote to get this issue further escalated. You can do that by navigating to the Feedback Forum and then searching for your topic, or creating a new one. 

 

Thanks again for posting, let me know if you have any other questions regarding this issue. 



Jordan Giboney
Technical Solutions Engineer | Media & Entertainment
Installation & Licensing forums | Contact product support | Autodesk AREA


Message 3 of 10

Hi again @vfxronin

 

I spoke with some of my team members about this issue a little further, and like I said before, this is a known limitation within Maya.

 

However, they did provide me with the following workaround: If you convert the particle shapes to mesh/polygons (using another one of your programs) beforehand, they should import into Maya. That being said, the scene will increase in size as meshing out the shapes creates more information within the file. 

 

I hope this workaround suits your workflow. Let me know if I can help with this issue any further!



Jordan Giboney
Technical Solutions Engineer | Media & Entertainment
Installation & Licensing forums | Contact product support | Autodesk AREA


Message 4 of 10
jordan.giboney
in reply to: vfxronin

hi @vfxronin

 

I wanted to check in and see if the information I provided answered your questions. If not, I would be happy to keep working with you until we find an answer. I am here to help 🙂

 

Have a great day, and best of luck with your projects.



Jordan Giboney
Technical Solutions Engineer | Media & Entertainment
Installation & Licensing forums | Contact product support | Autodesk AREA


Message 5 of 10

I know this is an old post, but I came across this issue myself and discovered the bug is in the alembic importer for maya. Turning on 'echo commands' you can see the command that runs is "emit -object particleShape1 ...". If the points you are importing are called 'particleShape1', they import correctly, but anything else will break.

 

Taking a look at the AbcImport for maya, the particle system is being created and the name set, but still fails, which suggests there is an issue in maya's MFnParticleSystem where the name is not being correctly set before emitting.

 

    MFnParticleSystem fnParticle;
    iObject = fnParticle.create(iParent, &status);
    fnParticle.setObject(iObject);
    fnParticle.setName(iNode.getName().c_str());

    MPointArray pArray;
    Alembic::Abc::P3fArraySamplePtr v3ptr = samp.getPositions();
    MVectorArray vArray;

    for (unsigned int pId = 0; pId < pSize; pId++)
    {
        pArray.append((*v3ptr)[pId].x,
                      (*v3ptr)[pId].y,
                      (*v3ptr)[pId].z);
    }

    status = fnParticle.emit(pArray);

 

I'll be submitting this as a ticket but as I came across this question I thought it worth posting here for anyone else that follows.

Message 6 of 10
vfxronin
in reply to: Mattalexshaw

It's a known bug for years aprently but as as to something to be done about . Well apparently the need to over hall the hole particula system. Know when that get done . How knows.

I personally gaive up and started using Houdini engine and v-ray porxy.

I personally just gaive up in Maya partical system and many others thing .

Sorry just a bit bitter about the hole thing
Message 7 of 10
Anonymous
in reply to: jordan.giboney

I'm trying to export alembic points through bifrost with geometry, based on already shared valley forest.
I managed to export points and geometry, but have this same error on trying to re-importing them in maya.
Just exporting single frame.
When I re-import them, I get one particle file without any particles.
Not trying to reinvent the wheel, but if anyone has any pointers, will be grateful.
The actual aim is to export geometries to UE.

Thanks

Message 8 of 10
mholeysovsky
in reply to: Anonymous

So I found a solution, but its really dumb that Maya requires this:
note: My goal was to export locators from Houdini to Maya. If you require rotation as well, you would need additional fiddling and it might be easier to use Houdini Engine for export (for that just save a hda with the file node inside and import it to Maya through Houdini Engine, the instancing steps are the same)


In Houdini:

* have only the points

* add the add node and in Particles tab check Add Particle System

* create a path attribute on the primitive, that ends in particleShape1/particleShape2, i.e. /particles/particleShape1/particleShape2/

* use csCache Alembic set to single frame to export the points

 

In Maya:

* create a locator (just one in the origin)

* switch to FX menus

* import the exported fxCache

note: it will only allow to import one particle cache, at a time. When you import second, it will be empty - sometimes deleting the current one will be enough to allow import new, sometimes you'll need a clean scene

To check if it impored, select the group and press F, if it shows you points its ok, if it just zooms to origin, its empty

* select the locator first, then the particle system in the imported hierarchy

* in nParticles menu click Instancer

* with the created instancer selected in MASH/Utilities click Bake Instancer to objects

 

Now delete everything except the group that just got created and youre done 😉

Message 9 of 10
sepu6
in reply to: vfxronin

Not need any of this anymore btw. Just use Bifrost Graph plus you get all attributes, etc. Also, you can just use the graph to do a lot of the same things that you usually do in H btw. 

Message 10 of 10
stigla
in reply to: sepu6

Some example of how would be helpful.

 

Thanks.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums