Maya Forum
Welcome to Autodesk’s Maya Forums. Share your knowledge, ask questions, and explore popular Maya topics.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

ADLSDK_STATUS_LICENSE_CHECKOUT_ERROR on MacOS. Cannot start Maya. How to register Maya 2020-2023 manually?

Message 1 of 7
1310 Views, 6 Replies

ADLSDK_STATUS_LICENSE_CHECKOUT_ERROR on MacOS. Cannot start Maya. How to register Maya 2020-2023 manually?

When attempting to open Maya, it bounces on the dock briefly and immediately stops opening, identically to how this troubleshooting page describes. However, none of the solutions were helpful. When opening through the Terminal, the output gives the error "ADLSDK_STATUS_LICENSE_CHECKOUT_ERROR". I've tried doing a clean install of the program, deleting all Autodesk-related files from my computer, but this did not help. The licensing software is up to date and running.

When running the command "sudo /Library/Application\ Support/Autodesk/AdskLicensing/Current/helper/AdskLicensingInstHelper list" as I found on this page, it only returned ARNOL, but not Maya. So this means that my system does not recognize Maya as being registered if I understand correctly. My question is, how do I "register" Maya on versions 2020+, or at least, how do I get Maya to recognize that it is? Because whatever automatic process it uses does not seem to be working as intended on my computer. If anyone knows of a manual way to register Maya 2020+, it would be greatly appreciated.

The version of MacOS I'm currently using is 10.14.6.
I am using a student license and I've gone through the entire student verification process successfully.

The Terminal output and log file are attached.

I have already looked at the links below, neither of which provided a working solution:

Apologies if I've made any formatting errors or anything, this is my first time on the Maya forums. I hope that one of you is knowledgeable enough to know the solution, because I've been banging my head against the wall about this for weeks now. Cheers.

Message 2 of 7
in reply to: choule3

The Maya installer should have registered Maya. I'd be worried about why that didn't happen.

This is an example of how you do it on the command line:

sudo /opt/Autodesk/AdskLicensing/Current/helper/AdskLicensingInstHelper register -pk 657N1 -pv 2022.0.0.F -el en_us -cf /var/opt/Autodesk/Adlm/Maya2022/MayaConfig.pit

// Stephen Blair
// Arnold Renderer Support
Message 3 of 7
in reply to: choule3

Oh my god, thank you so much, this worked with a bit of modification. I was wondering how to do a manual registration through the Terminal, but couldn't find anything online about it.

For anyone reading this in the future, or those curious, I modified the command to be this to work with Maya 2023 on my computer:

sudo /Library/Application\ Support/Autodesk/AdskLicensing/Current/helper/AdskLicensingInstHelper register -pk 657O1 -pv 2023.0.0.F -el en_us -cf /Applications/Autodesk/maya2023/adlmreg/MayaConfig.pit

 Honestly not sure why the automatic registration in the installer didn't work, but I've got it working now, thank you very much.

Message 4 of 7
in reply to: choule3

Hey there, does this apply to Maya 2024, too? I have troubles with the licensing service: it doesn't autostart at login, also it dies every now and then after quitting Maya.

Message 5 of 7
in reply to: choule3

I might be missing something if this procedure is changed for 2024. However I am getting an error:

Error (13) for adlmPITSetProductInformation_2: PRODUCTS information is not found

Any ideas why this is not working? 

Message 6 of 7

So I got this too when I entered a 2023 product code (-pk 65701 -pv 2024.0.0.F) instead of the 2024 product code (-pk 657P1 -pv 2024.0.0.F)

Unfortunately, this didn't help my situation either where I get this error message when I try and register the MayaConfig.pit... 2022.0.0.F was registered awhile back and works fine with an  AdlmThinClientCustomEnv.xml pointing to the Product Information.pit .. but I cant register 2023 or 2024 to authenticate and launch in the same way.

[root@license-server /opt/Autodesk/AdskLicensing/Current/helper]# ./AdskLicensingInstHelper register -pk 657P1 -pv 2024.0.0.F -el EN_US -lm NETWORK -cf /<network_share>/maya/maya2024/license_data/MayaConfig.pit
(500)(saving feature failed: [PIT] 24: Unable to locate the Product Information Table File.)
hint: might be caused by invalid feature for current pit file


Message 7 of 7
in reply to: Stephen.Blair

This is the correct line, after tested probably 15 different versions. Thanks so much

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators

Autodesk Design & Make Report