Community
Maya Animation and Rigging
Welcome to Autodeskโ€™s Maya Forums. Share your knowledge, ask questions, and explore popular Maya animation topics.
cancel
Showing results forย 
Showย ย onlyย  | Search instead forย 
Did you mean:ย 

Smooth Bind Not Influencing all Joints

2 REPLIES 2
SOLVED
Reply
Message 1 of 3
acornbringer
3225 Views, 2 Replies

Smooth Bind Not Influencing all Joints

Hey there!

 

When I smooth bind a mesh to a skeleton, sometimes it will ignore some joints. By adding the influence after the fact through Animation/Skin/Add Influence, it messes up the weights quite a bit I lose the benefit of the initial smooth bind being much cleaner. I was wondering if there was a way to insure maya considered the whole skeleton when I bind the weights.

 

I've tried selecting all the joints before binding but it still ignores those few joints.

 

Attached is a screenshot of my smooth bind settings.

 

Any insight would be appreciated ๐Ÿ™‚

 

-

 

Windows 10 Home 64-bit

Maya 2015 SP2

 

Intel Core i7-4771 CPU @ 3.50GHz (8 CPUs)
NVIDIA GeForce GTX 760

2 REPLIES 2
Message 2 of 3
Cagetron
in reply to: acornbringer

Try unchecking Remove Unused Influences.  When you do the default bind it's probably not assigning weight to those few joints for whatever reason so it just removes them as influences.  

 

Another tip, when you add an influence you can check "Lock Weights" and it will add the joint without messing up the weighting.  You can then unlock that newly added joint and carefully add weight to it.  

Message 3 of 3
acornbringer
in reply to: Cagetron

Awesome thanks!

 

That setting was my issue. And thanks for the tip about adding influence. The bind still doesn't add any influence but at least the joins still show in the Skin Weights Tool so I can add them myself or use the add influence like you suggested.

 

Thanks again!

 

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report