Communauté
Inventor - Français
Bienvenue sur les forums Inventor d’Autodesk. Partagez vos connaissances, posez des questions, collaborez sur des idées, et explorez les sujets Inventor populaires.
annuler
Affichage des résultats de 
Afficher  uniquement  | Rechercher plutôt 
Vouliez-vous dire : 

Inventor : Défaut affichage tracé à l'export PDF

13 RÉPONSES 13
RÉSOLU
Répondre
Message 1 sur 14
_QM_
404 Visites, 13 Réponses

Inventor : Défaut affichage tracé à l'export PDF

Bonjour à tou(te)s,

Je rencontre actuellement un défaut d'affichage à l'export de plans sous inventor.

J'ai une pièce réalisée avec une forme d'ellipse, je trace une esquisse dans la mise en plan pour représenter virtuellement le trajet d'ellipse sauf que dans la représentation du dessin, pas de soucis mais lors de l'export du plan PDF, l'ellipse n'a plus une forme d'ellipse mais est "cassée" par plusieurs lignes droites.

erreur de tracé.png
Je n'arrive pas à trouver d'où vient le problème...

Merci par avance pour votre aide 🙏


Le titre du sujet a été modifié par un modérateur pour faciliter la recherche. Titre original:
Défaut affichage tracé à l'export PDF

13 RÉPONSES 13
Message 2 sur 14
ThomasB44
en réponse à: _QM_

Salut @_QM_ 

Lors de l'export de ton plan en PDF, le plan est vectorisé. Les courbes sont transformées en une succession de droites. Leur définition dépend de leur taille sur le plan évidemment, mais surtout du format du plan, et du réglage de la résolution du vecteur en DPI lors de l'export. (cliquer sur options avant d'exporter)

En général, pour une bonne lecture, 300 DPI suffit. 600 DPI, si tu souhaites une lecture précise ou HD.

Pour des besoins particuliers, tu peux forcer la résolution jusqu'à 4800 DPI, mais attention si ça ralenti le processus d'export...

ThomasB44_0-1664462997300.png

 


Thomas
Mechanical Designer / Inventor Professionnal 2023
Inventor Professional EESignature

Message 3 sur 14
_QM_
en réponse à: ThomasB44

Merci pour cette solution qui aurait pu être pertinente mais je suis déjà en 1200dpi à l'export de mes plans.

Je viens de tester en 4800 DPI et le problème est toujours présent... 😐
Mes plans sont au format A3 et ma pièce est à l'échelle 30 : 1

Message 4 sur 14
ThomasB44
en réponse à: _QM_

Je suppose que tu as vérifié :

  • Pilotes carte graphique à jour
  • Adobe PDF à jour

Les 2 pourraient mener à ce résultat.


Thomas
Mechanical Designer / Inventor Professionnal 2023
Inventor Professional EESignature

Message 5 sur 14
_QM_
en réponse à: ThomasB44

Yes : 

  • Pilote carte graphique : Nvidia Studio 517.40 du 20/09/2022
  • Adobe Acrobat DC (64-bit) : à jour
Message 6 sur 14
Fabian_perree
en réponse à: _QM_

Bonjour @_QM_ ,

 

Même résultat en cochant l'option "Vue Raster" ?

En fermant et rouvrant l'IDW idem ?

En changeant d'imprimante PDF ?

 

Possible de nous transmettre un fichier simplifié dans lequel tu as l'erreur pour qu'on puisse la reproduire ?

 

Merci !

Fabian Perrée
Giùp.fr | LinkedIn

Ce post vous a été utile ? N'hésitez pas à aimer ce post.
Ce post a-t-il répondu à votre question ? Cliquez sur le bouton Accepter la solution.

EESignature

Cliquez ici pour accéder à toutes mes formations en ligne
Inventor 2022 : Modélisation et documentation de systèmes mécaniques
Message 7 sur 14
patrick.emin
en réponse à: _QM_

Bonjour @_QM_ 

Votre problème a-t-il été résolu? Si oui, pouvez vous nous indiquer de quelle façon pour que cela profite à la communauté, si non, pouvez vous nous apporter les précisions demandées de façon que nous puissions continuer à vous aider?

Si une des réponses résout votre problème ou vous a permis de mieux le comprendre, voulez vous avoir l'amabilité de cliquer sur le bouton  APPROUVER LA SOLUTION  en bas de la réponse qui apporte une solution?
Merci de ne pas accepter comme solution le message que vous êtes en train de lire.


Patrick Emin animateur de la communauté francophone


Vous avez trouvé un message utile? Alors donnez un "J'aime" à ce message!
Votre question a eu une réponse satisfaisante? Voulez vous avoir l'amabilité de cliquer sur le bouton
 APPROUVER LA SOLUTION  en bas de la réponse qui apporte une solution?
Signez notre Livre d'Or
Message 8 sur 14
_QM_
en réponse à: patrick.emin

Bonjour à tous,

Désolé pour mon délai de réponse.

Ci-joint les fichiers IPT + DWG + PDF d'un exemple similaire.

Le problème persiste toujours par contre j'ai constaté que si je passe les dimensions de 3-5mm à 10-15mm, le phénomène s'estompe.
Cela voudrait dire qu'il y a une limite d'échelle ?

Message 9 sur 14
Fabian_perree
en réponse à: _QM_

C'est un problème connu apparemment :

 

https://forums.autodesk.com/t5/forums/replypage/board-id/78/message-id/841079

 

En passant la vue en Raster j'ai corrigé le probléme, en pj.

 

Fabian_perree_1-1665402445345.png

 

 

 

Fabian Perrée
Giùp.fr | LinkedIn

Ce post vous a été utile ? N'hésitez pas à aimer ce post.
Ce post a-t-il répondu à votre question ? Cliquez sur le bouton Accepter la solution.

EESignature

Cliquez ici pour accéder à toutes mes formations en ligne
Inventor 2022 : Modélisation et documentation de systèmes mécaniques
Message 10 sur 14
_QM_
en réponse à: Fabian_perree

Merci pour ton retour mais dans mon cas malheureusement la vue Raster ne fonctionne pas (voir en PJ le PDF)

EDIT : petite précision je suis en 1200DPI

Message 11 sur 14
ThomasB44
en réponse à: _QM_

Salut,

J'ai ouvert tes fichiers exemple sur mon poste et je ne constate pas de problème sur ma version 2023, même en faible DPI.

Inventor a bien des limites de tailles, mais elles sont loin d'être atteintes dans ton cas :

https://knowledge.autodesk.com/fr/support/inventor/learn-explore/caas/CloudHelp/cloudhelp/2020/FRA/I...

 

On dirait un problème de conversion en PDF, puisque l'affichage est correct 😐

Lorsque tu utilises l'imprimante PDF, et non la commande Exporter sous PDF, le problème est identique ?


Thomas
Mechanical Designer / Inventor Professionnal 2023
Inventor Professional EESignature

Message 12 sur 14
_QM_
en réponse à: ThomasB44

Merci pour le retour.
Effectivement, en fonctionnant avec Imprimer et utilisant la commande "Microsoft Print to PDF" le problème disparait, merci ! 
Par contre on perd au niveau qualité du trait (si on zoom sur la vue 3D par exemple, c'est pixellisé et la couleur gris "floue").
C'est tout de même étrange, cela voudrait dire que l'exportateur PDF interne d'Autodesk n'est pas optimal ?

Message 13 sur 14
ThomasB44
en réponse à: _QM_

Oui, les vues en perspective sont mal gérées avec cette commande imprimer...il faut pousser la qualité de l'impression dans les paramètres de l'imprimante pour obtenir un résultat à peu près correct.

La feuille est complètement "aplatie", donc le résultat n'est pas aussi propre qu'avec la commande exporter. Je suis entièrement d'accord sur ce point.

 

Vu ce qu'a partagé Fabian, le problème semble similaire. Peut être le complément (si c'est bien lui ?!) qui permet d'exporter le dessin en PDF, en particulier avec les splines/ellipses, et sur la version 2021.

 


Thomas
Mechanical Designer / Inventor Professionnal 2023
Inventor Professional EESignature

Message 14 sur 14
patrick.emin
en réponse à: _QM_

Merci @_QM_ de marquer comme solutions approuvées les dernières réponses qui vous ont aidé.


Patrick Emin animateur de la communauté francophone


Vous avez trouvé un message utile? Alors donnez un "J'aime" à ce message!
Votre question a eu une réponse satisfaisante? Voulez vous avoir l'amabilité de cliquer sur le bouton
 APPROUVER LA SOLUTION  en bas de la réponse qui apporte une solution?
Signez notre Livre d'Or

Vous n'avez pas trouvé ce que vous recherchiez ? Posez une question à la communauté ou partagez vos connaissances.

Publier dans les forums  

Autodesk Design & Make Report