Community
Inventor Forum
Welcome to Autodesk’s Inventor Forums. Share your knowledge, ask questions, and explore popular Inventor topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Vault Properties not showing up in Inventor File Properties

6 REPLIES 6
Reply
Message 1 of 7
njt
Participant
1269 Views, 6 Replies

Vault Properties not showing up in Inventor File Properties

I'm using CNTRL-E to mass edit and change multiple properties in Vault Pro, but those changes to the properties do not show up in the Inventor .ipt file or parts list in an Inventor .idw file.

 

The Vault Category is configured correctly with the applicable properties assigned.

Mapped the properties in Vault thru Vault Settings/Behaviors/Properties/etc.

 

 Observation 1: In the Edit properties Dialogue box, on the Mapping Tab, even though I only have one mapping, down below on the Where Used Tab, it lists 2 File Entities, the one on top has the double arrow (Synchronize values between Vault property and file property), and the one below has the (Extract value from source file and writes into the Vault property) The arrows are grayed out so I couldn't reorder them if I wanted to. Why would I have only one mapping but then get these two entities? This happened the first time I created this new property, so I deleted the mapping and started over and the same two entities popped up again?

 

Observation 2: I can open a .ipt file in IV. Open up iProperties/Custom Tab, and it will show no properties.  But then if I open up iPropWiz, it will list all the properties, but they will be blank. Looking at my other screen with Vault, you can clearly see all the properties filled in.  If I hit Apply in iProp Wiz, THEN go to iProperties/Custom Tab, it is now populated with the Name of the properties, but they are all still blank.  If I then manually type the properties into either iProperties/Custom tab OR thru the iPropWiz (ive done both ways), and then save and check in the file, THEN those values now show up in Vault.

 

Now if I then CNTRL-E, change a property value in Vault, then immediately open up that file in IV, it doesn’t show the property updated.  If I click Update Properties nothing happens.  If I open up iPropWiz, its not updated.  It is only when I click on the iProperties icon that the message ‘file has been updated outside the current session’ message. I click Yes and then the properties are updated.

 

Thanks for help.

6 REPLIES 6
Message 2 of 7
bob_holland
in reply to: njt

@njt Welcome back to the Inventor forum.

If local Vault workspace is empty and you do a get on the file that you changed the properties, Does that file that get downloaded not have to correct properties?

 

Thank you.


Bob Holland
Autodesk Product Support
Message 3 of 7
njt
Participant
in reply to: bob_holland

I did as you suggested.  That did not work.  I did look at other “out of the box” UDP’s, such as ‘Authority’ and if you click on the ‘Inventor Mapping’, down below in the Where used section there is only one Bi-Directional mapping.

 

Authority iProperty.png

 

But if I click on the new UDP that I created ‘File ID’, then down below in the Where Used tab it displays two File Entities.  One bi-directional, and one File to Vault write. Why? Could this be causing the confusion? I click on the File to Vault entity but cannot delete it? I then deleted the mapping and chose another file to map to, same thing happened, as soon as I clicked OK to accept the new mapping, two entities popped up in the Where Used section.

 

File ID iProperty.png

 

 

Message 4 of 7
njt
Participant
in reply to: njt

Did the reply above go thru?

Message 5 of 7
njt
Participant
in reply to: njt

Matt,  

 

Tried sending you message but Autodesk said I reached my limit?? (one per week?)

 

It DOES appear that I can create a NEW property and map the Inventor File Property to the Vault File Property.

So I used that same logic on the old FILE ID property that had 2 entities.  Deleted those and remapped as you showed me.  But Vault is still not syncing.  It only does if I open up the individual part file and update the iProperty in that file explicitly, then check file back into Vault.

But I have 22,000 files and I shouldn't have to open up one by one to get the properties to sync?

 

Here you can see the ONE file that I manually updated the 'File ID (BACKUP)'.  All the rest are blank.  Even though all those files have a value in Vault. (you can also see all the new test properties I was making and they all show up perfectly)

Vault File ID prop still not showing up.JPG

Message 6 of 7
reidmatthew
in reply to: njt

@njt 

Thanks for the reply and extra info about the Create = Yes options. For others, here are a couple of links to info on this:



I am not sure or aware of any limit on the number of messages or replies users can send in the forums. I have brought that to the attention of the community forums team.

Here are a few things to look into around why the Vault property (UDP) values are not being written down to the Inventor files for existing iProperties and UDPs.

  1. Have you tried to use the Actions > Synchronize Properties command in Vault? Select a file that you want to synchronize. Then choose Actions > Synchronize Properties. That should look at the Vault property mappings and take the Vault value and write it down to the Inventor file properties based on the mapping definitions.
  2. Have you looked at the category assignments or other suggestions in this article https://knowledge.autodesk.com/support/autocad/troubleshooting/caas/sfdcarticles/sfdcarticles/Vault-...
  3. Another option that may work is to use the Inventor Task Scheduler to process a large batch of Inventor files. The Task Scheduler can check files out and back in to Vault in the background so you don't have to do it manually one by one. I would suggest you try this with a single file first to see if the process works as expected and the property values are written. Then you could ramp up to a larger set and process them overnight or the weekend, for example.

 

Let me know what you find out.



Matt R.
Product Support Specialist, Data Management


Message 7 of 7

check out assembly with all sub level parts. then update properties then it will synch...

include below setting to update include childrens.

 

manjunathmarulasiddappa_0-1658993450494.png

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums