Inventor Forum
Welcome to Autodesk’s Inventor Forums. Share your knowledge, ask questions, and explore popular Inventor topics.
This page has been translated for your convenience with an automatic translation service. This is not an official translation and may contain errors and inaccurate translations. Autodesk does not warrant, either expressly or implied, the accuracy, reliability or completeness of the information translated by the machine translation service and will not be liable for damages or losses caused by the trust placed in the translation service. To translate this discussion, select the language.

Inventor Forum

Reply
Post 1 of 24
Accepted Solution

Inventor 2013 - missing dimensions in drawing

4625 Views, 23 Replies
05-16-2012 01:31 PM

While working with an Inventor 2013 *.idw some of the dimension lines, extension lines, and learders became invisible, even though you can still see the dimension values and even the arrow heads of the no-show dimensions.  Even when printed, the same lines are not there.  2013 Glitch???  And when is the first HotFix coming out??

Guys,

 

I think I have found an explanation for what you are seeing.

This is actually as designed and is the result of the text clipping around hatches and dimensions that we implemented in 2013. See the wiki help:

http://wikihelp.autodesk.com/Inventor/enu/2013/Help/0000-What_s_N0/0001-What_s_N1/0058-Drawing58/0063-Cross_li63

 

The easiest way to explain why this happens is to look at this screenshot.
Dimensions sitting within the area designated by the green dots, will be clipped.

To avoid the issue , use smaller textboxes  or create the larger (empty) textboxes inside a draft view.

 

 

Cheers

Bob

Re: Inventor 2013 - missing dimensions in drawing

05-21-2012 01:08 AM in reply to: psohaney

Hi,

 

Can you send us the model and the corresponding drawing to investigate further.



Vinod Balasubramanian
AutoCAD Mechanical Technical Lead

Post 3 of 24

Re: Inventor 2013 - missing dimensions in drawing

05-22-2012 08:03 AM in reply to: VinodBalasubramanian
Here is the model, and the drawing. When some dimensions’ extension lines, dimension lines, etc, disappear from view. Don’t even print. *--* *PATRICK S. SOHANEY** **|** **Process Engineer* *REVSTONE INDUSTRIES, LLC* *MPI International, LLC* *Indiana** Fineblanking Division* 1200 Klöckner Drive Knox, IN 46534 OFFICE 574.772.3850 ext. 1335 FAX 574.772.2533 www.revstone.com
Note: To view our e-mail disclaimer please click here.
Post 4 of 24

Re: Inventor 2013 - missing dimensions in drawing

05-22-2012 08:15 AM in reply to: VinodBalasubramanian

Seems that when I move a dimension around, one or both of the extension lines and sometimes the dimension line disappear; you can still see the arrow head and dimension though.  I've played around a little while waiting (for 2013's first service pack... hint-hint-hint...), and noticed when I right-click and hide one of the (already hidden) extension lines, then right-click again and select "Show All Extension Lines", everything pops back one as normal.  But once you move the dimension around again, things disappear as before.

Post 5 of 24

Re: Inventor 2013 - missing dimensions in drawing

05-22-2012 09:40 AM in reply to: psohaney

You're file didn't attach to the thread.

Mike (not Matt) Rattray

Post 6 of 24

Re: Inventor 2013 - missing dimensions in drawing

05-22-2012 09:59 AM in reply to: mrattray

ACH! I shouldn't have replied to this thread. Now I caught the contagion, too!

 

I went to do some dimensioning for the first time in 2013 and look what I get! Lucky me. I tried the same thing psohaney said he tried, setting the ext line to hidden and then setting all ext lines visible and like him as soon as I moved it they disappeared again.

 

Some playing around has revealed that it's tied to a view being stuck in raster state. I was able to reproduce it by following the exact same steps as I used to create the first drawing. Making a different drawing on a different template with a different (much simpler) file did not reproduce it.

 

I'll play around with it and see if I can nail down exactly what the connection is here.

 

Mike (not Matt) Rattray

Re: Inventor 2013 - missing dimensions in drawing

05-22-2012 09:49 PM in reply to: mrattray

Hi Guys,

 

I tested the same and couldn't able to reproduce it. Probably need a video demonstrating on what's happening at your end. This would help us to investigate further.



Vinod Balasubramanian
AutoCAD Mechanical Technical Lead

Re: Inventor 2013 - missing dimensions in drawing

05-30-2012 07:42 PM in reply to: VinodBalasubramanian

Hi Guys,

 

I am working with our development on this. Can you provide a short video and as well as the problematic drawing file for us to do further testing at our end.

 

Looking forward to your replies.



Vinod Balasubramanian
AutoCAD Mechanical Technical Lead

Post 9 of 24

Re: Inventor 2013 - missing dimensions in drawing

05-31-2012 05:03 AM in reply to: VinodBalasubramanian

Here's a simple drawing file where I was able to replicate the problem. It seems to be tied to one of my migrated templates. I'll try to find time later in the day to make a video for you.

Mike (not Matt) Rattray

Post 10 of 24

Re: Inventor 2013 - missing dimensions in drawing

05-31-2012 07:57 AM in reply to: mrattray

Here's a video of it: http://s677.photobucket.com/albums/vv131/Diabolus_/Inventor/?action=view¤t=extlinevideo.mp4

It's not reliant on any combination of steps and is very easy for me and my users to reproduce, but only on that one template (posted previously).

 

 

Mike (not Matt) Rattray

Re: Inventor 2013 - missing dimensions in drawing

05-31-2012 06:21 PM in reply to: mrattray

Hi Matt,

 

I couldn't able to reproduce the problem. See below screenshot. Since you are using a custom template, can you share that with us for further testing.

 

Also please check with different options for graphics under Application options -> Hardware tab to see whether you can reproduce the same behavior.

 

Let me know your test results.



Vinod Balasubramanian
AutoCAD Mechanical Technical Lead

Post 12 of 24

Re: Inventor 2013 - missing dimensions in drawing

06-01-2012 04:58 AM in reply to: VinodBalasubramanian

I played around with the options in the hardware tab and still was reproducing the problem with every combination of options.

 

In the file set that I posted earlier in this thread the glitch only presents in the right view, the top view dimensioned OK.

 

Find the problem template and my application options export attached.

Mike (not Matt) Rattray

Re: Inventor 2013 - missing dimensions in drawing

06-03-2012 08:25 PM in reply to: mrattray

Hi Matt,

 

I tried with your template and the same application options settings. I couldn't able to reproduce the behavior on my end. It looks more of a graphic issue at the moment.

 

Have you tried switching your graphics options in the hardware tab under application options. Can you able to reproduce the same problem ?



Vinod Balasubramanian
AutoCAD Mechanical Technical Lead

Post 14 of 24

Re: Inventor 2013 - missing dimensions in drawing

06-04-2012 04:53 AM in reply to: VinodBalasubramanian

mrattray wrote:
I played around with the options in the hardware tab and still was reproducing the problem with every combination of options.

 

Mike (not Matt) Rattray

Re: Inventor 2013 - missing dimensions in drawing

06-04-2012 07:52 PM in reply to: VinodBalasubramanian

Can you confirm whether you have installed a certified graphic card driver for Inventor. If not you can download them from the link below,

 

http://usa.autodesk.com/adsk/servlet/syscert?id=18844534&siteID=123112



Vinod Balasubramanian
AutoCAD Mechanical Technical Lead

Post 16 of 24

Re: Inventor 2013 - missing dimensions in drawing

06-05-2012 04:40 AM in reply to: VinodBalasubramanian

I don't have control over our hardware here and the IT dept. thinks that workstation grade hardware is unnecessary. I'm stuck with a gaming card, AMD Radeon HD 6670, with no available certified drivers.

Mike (not Matt) Rattray

Highlighted
Post 17 of 24

Re: Inventor 2013 - missing dimensions in drawing

06-06-2012 11:20 AM in reply to: mrattray

Guys,

 

I think I have found an explanation for what you are seeing.

This is actually as designed and is the result of the text clipping around hatches and dimensions that we implemented in 2013. See the wiki help:

http://wikihelp.autodesk.com/Inventor/enu/2013/Help/0000-What_s_N0/0001-What_s_N1/0058-Drawing58/006...

 

The easiest way to explain why this happens is to look at this screenshot.
Dimensions sitting within the area designated by the green dots, will be clipped.

To avoid the issue , use smaller textboxes  or create the larger (empty) textboxes inside a draft view.

 

 

Cheers

Bob




Bob Van der Donck


Principal UX designer DMG group
Post 18 of 24

Re: Inventor 2013 - missing dimensions in drawing

06-06-2012 11:26 AM in reply to: bobvdd

I think you got it, Bob! Thanks! I'd mark it as solution but, I'm not the OP.

 

Note to self: avoid unneccessarilay massive text boxes.

 

Thanks again, Bob!

Mike (not Matt) Rattray

Post 19 of 24

Re: Inventor 2013 - missing dimensions in drawing

04-30-2013 01:27 PM in reply to: bobvdd

Bob, your post made my day. I was in a rush to get some drawings out for quotes and kept having the disappearing leader/dimension problem. When I moved an adjacent text box, after reading your post, the issue resolved. So the cause is overlapping text boxes and is easy to fix.

Regards, Bill

Post 20 of 24

Re: Inventor 2013 - missing dimensions in drawing

04-30-2013 01:36 PM in reply to: billmace6

Thanks Bill for confirming the solution!

Always good to get positive reaction to a post that was made almost a year ago.

Just an extra proof of the benefit of this newsgroup.

Bob




Bob Van der Donck


Principal UX designer DMG group
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post