Community
Inventor Forum
Welcome to Autodesk’s Inventor Forums. Share your knowledge, ask questions, and explore popular Inventor topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Importing application options doesn't actually update them

4 REPLIES 4
SOLVED
Reply
Message 1 of 5
snappyjazz
196 Views, 4 Replies

Importing application options doesn't actually update them

I have exported my application options to share with another cad user. Things like Content Center Access Options(to Vault Server), and iFeature user root directory. However when I import these options on the other computer, they don't get updated. I get the below dialogs when I click "apply" after importing. I've restarted Inventor after importing, but I still don't have updated Application Options. Am I doing something wrong or is there a problem here?

 

snappyjazz_0-1706656082362.png

 

 

snappyjazz_1-1706656097059.png

 

One of the settings I want to change:

snappyjazz_2-1706656160572.png

 

Labels (2)
4 REPLIES 4
Message 2 of 5
pcrawley
in reply to: snappyjazz

I think you need to switch Projects rather than restart Inventor.

 

Import the Application Options - Go to Projects - switch to a different Project - switch back to current Project - Check App Options.

Peter
Message 3 of 5
snappyjazz
in reply to: pcrawley

@pcrawley Thanks for replying. Unfortunately that didn't work. Does that work for you? I'm using 2022. What version are you using?

Message 4 of 5
pcrawley
in reply to: snappyjazz

Hi @snappyjazz - sorry for the late reply.  It does work for me, but I'm using 2023 and 2024.

 

If importing the settings doesn't work, then it is probably related to the user's permissions in Windows.  Application options are stored in the registry, and the user may have insufficient permission to write the changes.

 

Try right-clicking the Inventor icon and using "Run as administrator" - import the settings - restart Inventor (again using "Run as administrator") and see if the changes remained.  If they did, then the problem is the user's permissions.

Peter
Message 5 of 5
snappyjazz
in reply to: pcrawley

@pcrawley I ran inventor as admin like you said and I still couldn't update as intended. But something that you said gave me an epiphany. When you said "stored in registry", I remembered that Inventor is finicky about where info is accessed from. Long story short, I moved my exported xml to the default location: C:/users/.../AppData/AutoDesk/Inventor 20XX/Preferences. When I imported from there, the application options updated! 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report