Community
Inventor Forum
Welcome to Autodesk’s Inventor Forums. Share your knowledge, ask questions, and explore popular Inventor topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

.iam to .dwg incorrect material assignment

6 REPLIES 6
Reply
Message 1 of 7
james.collinsPWQR2
189 Views, 6 Replies

.iam to .dwg incorrect material assignment

Hi All,

 

I have exported an .iam file to .dwg and plan to use the solids Material property in ACAD to assign layers.

jamescollinsPWQR2_2-1717455928499.png

The problem I have run into however, is that sometimes the material is assigned incorrectly. For instance the material on all of the stiffeners should be "3DF-STIFFENER", but this one randomly was assigned to "polycarbonate - Clear". From a 200 part assembly, about 5% of the solids have had their Material incorrectly assigned.

jamescollinsPWQR2_0-1717455561278.png

Has anyone had this happen when exporting from iam to dwg, and if so is there a fix?

 

Thanks,

 

James

6 REPLIES 6
Message 2 of 7

Hi James,

 

I vaguely remember seeing a corruption case like this before. But I honestly do not remember the exact detail and how it was resolved. If possible, please share the files that exhibit the behavior. I would like to understand the material style assignment issue better.

Many thanks!



Johnson Shiue (johnson.shiue@autodesk.com)
Software Test Engineer
Message 3 of 7

Hi Johnson,

 

Thanks for the quick reply, I just sent you the files via email.

 

Thanks,

 

James

Message 4 of 7

Hi! James did send the files! Without disclosing the detail, I can comment as such. It seems that there are corrupted appearance styles and material styles leading to such erratic export behavior. Maybe the unused styles need to be purged (Manage -> Styles Editor -> Purge -> check "Purge subcomponent styles").

Many thanks!



Johnson Shiue (johnson.shiue@autodesk.com)
Software Test Engineer
Message 5 of 7

Morning Johnson,
 
I wouldn't be surprised if an appearance style was corrupt as I was running an iLogic rule that assigns appearances from the favourites list.
 
Unfortunately the workaround didn't seem to help on my machine, did it work on yours?
 
Thanks,
 
James
Message 6 of 7

Hi James,

 

Please send me an email showing which exact frame member still carries the wrong material style in the dwg file exported from Inventor.

Many thanks!

 



Johnson Shiue (johnson.shiue@autodesk.com)
Software Test Engineer
Message 7 of 7

For anyone interested we weren't able to find the root issue, but I will update this space if anything changes.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report