Installation & Licensing
Welcome to Autodesk’s Installation and Licensing Forums. Share your knowledge, ask questions, and explore popular Download, Installation, and Licensing topics.

Installation & Licensing

Reply
Post 21 of 36

Re: FLEXnet Licensing errors

06-12-2013 08:27 AM in reply to: jneal

Jess,

 

You need to stop all of the services, then update the license manager with 11.11 version... then restart the service through LMTOOLS...

 

Here's the link again:

http://usa.autodesk.com/adsk/servlet/ps/dl/item?siteID=123112&id=10976858&linkID=9240618



If this information was helpful, please consider marking it as an Accepted Solution by using the Accept as Solution


Post 22 of 36

Re: FLEXnet Licensing errors

06-12-2013 09:35 AM in reply to: Darin.Green

Ok...  I'm starting from scratch... I deleted all traces of NLM files and exe's from my server. Uninstalled network license manager via add remove programs. Rebooted. 

 

When i go look into services i still have a "Flexlm Service 1". It is not started.

 

Should I still have that if everything has been uninstalled?

 

Win Server 2008 R2 FYI

 

Jess

 

Application Engineer
All CAD Northwest
Meridian ID
Post 23 of 36

Re: FLEXnet Licensing errors

06-12-2013 10:50 AM in reply to: jneal
Yes. Delete the service from LMTOOLS if you wanna remove that.
Post 24 of 36

Re: FLEXnet Licensing errors

06-12-2013 10:54 AM in reply to: jneal

Yes, because the license manager was probably installed on that machine and all you did was delete the files from the directory without uninstalling from Add/Remove Programs.

 

Regardless of that service still being there, once you install the updated license manager, enter a new name for the service on the Config Services tab then fill in the other information and click save service. This will avoid using the default (old) FlexLM Service 1 service.



If this information was helpful, please consider marking it as an Accepted Solution by using the Accept as Solution


Post 25 of 36

Re: FLEXnet Licensing errors

06-12-2013 01:04 PM in reply to: Darin.Green

Now I cant get it to work at all even after a reboot.... 

 

Here's what I did:

 

  1. uninstalled everything via add/remove programs
  2. deleted extraneous files/folders via explorer
  3. reboot
  4. installed nlm11.11_ipv4_win64.exe
  5. configured a new service called "All CAD Flex1"
  6. started the server

 

 

Info:


---------
Version
---------
FLEXnet Licensing v11.11.0.0 build 106800 x64_n6 (lmgr.lib), Copyright (c) 1988-2012 Flexera Software LLC. All Rights Reserved.



 

Here's the same winsock error I keep getting. 


--------
Status
--------
Flexible License Manager status on Wed 6/12/2013 14:10

[Detecting lmgrd processes...]
License server status: 27000@master
License file(s) on master: C:\allcadnw\IT\License Manager\master.lic:

master: license server UP (MASTER) v11.11

Vendor daemon status (on master):

adskflex: Cannot connect to license server system.
The license server manager (lmgrd) has not been started yet,
the wrong port@host or license file is being used, or the
port or hostname in the license file has been changed.
Server name: 192.168.10.5
License path: 27000@master;
FLEXnet Licensing error:-15,10. System Error: 10061 "WinSock: Connection refused"
For further information, refer to the FLEXnet Licensing documentation,
available at "www.flexerasoftware.com".

 




It says lmgrd has not been started but there are (2) instances of it in task manager showing. 

 

I'm at a loss here guys. Not sure if there is some sort of registry magic i need to do to do a clean uninstall..

 

Again thanks for the help eveyrone-

 

Jess

 

Application Engineer
All CAD Northwest
Meridian ID
Post 26 of 36

Re: FLEXnet Licensing errors

06-12-2013 01:09 PM in reply to: jneal

does the license file info match to what the license manager see as far as mac address and server name?

can you try disabling the firewall or allow these ports through?

TCP ports 2080 (for the adskflex vendor daemon)
TCP ports 27000 to 27009 (for the lmgrd master daemon)

Post 27 of 36

Re: FLEXnet Licensing errors

06-12-2013 01:19 PM in reply to: jneal

Definitely do what Darren recommends.  What is your server OS?

Post 28 of 36

Re: FLEXnet Licensing errors

06-12-2013 01:26 PM in reply to: TravisNave

Win Server 2008 R2 x64

 

Application Engineer
All CAD Northwest
Meridian ID
Post 29 of 36

Re: FLEXnet Licensing errors

06-12-2013 01:29 PM in reply to: DarrenP

Here's a screen shot while i am attempting to open ports up. Everything matches as far as i can tell...

 

Application Engineer
All CAD Northwest
Meridian ID
Post 30 of 36

Re: FLEXnet Licensing errors

06-12-2013 01:31 PM in reply to: jneal

delete the 27000 you don't need this

Post 31 of 36

Re: FLEXnet Licensing errors

06-12-2013 01:38 PM in reply to: DarrenP

DarrenP wrote:

delete the 27000 you don't need this


Done...

 

So It is now up and running again. I added exceptions for 2080, 27000 and for the 4 exe's as well. I'll report back if its not running again. 

 

I still have 2 lmgrd.exe's running in task manager for some reason. One is 1808k and the other is 4608k. Not sure why...

 

Jess

 

Application Engineer
All CAD Northwest
Meridian ID
Highlighted
Post 32 of 36

Re: FLEXnet Licensing errors

06-12-2013 02:13 PM in reply to: jneal

jneal wrote:

DarrenP wrote:

delete the 27000 you don't need this


Done...

 

So It is now up and running again. I added exceptions for 2080, 27000 and for the 4 exe's as well. I'll report back if its not running again. 

 

I still have 2 lmgrd.exe's running in task manager for some reason. One is 1808k and the other is 4608k. Not sure why...

 

Jess

 


Yes, that is normal. 

Post 33 of 36

Re: FLEXnet Licensing errors

06-12-2013 02:18 PM in reply to: TravisNave

i just noticed this on ours to

so yes this seems to be normal

Post 34 of 36

Re: FLEXnet Licensing errors

06-12-2013 02:31 PM in reply to: DarrenP

Thanks again guys for your help. I really appreciate it...

 

I'm going to mark the post with the port exceptions as the answer...

 

Jess

 

Application Engineer
All CAD Northwest
Meridian ID
Post 35 of 36

Re: FLEXnet Licensing errors

06-12-2013 02:32 PM in reply to: jneal

 


jneal wrote:

Thanks again guys for your help. I really appreciate it...

 

I'm going to mark the post with the port exceptions as the answer...

 

Jess

 


your welcome
you may want to wait a few days to see if it happens again before marking it as a solution

Post 36 of 36

Re: FLEXnet Licensing errors

06-14-2013 07:02 AM in reply to: DarrenP

DarrenP wrote:

 your welcome

you may want to wait a few days to see if it happens again before marking it as a solution

 

Still running strong fellas.. I'll mark a solution now. Thanks again for your help-

 

Jess

 

Application Engineer
All CAD Northwest
Meridian ID
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post