Installation & Licensing
Welcome to Autodesk’s Installation and Licensing Forums. Share your knowledge, ask questions, and explore popular Download, Installation, and Licensing topics.

Installation & Licensing

Reply
Highlighted
Post 1 of 15
Accepted Solution

FLEXnet License Administrator - getting clients to see server

5538 Views, 14 Replies
07-05-2012 03:19 PM

I'm trying to get a networked Autocad environment set up in my bureau; we've never had one before, and I'm not an Autocad user.

 

I already had a FLEXnet License Administrator running for another product, so followed the setup instructions for adding Autcad.  I was able to do that, and I believe it is functioning properly.  However, I must be doing something wrong on the client end, as I have not been able to get Autcad 2013 to take a license.  I've been trying to figure out what I need to do on the client end to let Autocad know that I'm using the FLEXnet License Administrator.  Suggestions?

 

I've downloaded the Autocad 2013 executable, and installed it, telling it to use the network option.  I've identified the server to it (WBWISEINT).  I was getting a 15.570.10035 error message, so looked that up and added two variables to my client machine - ADSKFLEX_LICENSE_FILE = @WBWISEINT  and FLEXLM_TIMEOUT = 1000000.  Adding those only succeeded in changing the error message to 15.570.0.  I've located the licpath.lic file in my Program FIles/Autodesk/Autocad 2013 folder, and it did not show the correct physical address, so I updated it.  That didn't change the error message.

 

When I start up Autocad 2013, a FLEXnet License Finder dialog box comes up.  I've tried both options - Specify the License Server System (I tried \\wbwiseint, "WBWISEINT" and "10.106.250.207) and Specify the License FIle (path to a copy of ACD2013enlicense.lic), and the screen returns with "A valid license could not be obtained by the network license manager.  Error [-15.570.0]. 

 

Server is running Windows Server 2008, and the client machine is running Windows XP sp3.

I downloaded the Autocad 2013 software and installed the network version of it. There had never been Autocad on this client computer before. When I tried running it, I got an error message "A valid license could not be obtained by the network license manager Error [-15.570.10035]". I looked that up, and found references to the need for two variables (ADSKFLEX_LICENSE_FILE, FLEXLM_TIMEOUT), which I added to my client machine. I have tried ADSKFLEX_LICENSE_FILE set to "@wbwiseint","@ \\wbwiseint, and "@10.106.250.207". When I ran it again, I got the error message "A valid license could not be obtained by the network license manager Error [-15.570.0]". I should mention that it always comes up with "FLEXnet License Finder" window. I've tried "Specify the License Server System" and I've tried "Specify the License File". Either way, it comes back with the error noted above. I've also looked at the licpath.lic file. When I opened it, the server's address was not correct, so I changed that. It was 0000000000 and I changed it to 005056893fad. That didn't help.
Post 2 of 15

Re: FLEXnet License Administrator - getting clients to see server

07-06-2012 06:25 AM in reply to: bobgoldie

This is almost always attributed to a firewall issue or IPv6.  First make sure your NLM is running and the status enquiry shows licenses are available.

 

For more information about Network License Manager connectivity issues and IPv6, please see this discussion post here:
http://forums.autodesk.com/t5/Installation-Licensi​ng/Network-License-Error-1-5-15-and-IPv6/td-p/298...

 

Make sure the fireall is off or exceptions are made for the 4 .exe files and/or ports 27000 and 2080.  You can verify this by using IE by typing:

 

http://servername:2080

http://servername:27000

 

You should get a result of:

 

Wê-60Wê-60Wê-60Wê-60Wê-60Wê-60

 

Let me know what you find.

Post 3 of 15

Re: FLEXnet License Administrator - getting clients to see server

07-06-2012 08:09 AM in reply to: bobgoldie

If the server is Server 2008 R2 and you are running the 11.9 or 11.10 license manager, you may need to downgrade to 11.7.  The adskflex.exe has known to be problematic on R2.  But 11.7 seems to work well. 

Post 4 of 15

Re: FLEXnet License Administrator - getting clients to see server

07-06-2012 09:41 AM in reply to: TravisNave
Thank you. We are running R2 and 11.10. It's possible that port 27000 isn't open, so we'll try that first. If that doesn't work, then I'll try going down to 11.7.
Post 5 of 15

Re: FLEXnet License Administrator - getting clients to see server

07-06-2012 10:27 AM in reply to: bobgoldie

Keep me posted.  I was able to get 11.10 working on R2 the majority of the time.  But 11.9 rarely ever worked.  But I have yet to see 11.7 fail in the same fashion as 11.9 did and 11.10 sometimes does. 

Post 6 of 15

Re: FLEXnet License Administrator - getting clients to see server

07-09-2012 02:04 PM in reply to: TravisNave
One of the actions I was told to try was to ensure that ports 2080 and 27000 are open. This could be tested by typing in http://wbwiseint:2080 into Internet Explorer. I tried that, and got the results they said to expect (W?-60W?-60W?-60W?-60W?-60W?-60). However, when I did the same thing to port 27000, it wouldn't work. I typed "W?-60W?-60W?-60W?-60W?-60W?-60" into the browser search to find out more about what this means. It brought me to another autocad email (6.6.2011; General Licensing: Using Internet Explorer to check if the ports used for licensing are open), and this one said that Port 2080 is for adskflex and Port 27000 is for lmgrd. As I understand it, I'm using adskflex and not lmgrd, correct? So I don't need to worry about port 27000 failing? Of course, that means I still don't know what is preventing this from working properly. I'm pretty sure that the software is running on the server. Here's a screen capture of what I can see when I log in, which leads me to believe it is something on the client end. Your thoughts?
Post 7 of 15

Re: FLEXnet License Administrator - getting clients to see server

07-09-2012 02:06 PM in reply to: bobgoldie

nothing was attached

Post 8 of 15

Re: FLEXnet License Administrator - getting clients to see server

07-09-2012 02:20 PM in reply to: bobgoldie

Both need to be open.  LMGRD is the master daemon.  ADSKFLEX is the vendor daemon. It is possible that your license file may have changed the master daemon port to something other than 27000.  For example, if you have a redundant server, it might be using 27005.  The header of the license file should show this.  If there is nothing listed, it is default 27000.  Chances are it is being firewall blocked.

 

Post 9 of 15

Re: FLEXnet License Administrator - getting clients to see server

07-09-2012 02:34 PM in reply to: TravisNave

what error are you getting on the client side?

is it still the -15 error?

Post 10 of 15

Re: FLEXnet License Administrator - getting clients to see server

07-09-2012 03:18 PM in reply to: DarrenP
I downloaded the Autocad 2013 software and installed the network version of it. There had never been Autocad on this client computer before. When I tried running it, I got an error message "A valid license could not be obtained by the network license manager Error [-15.570.10035]". I looked that up, and found references to the need for two variables (ADSKFLEX_LICENSE_FILE, FLEXLM_TIMEOUT), which I added to my client machine. I have tried ADSKFLEX_LICENSE_FILE set to "@wbwiseint","@ \\wbwiseint, and "@10.106.250.207". When I ran it again, I got the error message "A valid license could not be obtained by the network license manager Error [-15.570.0]". I should mention that it always comes up with "FLEXnet License Finder" window. I've tried "Specify the License Server System" and I've tried "Specify the License File". Either way, it comes back with the error noted above. I've also looked at the licpath.lic file. When I opened it, the server's address was not correct, so I changed that. It was 0000000000 and I changed it to 005056893fad. That didn't help.
Post 11 of 15

Re: FLEXnet License Administrator - getting clients to see server

07-10-2012 08:24 AM in reply to: bobgoldie

The ADSFLEX_LICENSE_FILE overrides the LICPATH.LIC.  You only need to put @SERVERNAME (or in yoru case @wbwiseint) as the value assuming the connection to DNS uses IPv4.  Changing the LICPATH.LIC MAC entry does nothing because it is only used to point to the hostname.  Thus 000000000000 is default and is irrelevant. 

 

Make sure that you can PING your NLM server.  Make sure it is IPv4.  Make sure that you can test the connection on both 2080 *and* 27000 with the IE links.  You may need to make exceptions for the four NLM .exe files as well as ports 2080 and 27000. 

 

http://wbwiseint:2080

http://wbwiseint:27000

 

Also make sure that the NLM is actually running and that the status enquiry shows that licenses for your product are available.  You are welcomed to post your status results here.

Post 12 of 15

Re: FLEXnet License Administrator - getting clients to see server

07-10-2012 11:33 AM in reply to: TravisNave
What I know: 1. I can ping wbwiseint. 2. IPv6 is enabled. 3. I get the correct message when I type http://wbwiseint:2080 into Internet Explorer. 4. I do not get the correct message for 27000. 5. The service lmadmin is running. 6. I can open FLEXnet License Administrator, and it shows adskflex as an option, and shows 3 licenses available. 7. The system information for FLEXnet shows the License Server Manager Port in Use to be 7788, not 27000. 8. This is because there are two applications (Autocad, Synergee) using FLEXnet License Administrator, and the other application specifically mentions 7788. Synergee uses a vendor port of 7789. So there seem to be at least 3 things different. I'm running IPv6, I don't get the message for 27000, and FLEXnet is probably using port 7788 anyway. Does that mean I need a license file that specifically mentions 7788?
Post 13 of 15

Re: FLEXnet License Administrator - getting clients to see server

07-10-2012 11:46 AM in reply to: bobgoldie

Not necessarily.  You should be able to add 27000 to the end of the first line of your license file then save and reread it.  That should force the master daemon to use 27000 at least for the ADSKFLEX vendor daemon connection.  You might give that a try and verify the status to see that it is working as expected.  I think once you get this part resolved, you'll be good to go.

 

As for the IPv6, you can bypass this by adding the IPv4 number and hostname of the NLM server to the HOSTS file on the workstation.  That's all in my IPv6 fix link I posted previously (or in my sig line.)

Post 14 of 15

Re: FLEXnet License Administrator - getting clients to see server

07-10-2012 01:24 PM in reply to: TravisNave
I have Autcad 2013 network version up and running! What I needed to do was add the port 7788 to the end of the first line. This was done because the license manager is being shared between two applications (Autcad and Synergee), and Synergee had put a specific port in for the master daemon (7788) instead of the generic 27000. Thank you for all your help. You gave me the information I needed!
Post 15 of 15

Re: FLEXnet License Administrator - getting clients to see server

07-10-2012 01:27 PM in reply to: bobgoldie

That should work so long as you're using the same LMGRD file.  Although it is best for each master daemon connection to use a different port for each service connection.  In any case, I am glad you are up and running. 

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post