Installation & Licensing
Welcome to Autodesk’s Installation and Licensing Forums. Share your knowledge, ask questions, and explore popular Download, Installation, and Licensing topics.

Installation & Licensing

Post 61 of 66

Re: Autocad 2016 stuck at "Checking License" in splash screen. Tried e

01-26-2017 10:55 AM in reply to: natashal84

Like others on this email thread, I have tried all suggested ways of resolving this to no avail.

I have been running both AutoCAD 2016 and 2017 successfully on my Windows 10 machine for sometime, without any such License issue.  Now as of about 4 hours ago, it takes 5 to 20 minutes to start up AutoCAD, always getting stuck with the 'Checking license...' message.


Per this thread:

1.  This is a fairly common problem with no specific known fix, just a handful of 'try this and try that and maybe the problem will go away'.

2.  Is a very serious problem, i.e.  prevents the AutoCAD application from being used at all.

3.  And even more importantly, is preventing users from getting their work done, i.e. cost to our companies.


Given the above, I would consider this issue a fairly critical issue that needs resolution by the Autodesk team ASAP.   Could you please escalate this to the appropriate staff at Autodesk and resolve this now.


Thank you,




Post 62 of 66

Re: Autocad 2016 stuck at "Checking License" in splash screen. Tried e

01-31-2017 04:43 AM in reply to: jmorris03

When I try to open my Autocad 2017, it is frozen in the initial screen with status "Checking license" for 3-7 minutes. My attempts:
- I created an environment variable increasing the waiting time;
- I formatted the computer, I installed drivers only, without antivirus
- I have edited the ADSKFLEX_LICENSE_FILE registry key;
- I removed .NET 4.6 and installed 4.5;
- Delete and re-created the file, with _NETWORK content;
- My LICPATH.lic looks like this: SERVER 000000000000 USE_SERVER;
- Change the permissions of the FLEXNET folder.
Please, I need help because it is a long waiting time to open the program.


My last attempt was delete all the text in the key ADSKFLEX_LICENSE_FILE, but isn't work too.


I opened a call with autodesk, when there is an answer I'll post it here.


Good luck for us!


Post 63 of 66

Re: Autocad 2016 stuck at "Checking License" in splash screen. Tried e

01-31-2017 05:13 AM in reply to: patobranco

Hi you all...

I guess there is no working fix for this problem. It didn't work for me for months. And suddenly works for me two weeks ago. I checked for system changes (like windows updates, etc) but i didn't change a thing! So stop reinstalling, formatting drives, etc. You just f*ck up your system. 
The problem has to be on a server of Autodesk. 
They post useless posts on this forum like they are helping... But they don't.
I'm a educational user (free). So i can't really complain. But if you pay for the program (and it's a lot of money!) your realy f*ucked up!

Hopefully there's someone there who will help you out! I think this is a big problem that has to be solved!!

So autodesk... Stop posting "we really try to help" posts, and just let the tech guys fix this! 

JesperSmiley Frustrated

Post 64 of 66

Re: Autocad 2016 stuck at "Checking License" in splash screen. Tried e

01-31-2017 09:10 AM in reply to: j.spierenburg

Hello everyone

My problem with the slowness when opening the autocad 2017 with license by the network was solved:
We have included an entry in the dns server for the host machine name.

To understand what's happening on your network during checking license, install the wireshark software.

Good luck!

Post 65 of 66

Re: Autocad 2016 stuck at "Checking License" in splash screen. Tried e

03-20-2017 10:21 AM in reply to: patobranco

hello all,

if you have more then 1 network adapter (etc external network card,  port replicator... ), disable all. Keep active only one network card in your pc. Thats works for me after all previous sugestions and unsuccessful attempts in this topic.

Post 66 of 66

Re: Autocad 2016 stuck at "Checking License" in splash screen. Tried e

03-22-2017 08:37 AM in reply to: herczner



I have a potential solution.


Download and run CCleaner (free) and use the 'Clean Registry' functionality.


This has been mentioned a couple of times in this thread, but I wanted to emphasize that I was experiencing the 'Checking License..' standstill this morning.  I ran CCleaner's 'Clean Registry' function and AutoCAD started working immediately after that.


Surely there is some Registry value that can become corrupted and causes an issue when checking the license.. I'm not sure which one, but running CCleaner worked for me.



Post to the Community

Have questions about Autodesk products? Ask the community.

New Post