Community
Fusion Support
Report issues, bugs, and or unexpected behaviors you’re seeing. Share Fusion (formerly Fusion 360) issues here and get support from the community as well as the Fusion team.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Which ca-cert bundle or location does Fusion use on Windows 11? "Server Verification Warning" (unable to validate certificate)

1 REPLY 1
Reply
Message 1 of 2
OceanHydroAU
100 Views, 1 Reply

Which ca-cert bundle or location does Fusion use on Windows 11? "Server Verification Warning" (unable to validate certificate)

I've been suffering the below (see screenshot) for months now (years maybe even).

 

Does anyone know what CA bundle fusion is using (what file, or, what store it uses?)

 

Screenshot 2024-04-03 183509.png

trusting failures is obviously a very poor security decision, so I want to fix it.  I find this in my logs:-

 

20240403T201644 E 9776 GET 60 https://js.prd.fusionapi.autodesk.com/fusion360-runtime-config/config.json dt=0.53 schannel: CertGetCertificateChain trust error CERT_TRUST_IS_UNTRUSTED_ROOT
20240403T201744 E 9776 GET 60 https://js.prd.fusionapi.autodesk.com/hds/fusion360.json dt=0.66 schannel: CertGetCertificateChain trust error CERT_TRUST_IS_UNTRUSTED_ROOT

 

but I can load https://js.prd.fusionapi.autodesk.com/fusion360-runtime-config/config.json no problem on the same PC in:-

chrome,

curl from commandlne

edge browser

firefox

python (example below)

... so it looks like every ca-store I can think of of my box is just-fine.

 

I've erased and reinstalled all my windows certificates

my machine is up-to-date (with correct time etc)

I do not use proxies, and I've tried with my A/V turned off (yes "CERT_TRUST_IS_UNTRUSTED_ROOT" has nothing to do with those things, but I tried them anyhow) 

I've tried everything in the help page https://www.autodesk.com/support/technical/article/caas/sfdcarticles/sfdcarticles/Server-Verificatio...

I've uninstalled and reinstalled Fusion

I've done the service-tool repair

 

Anyone got any ideas?

 

I do notice, when doing a "dir /s /a *.crt",  "dir /s /a *.pem" in the AutoDesk program root folder that there's a bunch of ca-cert related files that have dates of 2017 and 2020 respectively... and keeping in mind that I just now did a fresh re-install, it does beg the question why antique bundles are shipping in the current product.  (and yes - I also tried overwriting all of them with the latest working ones, which didn't fix anything)

 

Anyone got any ideas?

I'm using Windows 1 Pro Version 10.0.22631 Build 22631

 

C:\Users\cnd\Downloads>python
Python 3.12.0 (tags/v3.12.0:0fb18b0, Oct  2 2023, 13:03:39) [MSC v.1935 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> import requests
>>>
>>> # URL of the JSON file
>>> url = 'https://js.prd.fusionapi.autodesk.com/fusion360-runtime-config/config.json'
>>>
>>> # Perform the GET request
>>> response = requests.get(url)
>>>
>>> # Check if the request was successful
>>> if response.status_code == 200:
...     # Load the JSON content
...     data = response.json()
...     # Print the JSON content
...     print(data)
... else:
...     print(f"Failed to retrieve the JSON. Status code: {response.status_code}")
...
{'product': {'id': 'fusion360-runtime-config', 'metadata': {'cpxmovecopy': 'no', 'AnyCAD': 'yes', 'UserVoiceEnabled': 'no', 'BranchingEnabled': 'yes', 'tHODisabled': 'yes', 'ECM': 'yes', 'SupportSolidEdgePartFile': 'yes', 'SupportStepFile': 'yes', 'OnDemandLMV': 'yes', 'crossprojectreference': 'yes', 'FusionSingleTier': 'yes', 'fusion-asm-fpe': 'no', 'symphonydm': 'no', 'TeamHub_ShowCreate': 'no', 'DisplayRetirementMessage': 'yes', 'anycadassembly': 'yes', 'DisableLegacyGLProfile': 'yes', 'FusionGenerativeTrial': 'yes', 'EnableEvergage': 'yes', 'SupportPrtFile': 'yes', 'GenerativeForStudents': 'no', 'autodeskgenerativedesignlink': 'yes', 'MfgExtGraceAccess': 'no', 'PersonalUserCapacityLimit': 'yes', 'use-trials-service-for-product': 'yes', 'IDSDKEnabled': 'yes'}}}
>>> ^Z

 

 

Labels (1)
1 REPLY 1
Message 2 of 2
OceanHydroAU
in reply to: OceanHydroAU

After today's huge Microsoft Windows patch update, this issue is now occurring on my other machine (Windows 10) as well...

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report