Community
Fusion Support
Report issues, bugs, and or unexpected behaviors you’re seeing. Share Fusion (formerly Fusion 360) issues here and get support from the community as well as the Fusion team.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to login with browser from Fusion 360.

7 REPLIES 7
SOLVED
Reply
Message 1 of 8
terrence.mitchem
181 Views, 7 Replies

Unable to login with browser from Fusion 360.

When trying to login to Fusion 360, the browser never appears.

 

I've followed the steps here with no luck, but noticed something interesting in one of the Identity Services log file (idServices.log)

 

2023-11-10T18:39:41.788Z [Fusion360:17508, 38000] [IdSDKPlugin INFO] SSO process is not running. Starting it.
2023-11-10T18:39:41.788Z [Fusion360:17508, 38000] [IdSDKPlugin INFO] Launching SSO process with command line: C:/Users/terre/AppData/Local/Autodesk/webdeploy/production/3167d85f5fd4280287d8295f20592fa13b977617/Autodesk Identity Manager/AdskIdentityManager.exe --process_name Autodesk.IDSDK.DefaultProcess-v2 --server_name Autodesk.IDSDK.DefaultServer-v2
2023-11-10T18:39:41.807Z [Fusion360:17508, 38000] [IdSDKPlugin ERROR] Failed to launch SSO process C:/Users/terre/AppData/Local/Autodesk/webdeploy/production/3167d85f5fd4280287d8295f20592fa13b977617/Autodesk Identity Manager/AdskIdentityManager.exe

 

When I tried to run the executable manually from Explorer, I got this:

 

Capture.JPG

 

It's interesting because the file is most definitely there, so there's something weird going on.  My first guess is a permission issue of some sort or a missing dependency.

 

7 REPLIES 7
Message 2 of 8

@terrence.mitchem 

1. What other Autodesk products do you have installed on your machine? 

2. If you go into Add/remove programs do you see Autodesk Identity manager in there? 


Rajkumar Ilanchelian
Autodesk Fusion

Join Fusion Insider

Message 3 of 8

Autodesk Fusion 360

Autodesk Identity Manager

Autodesk Single Sign On Component

 

The last two were installed as part of the troubleshooting procedure I linked in my previous message.

 

Message 4 of 8

@terrence.mitchem Please remove both of them and restart your machine. Do the login again and I assume the browser will not start this time around as well. 

What is your default browser and if you change the default browser does that help? 

Rajkumar Ilanchelian
Autodesk Fusion

Join Fusion Insider

Message 5 of 8

I've already tried without either of them installed.  I've tried with both Chrome and Edge as the default browser, and reboots in between each try.  Webview2 is also installed correctly, and I've tried running normally and as Administrator.

 

What I really need to know is what log file the failure (if it is being logged) would show up in.

 

Message 6 of 8

@terrence.mitchem The log will be in the  Identity Services log. Can you remove the two files and then run Fusion and now collect the logs and post here again please? This way we can remove the Identity manager and SSO out of the triage. 

Rajkumar Ilanchelian
Autodesk Fusion

Join Fusion Insider

Message 7 of 8

And lo and behold, it worked 😁

 

Which is weird, because I only installed Identity Manager and SSO because it wasn't working, and that's what the troubleshooting article said to do.

 

Whatever, I'll take it!

 

Thanks for the help.

 

Message 8 of 8

@terrence.mitchem Glad it is working now 🙂

Rajkumar Ilanchelian
Autodesk Fusion

Join Fusion Insider

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report