Community
Fusion Support
Report issues, bugs, and or unexpected behaviors you’re seeing. Share Fusion (formerly Fusion 360) issues here and get support from the community as well as the Fusion team.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Since last update Connexion devices not working properly

25 REPLIES 25
Reply
Message 1 of 26
david.oldridge
600 Views, 25 Replies

Since last update Connexion devices not working properly

Immediately after the most recent update, both of my Connexion devices began behaving erratically. As soon as I open Fusion they seem ok. But shortly after I start to work in a sketch, the Spacemouse refuses to orbit, although it will zoom in and out. And the wheel button on my 3D mouse, which enables panning stops working. When I reboot Fusion, initially everything is back to normal.

MacBook Pro - M1

Anyone else having this issue? and any thoughts welcome

Thanks

25 REPLIES 25
Message 2 of 26

Can't see a function to edit post. So I wanted to add that periodically the left 3D Mouse button seems to stop functioning, in the sense that it stops the ability to draw selection boxes
Message 3 of 26

Regarding the inability to rotate while in sketch mode, this is actually a 3DConnexion setting:

2023-09-29_05h34_37.png

 

Otherwise, are you using the latest drivers for your device(s)?


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 4 of 26

Hi Seth,

thanks for your response.

I think the image you’ve shown is for Windows. It’s a different UI on Mac.

yes I have checked there are no updates to my Connexion software.

I don’t think it is a connexion profile or button setting issue, because the devices do work sporadically.

All this occurred immediately after the last Fusion update.

I presume there is no way of rolling back to an earlier Fusion?

Message 5 of 26

No, rolling back is not possible.

I'll fire up my Mac to see what the equivalent menu option is on that side.

I know on Windows we do have an option to use the legacy driver for 3D Connexion devices, that may exist in Mac as well

 
 

 

 


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 6 of 26

Many thanks Seth,

 

Look forward to any more thoughts.

 

It appears that the devices will temporarily come back to life without necessarily re-launching, but it might be 10 minutes later - that doesn't apply to the panning function of the wheel button. Once that drops it doesn't return until I relaunch Fusion. It reminds me of some previous iterations of Fusion which wouldn't work properly with the M1 chip - endlessly hanging, waiting for the coloured wheel of death to finish spinning, when doing even the the simplest of sketch tasks. I move to another display and another app and everything is fine. It is Fusion specific.

If I had only found a specific pattern of what trips the devices and what restores them. But so far it seems quite random.

Message 7 of 26

@david.oldridge 

Do you Calibrate your 3DConnexion device every morning?

Windows image shown...

TheCADWhisperer_0-1695990618105.png

 

Message 8 of 26

Hi,

No I have never calibrated them, and have not had a problem before.

the option to do so, which you have shown appears to relate to a windows properties setup, which I don’t recall being available on the Mac version.

Certainly I tune both devices in terms of Fusion specific speed and response

Message 9 of 26
Bjanders
in reply to: david.oldridge

I have the same, or similar, issue on my Mac Mini M2 Pro with the last Fusion update. I posted about it in this old thread: https://forums.autodesk.com/t5/fusion-360-support/3dconnexion-spacemouse-very-slow/td-p/9080272

 

It would really be helpful if you could roll back a version to test if a problem is caused by an update, or if you experience a serious issue preventing you from working (efficiently).

Message 10 of 26
david.oldridge
in reply to: Bjanders

Yes, a roll back would be useful, and possibly a lot less frustrating. I am 99% certain this is a conflict between the most recent Fusion update and 3D Connexion software, for 2 reasons: 1. It started immediately after the last update (and I don't believe in coincidences) and 2. it's not a mouse hardware issue as this randomly erratic behaviour has afflicted both my 3D Cad Mouse and my Space Mouse at the same time.

Whilst there is no real pattern emerging, I have discovered 2 things:

1. When the Space Mouse refuses to orbit, I can use the Cad mouse to very slightly engage the orbit cube at top right, whereupon the Space Mouse will then happily take over and work normally.

2. If I go to the Cad Mouse settings and change the wheel button mapping to something else, and then change it back to the correct mapping as Button 3, the wheel button starts to operate panning as it should. Not long thereafter, it will stop panning again. I have no idea what triggers that, and it will not operate correctly again unless I make the changes just described or relaunch Fusion.

One other annoyance which goes hand in hand with this, since the update, is the fact that most of the times I click to edit a sketch, the sketch opens up and instantly zooms in to its maximum extent, not even with the sketch in centre focus, leaving me wasting time zooming out and trying to find the sketch again. But again it's relatively random.

 

Message 11 of 26
Bjanders
in reply to: david.oldridge

I don't think I have the same issue as you. For me the movements are jerky with the SpaceMouse, even with just one simple block in the design. With a normal mouse everything is smooth.

 

I've experienced sketches being locked in 2D (does not orbit), until you engage the orbit cube. For me it's been like that for a long time, and see it as desirable feature, as normally I don't want to orbit sketches.

Message 12 of 26
Bjanders
in reply to: david.oldridge

In the Fusion 360 Preferences I changed General -> SpaceMouse driver to Legacy (it was set to Latest), and now it is smooth again.

 

Now that I think of it, I'm pretty sure I originally was using the legacy driver, as I can remember having to change 3DConnextion SpaceMouse settings for the legacy driver, and I was wondering why the legacy driver was in use

Message 13 of 26
Phil.E
in reply to: Bjanders

There was a pretty big update to macOS drivers for spacemouse. Fusion recently updated to consume these changes and it's helpful to be on the latest drivers. Please let me know what you find, I'm glad to report any new issues with 3Dconnexion devices and Fusion. 





Phil Eichmiller
Software Engineer
Quality Assurance
Autodesk, Inc.


Message 14 of 26
Bjanders
in reply to: Phil.E

Hi

 

I'm using a Mac Mini M2 Pro with a 4k display with 3008x1692 scaling in the Mac Displays settings. I haven't tried with any other scaling yet. I'm using Fusion 360 2.0.17457 arm64 on macOS 14.0.

 

Here are to video captures. One with the "Latest" driver in Fusion and with the "Legacy". I have the exact same settings for both in the Mac 3DConnexion settings.

 

Using the Latest driver is totally unbearable as is so extremely slow. Using the Legacy driver everything is fluid.

 

If you need any further info, I'll be happy to help.

 

 

 

Message 15 of 26
Bjanders
in reply to: Bjanders

For some reason I can't edit my previous reply.

The video of my Latest driver is not representative, because I didn't in fact have the same speed in the macOS 3DConnexion settings. I was hoping it was only a user error, but with speed set in the middle/default (as I had with the Legacy driver), it is faster, but still jumpy as seen in the updated video here. (This was my original issue. I had then put on slower speed to test if it made it any smoother).

 

Message 16 of 26
Bjanders
in reply to: Bjanders

I also tried setting the macOS Display settings to no scaling. This makes it much better when using the Latest driver, so you probably wouldn't notice any issue unless you compared it to the Legacy driver. So if you want to reproduce the issue, then I suggest you try with a 4k display on the middle scaling setting in the macOS Display settings.

Message 17 of 26
phil_eichmiller
in reply to: Bjanders

Did you do this yet?

phileichmiller_0-1697050711445.png

 

Message 18 of 26
Bjanders
in reply to: phil_eichmiller

I had the previous version of the driver, 10.8.1. I now updated to 10.8.2 and the behaviour is exactly the same, i.e. still jerky movements.

Message 19 of 26
Phil.E
in reply to: Bjanders

Thanks for the information.

 

I just noticed that you are using macOS14, which is not officially supported by Fusion or 3Dconnexion yet. So that might be part of the problem. I can't confirm this because all of my mac test machines are <= 13.5.1

 

Testing on an m1 mac mini and an older Intel iMac, comparing legacy and latest drivers, using the latest 3Dconnexion drivers, I can't reproduce a general slowness. However, I do see a stuttering effect when the mouse pointer is moved while the orbit is moving. This is because moving the mouse pointer will activate the face highlighting effects.

 

Are you using your regular mouse pointer by moving it over the box bodies as they are orbiting in the videos?

 

I can report the stuttering that happens when you move the mouse pointer onto the orbiting model. There may be an opportunity to get better performance in this case. A workaround would be not to move the mouse pointer while orbiting the model.

 

I also got slightly better performance after reducing graphics effects in Preferences and in the Display Settings/Graphics Diagnostic. With all effects fully "on" there was no stuttering other than what was seen when the mouse pointer is actively moving on the model faces while they are orbiting.

 

 





Phil Eichmiller
Software Engineer
Quality Assurance
Autodesk, Inc.


Message 20 of 26
Bjanders
in reply to: Phil.E

I had the same issue before upgrading to macOS 14, so I don't believe this is the culprit.

 

I'm not moving the mouse over the box bodies. The mouse would be visible in the screen capture if I was. Also, I'm not touching the normal mouse at all during the recording.

 

Notice how the green center of rotation dot flashes when using the latest drivers and not at all when using the legacy drivers.

 

Have you tried reproducing on a 4k (or higher) resolution display and having macOS display scaling on (middle setting), and Fusion 360 in full screen?

 

DIsplay settings.png

 

The difference in performance between legacy and latest is day and night. I don't see any reason why I should be using latest (with potentially turned down visual settings), when legacy works perfectly.

 

Of course it would be good to resolve this, if the legacy drivers eventually will be removed completely.

 

Could the issue be that I'm using a wired two button SpaceMouse? It seems 3DConnexion doesn't officially support it anymore.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report