Community
Fusion Support
Report issues, bugs, and or unexpected behaviors you’re seeing. Share Fusion (formerly Fusion 360) issues here and get support from the community as well as the Fusion team.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Physical Material and Appearance not applying

14 REPLIES 14
SOLVED
Reply
Message 1 of 15
Careless_
6727 Views, 14 Replies

Physical Material and Appearance not applying

I've tested with a number of different projects and different files just now.

When I right click on a component to select "Physical Material" or "Appearance" and apply my preferred options to a selected component, upon clicking "close" at the bottom of the dialog box, the properties are reset and the component goes back, to being its generic material/appearance gray colour.

 

Wasn't there an OK button before?

 

Applying Black Opaque Plastic property.

 

 

After clicking "close"

 

 

You can see the object returns to normal. No component color toggling is enabled. I have not changed any settings in F360 for quite a long time now.

 

This happens at the component, body, and assembly level. No change in appearance after the dialog is closed.

 

In the above screenshots, the component was Derived into the current assembly.

 

If I go back into to the original component file and change the properties, the same thing happens; shown below.

 

The properties ARE changed, but the appearance is not.

 

 

I simply cannot change the appearance of components anymore. Is there a viewport setting that controls this?

14 REPLIES 14
Message 2 of 15
jeff_strater
in reply to: Careless_

@Careless_ - can you share that model here?  I don't have any immediate explanation for what you are seeing, so I'd like to try it myself.  Are you applying the appearance at a component or body level?  If you have time, recording a screencast of what you are doing might also help.  Thanks.


Jeff Strater
Engineering Director
Message 3 of 15
Careless_
in reply to: jeff_strater

Essentially, I tried adding material to the item by dragging onto the component, onto the individual body, every way I know how. I have also tried a few other components as well.

 

The only common thing that I recall these components having amongst them is that they were restored from a project I put on the back-burner for a year or so (archived on f360). 

 

Applying the same process to another item from a newer (last week) project and component does not have any issues. In fact, even applying materials or appearances to a newly created component in an assembly within this restored archive project does not seem to pose any issue.

 

If I open the (see attached) model on its own, the same thing happens.

 

  1. Right Click component or body.
  2. Select "Physical Material" to open the dialog box
  3. Apply a material (Drag/Drop, etc.)
  4. See object change colour/opacity/texture to reflect material appearance.
  5. Click CLOSE
  6. Appearance is gone.
  7. Viewing component properties shows that material is indeed changed, but appearance is lost.

Perhaps something has changed in the way the physical material is saved in newer file or program versions that it will no longer work on these old files?

 

As per the first post, here is what is going on:

 

SCREENSHOT 1

The appearance will apply and show up while the dialog box is open. 

 

SCREENSHOT 2

As soon as I click "CLOSE" (which should really have an OK/CANCEL button, tbh), the appearance disappears.

 

SCREENSHOT 3
As you can see in the last photo, the item has taken on the material properties, but no matter if I change it to Aluminum, Plastic, Glass or whatever is in the list- the appearance of said material is not applied.

 

I've attached one of the offending files that does not have any discernible features from the design- so I've shared it here as per your request.

Message 4 of 15
jeff_strater
in reply to: Careless_

I can see what is going on, and admit that this is confusing.  Here's the basic thing:  Appearance overrides physical material.  And, this is what you want to happen (so you can "paint" a steel part to be blue, or even just some faces).  It just happens that the body in this component has an appearance applied (Plastic - Matte (Gray)) that was overriding the physical material.  If you remove the appearance override, you will again see the physical material:

Screen Shot 2020-05-05 at 3.16.56 PM.png

 

The Physical Material command also further confuses things because it temporarily suppresses appearances during the command, so that you can see the physical material being applied.  But, this is confusing because as soon as you hit OK, the appearance is un-suppressed.

 

There is also a utility that I like from @prainsberry built that I love:  https://github.com/tapnair/AppearanceUtility This utility shows all the appearance overrides for the entire model, and lets you selectively turn them on and off.

 

here is a screencast that shows all this:

 


Jeff Strater
Engineering Director
Message 5 of 15
jeff_strater
in reply to: Careless_

well, I had a nice reply to this, but it seems as if the spam filter has eaten it.  I'll try to get it restored...

 


Jeff Strater
Engineering Director
Message 6 of 15
jeff_strater
in reply to: Careless_

OK, going to try again.  Hopefully this one goes through...  We may end up with two of these, sorry

 

the basic problem is that this body has both a physical material and an appearance.  Appearance has a higher priority (which is what you want, since you can think of it as painting over the base material).  The Physical Material command further confuses this issue by temporarily suspending the appearance during the command.  But, when you exit, the appearance comes back.  The way around it is to remove the appearance:

Screen Shot 2020-05-05 at 3.16.56 PM.png

 

there is a nice utility that @prainsberry built that I use all the time to debug appearance issues.  you can find it here:  AppearanceUtility .  The screencast below shows both ways of doing this:

 

 


Jeff Strater
Engineering Director
Message 7 of 15
Careless_
in reply to: jeff_strater

Excellent, I'll give it a shot. Thanks!

 

Maybe one of those little pop-up boxes in the bottom right corner to alert the user that there is an appearance override active would be a simple way to avoid confusion?

Message 8 of 15
Careless_
in reply to: jeff_strater

Just tried both methods.

Seems to work quite well.

Thanks again.

Message 9 of 15
gts9198
in reply to: Careless_

the way this program deals with anything is cancer. its 2022 and the options in this forum are simply non existent, unbelievable. have to be a long time user just to understand this quirky junk. so much for being better than solid works.
Message 10 of 15
Careless_
in reply to: gts9198

well it seems like my suggestion above about a notification or even maybe a paintbrush icon next to the component/body name in the component tree on the left of the viewport to signify an appearance change is applied/active seems to be a good solution to me but I'm not sure what the dev team is up to lately, so I dunno what to tell ya.

 

the program has gotten a lot better... but its the little things...

Message 11 of 15
monkeysZ9UQU
in reply to: Careless_

Found similar behaviour in 2022.
Eventually figured out that if the body is not a part of a component, it will show the Physical Material/Appearance of the root object.
Edit the Physical material or appearance of the root object, or turn your body into a component and then change it.

Message 12 of 15

Thank you Jeff for a very good write-up on this topic. I agree very confusing. I spent a few hours trying to figure out why I could set materials, but then later could not change... Appreciate the detailed reply to the user's question.
Message 13 of 15
bww001
in reply to: jeff_strater

Did not work for me. All my previous model and current model. The model appears as line drawing with white background. No mater what material I tried to drag and drop onto the model, nothing changes. Do not see the feature you circled on the drop down menu. Is my Fusion 360 corrupted in some way?

Message 14 of 15
g-andresen
in reply to: bww001

Hi,

you´re in wireframe mode > select a shaded view

IMG_1212.jpeg

 

günther

Message 15 of 15
bww001
in reply to: g-andresen

Thank you so much. I was at my wits end trying to figure out what happened.

Again, thank you.

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums