Community
Fusion Support
Report issues, bugs, and or unexpected behaviors you’re seeing. Share Fusion (formerly Fusion 360) issues here and get support from the community as well as the Fusion team.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

No permission to save my own documents

9 REPLIES 9
SOLVED
Reply
Message 1 of 10
LarsFi
749 Views, 9 Replies

No permission to save my own documents

Hopefully someone can help to solve my current issue.

 

Milled some parts this weekend and had F360 nearly the whole time opened with several files which I had to mill on my CNC.

I moved all the files to mill in a folder named "milling" and worked on them over the weekend - changed and saved them several times.

After the weekend I moved all the files from the "milling" folder back to their origin "parts" folder and deleted the "milling" folder.

Friday night I received an F360 update but as mentioned I worked the whole weekend after this update on my files without any issues.
Trying today to change something in the files (which have been moved to "milling" and back to "parts" folder) i get the attached message saying that I have no permission to save this files.
Hovering over the box underneath "Connot be saved" there pops up a message "You don't have write permissions for this design".

Tried to save the files under another name and that worked - the issue is that all this files are linked into a bigger assembly and I am hesitant starting to change all the joints I have to exchange if I use the renamed saved files.

All other files can be saved without an issue which tells me that something went wrong moving the files between the folders

 

I am using the personal license w/o a subsciption

 

What can I do to solve this?

 

Thanks in advance for your support

 

9 REPLIES 9
Message 2 of 10
Phil.E
in reply to: LarsFi

Hi,

 

Glad to help. Can you please gather your diagnostic logs?

 

Help > Support and Diagnostics > Diagnostic log files. 

 

Please post those, it should have some answers.





Phil Eichmiller
Software Engineer
Quality Assurance
Autodesk, Inc.


Message 3 of 10
LarsFi
in reply to: LarsFi

Hi Phil,

 

thanks for looking inside this issue.

Attached is the disgnostics file.

 

Greetings from Germany

 

Lars

Message 4 of 10
saurabh.singhKD42F
in reply to: LarsFi

Hi @LarsFi ,
Can you try moving the parts to a different folder again, maybe that might help.
If above steps doesn't help, you can invite me to the project, I'd be happy to take a look further. (Id : saurabh.singh@autodesk.com)

Message 5 of 10
AnandSomani
in reply to: LarsFi

Also, one other thing to try would be this:

 

Go to Preferences > General > turn on “Automatic version on close”

 

Screenshot 2020-12-16 at 1.06.41 PM.png

Then try making an edit to a design and rather than saving it explicitly, directly close it. Due to above preference, it will implicitly try to Save your changes on close.

 

There's a chance that it may not work as well (you may eventually see a pop up saying that the Save failed), but in case it works, you'll at least have a workaround until we investigate the issue.

 

Apologies for the inconvenience.

Anand
(Fusion 360 Developer)
Message 6 of 10
AnandSomani
in reply to: LarsFi

UPDATE:

 

We were able to reproduce the issue. (Internal ticket: FUS-76471)

 

We were also able to find a confirmed way to workaround this issue in the mean time. Please follow these steps:

 

1. Close all designs in Fusion 360

2. Locate the local cache files directory –

 

Windows
C:\Users\***\AppData\Local\Autodesk\Autodesk Fusion 360\***\W.Login

MacOS
Macintosh HD > Users > *** > Library > Application Support > Autodesk > Autodesk Fusion 360 > *** > W.Login

 

More info at: https://knowledge.autodesk.com/support/fusion-360/learn-explore/caas/sfdcarticles/sfdcarticles/How-t...

 

3. You should see a folder named 'F' there. Rename it (E.g. change it to 'F--')

 

Now try to open the design in Fusion 360 again and try to save it. It should succeed now.

 

We'll try to fix the root cause in the meantime. Thank you for your patience and appologies again.

Anand
(Fusion 360 Developer)
Message 7 of 10
LarsFi
in reply to: LarsFi

@saurabh.singhKD42FMoved the files in a folder named the same then I had it moved the other day. Could save the files there successfully and then moved them back in their original folder and can save them there as well as it should be.

Your suggestion worked so that issue is solved.

 

@saurabh.singhKD42F @AnandSomani @Phil.E 

If you need more files or data to investigate what happened I am happy to provide them.

 

Than you so much for helping me out of that - you made my day!

 

Lars

Message 8 of 10
LarsFi
in reply to: LarsFi

@AnandSomaniYour finding overlapped with my answer 😉 - thanks for the investigation and I will follow your described steps  in addition to the moved files solution I reported

Message 9 of 10
arie1
in reply to: AnandSomani

I have followed these instructions, however for some reason to find the F folder it is within: C:\Users\***\AppData\Local\Autodesk\Autodesk Fusion 360\unkown user\W.Login

 

This is quite bizzare and so i still can't save because Fusion is not recognizing me as the administrator of my own project.

Can you please advise?

Message 10 of 10
AnandSomani
in reply to: LarsFi

Hi @arie1,

 

That's odd. Can you share a bit more about what issue do you see in Fusion 360? Does it not let you save? If so, what errors does it show you? Any screenshots would help as well.

 

Could you try the problematic workflow in Fusion and then share the log files please: Help > Support and Diagnostics > Diagnostic log files

Anand
(Fusion 360 Developer)

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report