Community
Fusion Support
Report issues, bugs, and or unexpected behaviors you’re seeing. Share Fusion (formerly Fusion 360) issues here and get support from the community as well as the Fusion team.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

New Update Breaks Drawings Very Easily?

9 REPLIES 9
SOLVED
Reply
Message 1 of 10
natzoo
291 Views, 9 Replies

New Update Breaks Drawings Very Easily?

I have thousands of hours designing 3D and 2D drawings for bike frames. I developed a very robust workflow that allows me to change the 3D design and automatically update the 2D construction drawings.

 

This month I have noticed that 2D drawings break EXTREMELY easily. One minor change to a 3D part sketch breaks several pages of 2D drawings (most are not even related to the component that changed)

 

natzoo_0-1694639133303.png

 

In addition, anything that "shifts" the component on the 2D drawing breaks the links:

Untitled.png

 

I am very confident the drawings breaking is a new bug. I had spent many hours developing my workflow to keep the drawings linked, now change breaks them all!

 

Is anyone else experiencing this? Can Fusion360 tech support help out?

 

EDIT: 
I created a test file to show the bug:

https://a360.co/3EJSS4t

 

A minor change to the angle of the tubes:

natzoo_0-1694640534453.png

Breaks any dimension that referenced the tube:

natzoo_1-1694640596071.png

 

It is almost as if Fusion is re-generating completely new bodies every time, and the link to the 2D sketch is no longer maintained. A month ago this was never an issue.

9 REPLIES 9
Message 2 of 10
jhackney1972
in reply to: natzoo

I downloaded your drawing and model which you say shows a problem with disassociation of dimensions in the drawing after an angle change in the model.  I do not see any issues or problems in the update.  I did it twice to be sure.  It is possible that you need to Repair your Fusion 360 installation using the Fusion 360 Service Utility.

 


"If you find my answer solved your question, please select the Accept Solution icon"

John Hackney
Retired

Beyond the Drafting Board


Message 3 of 10
natzoo
in reply to: jhackney1972

Thank you for the quick response.

 

I see it works perfectly for you, but I have no idea why my CAD does not work. I tried:

  1. Repairing via Service Utility
  2. Complete uninstall + re install
  3. Downloading the link I posted, then re-uploading to my workspace

All have the same result: the dimensions that reference the body of the tube break when I update the 3D part.

 

I even created a simple part that replicates the bug:

https://a360.co/3LoJA1P

natzoo_0-1694657636734.png

 

This is the version I am using:

  • Fusion 360 2.0.16985 x86_64
    Active Plan: Subscription
    Windows 11 Home 22H2 (22621.2134)

Any other avenues I am overlooking?

 

Message 4 of 10
jhackney1972
in reply to: natzoo

I normally run Fusion 360 on a Windows 10 computer but since you are having trouble on a Windows 11 computer, I switched to see if I had the same issue.  I did and I get the failure! So this is a Windows 11 issue it would seem as it works OK on Windows 10.

 

@ClintBrown3D, I hope you can take a look at this.


"If you find my answer solved your question, please select the Accept Solution icon"

John Hackney
Retired

Beyond the Drafting Board


Message 5 of 10
natzoo
in reply to: natzoo

Thanks! I am not crazy after all!

 

It feels like something deep in the back end broke how drawing dimensions are linked to the part. Before, you could hide and unhide a body in a sketch without breaking the dimensions. Now anything that causes the drawing to re-generate breaks the dimensions.

Message 6 of 10
ClintBrown3D
in reply to: natzoo

Hi @natzoo & @jhackney1972 

 

The team is aware of an issue affecting Windows 11 and dimension dis-association, they are actively working on a fix, I'm sure it will be available in an upcoming release.

 

cc: @Pramod.kadam 

Message 7 of 10
natzoo
in reply to: ClintBrown3D

Thanks! Hopefully, it can be fixed soon. It is basically blocking me from doing work...

Message 8 of 10
natzoo
in reply to: natzoo

@ClintBrown3D I was wondering when to expect this bug fix. I am blocked from doing work. I have over 100 designs that have 6+ pages of drawings that I am too afraid to open for fear of disassociating the dimensions. It is an extremely disruptive bug for me and the small business I am working with.


This is one of my frustrations with subscription products: the forced updates can break existing workflows. I know there is a balance between improving the product and keeping it from breaking, but I feel like a bug this devastating should have been caught internally or with a Canary test group. If Fusion was not a subscription and I owned the software, I would simply not update it, or revert back to a previous update.

 

To add more insult to injury, I paid a subscription for this month, even though I can't do any work. I also lost faith in my existing drawings. Will I have to go and re-do 600 pages of drawings once this bug is fixed?

Message 9 of 10
ClintBrown3D
in reply to: natzoo

Hi @natzoo 

 

I’m truly sorry that you have been affected by this.

I believe that the update we shipped today included a fix for this disassociation issue. Hopefully you are back up and running. 

 

Im currently out of office travelling so will tag @Pramod.kadam & @-kyle.Williams- for any follow-up. 

Message 10 of 10
natzoo
in reply to: natzoo

@ClintBrown3D @Pramod.kadam Thanks, the update did the trick. I appreciate the quick turnaround. I hope this can be a case for better testing before pushing new releases or the option to revert to a previous version. I lost almost three weeks of work struggling through the dissociation bug. If I were a serious engineering company, it would have been devastating. Luckily I just design bikes 😂

 

natzoo_0-1695181692525.png

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums