Fusion Support
Report issues, bugs, and or unexpected behaviors you’re seeing. Share Fusion (formerly Fusion 360) issues here and get support from the community as well as the Fusion team.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Lagging cursor on Macbook Pro M2

Message 1 of 4
144 Views, 3 Replies

Lagging cursor on Macbook Pro M2


Occasionally, I try to do some work on my MacBook Pro (M2) instead of my Windows workstation. But as soon I start - I can't withstand the cursor lag in sketch mode, thus shutting down the Fusion360. Is there anything I can do to eliminate this lag and have the snappiness I have on my Windows workstation?

Labels (6)
Message 2 of 4

Hi @mitkus.tadas, thanks for the report. I think I can reproduce this. Does it happen when both full screen and zoomed/maximized? Or just full screen?


Another option to try is going into the application Preferences > Graphics > Display and unchecking High-resolution canvas graphics on high DPI displays.

Lance Carocci
Fusion 360 QA for UI Framework/Cloud Workflows, and fervent cat enthusiast
Message 3 of 4

@lance.carocci Thank you for your reply and confirming that the issue can be replicated. While disabling the High-resolution canvas graphics is indeed helping, it's not a very huge improvement, and lag is still there. It appears that the biggest change is the Fusion360 window screen size - the smaller the window, the snappier it gets. Please see an attached video showing the differences from the smallest possible window to the mid-sized window to the maximized window. 

I have plans to convert to full-time working on Mac but can't before this issue is solved. Any help would be much appreciated!

Message 4 of 4



I did some further testing on this and found that Anti-Aliasing in conjunction with High Res Canvas Graphics is responsible for almost a 40-50% drop in framerate. Frankly, AA isn't really needed at 2x scale, but I see some logic here we can improve nonetheless, such as the fact that AA doesn't seem to be disabling automatically if a minimum navigation FPS is set.


You can disable AA under the Navigation Bar under the Effects submenu. There is also a preference that will override this and disable AA and AO with high res canvas graphics.

Lance Carocci
Fusion 360 QA for UI Framework/Cloud Workflows, and fervent cat enthusiast

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums