Community
Fusion Support
Report issues, bugs, and or unexpected behaviors you’re seeing. Share Fusion (formerly Fusion 360) issues here and get support from the community as well as the Fusion team.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Importing a .obj file with associated .mtl and .jpg

27 REPLIES 27
SOLVED
Reply
Message 1 of 28
brianchristiangrover
6628 Views, 27 Replies

Importing a .obj file with associated .mtl and .jpg

Hi all,

 

I am trying to import a .obj file as well as its associated .mtl file. I also have .jpg files that the .mtl file references. I easily pull the .obj file into Fusion360 but cannot find a way to link the file with its .mtl and .jpg files. Any help on how to bring these associated files in would be greatly appreciated! 

 

Thanks!

Brian

27 REPLIES 27
Message 2 of 28

My recommendation is to convert the OBJ file with mtl / jpg you have at hand to a 3mf (you can use Autodesk Netfabb to do that if you like) After that you can open the 3MF file in Fusion 360.

Message 3 of 28

Hi @brianchristiangrover,

 

Welcome to the Autodesk Community, and thank you for posting your question here in the Fusion 360 forum!

 

If you can't convert the OBJ to a 3MF as @Sualp.Ozel recommended, here are a couple of additional things you might try to get the OBJ to display its appearance when you bring it into Fusion 360:

  • Make sure the 3 files are in the same folder (OBJ, MTL, JPG).
  • Make sure to use the Mesh > Create > Insert Mesh command to insert the OBJ.
  • In Preferences > Material, make sure you haven't changed the default appearance, or it'll override the OBJ's appearance when you insert it.
    PrefsMaterial.png
  • Turn off Inspect > Component Color Cycling.
    CompColor.png
  • Turn off Display > Mesh Display > Face Groups.
    DisplayFG.png
  • If the mesh is really dense, switch to a Visual Style that doesn't display any edges, or they may obscure the appearance.
    DisplayVS.png

Let us know if any of these suggestions work for you, or if you need any more help.


Victoria Studley
Content Experience Designer - Fusion 360
Fusion 360 | Learn & Support
Documentation | Contact Support
Message 4 of 28

Thanks for the help! Toggling off Face Groups under Mesh Display worked, as @Victoria.Studley suggested.

In regard to @Sualp.Ozel's suggestion, I do not have access to Netfabb at this time

Message 5 of 28

I am experiencing problems when I import a mesh that it uses the previous mesh I imported in another designs jpg and 3mf file . Anybody know how to fix this?

 

Message 6 of 28

I have chair from internet. The model looks like steel, and doesn't use its own materials.

When i put on F360 materials render in cloud or local render is failed. 

There is .obj with .mtl and .jpeg in one folder.

I did everything from this topic, but it doesnt work! 

Help me please put on materials and render it correctly! 75948758-b87a-42d8-8c36-5eede6ce9b48.jpgfa5c6c94-2784-4112-b316-9e2af6aeb948.jpg

Message 7 of 28

I tried to do this for an imported obj file but half the options pictured are not in my copy (personal) of F360 such as:
Inspect > Component Color Cycling.
Display > Mesh Display > Face Groups.

So can I still apply the mtl file to the mesh?

Message 8 of 28
parildav
in reply to: Feltman_Langer

Hi, I didnt have Mesh Display > Face groups either, but "Shift+F" worked for me =D
The Inspect > Component Color Cycling just got renamed to Inspect > Display Component Colors

Works with textures ❤️
Message 9 of 28

I have had similar issues with displaying the texture mapping. I followed the suggestions here to no avail. Enabling smooth shading instead of flat shading did work though. Screenshot (4).png

Message 10 of 28
camhamilton
in reply to: Olle_Eriksson

Brilliant!! After applying the suggested settings, my OBJ + MTL+ JPG's loaded correctly. This was a Fusion 360 OBJ file set exported from PolyCam, a photogrammetry app. Now I can design my mobile miter saw table with a 3D scaled body as a reference. Saved hours of design time.

 

Thanks!

Message 11 of 28

Well, after the newest update, this solution no longer works. Kind of frustrating when I want to reference a scan to build a surface from and cannot use the desired marks I intended. Any reason this should be so non-intuitive?

Message 12 of 28


@dan.ballarin wrote:

Well, after the newest update, this solution no longer works.


@dan.ballarin 

I just tried on my machine and it worked fine.

TheCADWhisperer_1-1681309194104.png

Can you zip your folder of files and Attach the resulting *.zip here for testing?

Message 13 of 28

@dan.ballarin 

Did you figure this out?

Message 14 of 28

Sorry for the late response, my work got super busy.  I guess it's good to know that it wasn't part of some update. I can upload the file I was trying to work with. I believe it must be in my settings somehow. It automatically sets the appearance of the material to metal, so it is either "color cycle", or "steel"

Message 15 of 28

@dan.ballarin 
Go back and read the original post.

Your obj must be able to find your mtl and jpg files to apply the appearance when opening in Fusion.  You did not Attach those files for testing?  See Message #3 first bullet. 

Message 16 of 28

Screenshot 2023-04-14 102620.pngHere is a screenshot with the blue marks. If I upload this exact file into another mesh program(Ossur Design Studio), it works just fine. I guess the MTL and jpeg files are embedded in the file itself?  Unfortunately when I'm not able to just separate the file to my knowledge from the scanning software (Scandy Pro), and in fact the embedded single file is preferred for the Ossur mesh program.

Thanks!

Message 17 of 28

Hi all,

 

I faced the exact same problem as dan.ballarin described. I'm not able to open / import any of the obj files with displaying the texture.  No matter what I set in Preferences > Material. The problem is always the same. The appearance in Fusion is automatically sets to the standard material "steel".

If I use autodesk viewer to display the file it shows up correctly. I also tried to transfer the file from autodesk viewer to Fusion 360, with no success.

Attached is a zip-file containing the obj, mtl and jpg file. May anyone have a look into this and can tell me what's wrong. Do I have somehow a wrong setting in Fusion or is it may be a software bug in the actual version?

Thanks in advance!

 

Message 18 of 28

@marcial.blasutto 

I was able to get it to display colors in Autodesk Mesh Mixer and in Autodesk Inventor Professional, but not in Autodesk Fusion 360.

TheCADWhisperer_0-1692533352805.png

 

Message 19 of 28

@TheCADWhisperer thank you for your reply. Do you have an idea why Fusion will not display the colors? Or is there may be a workaround?

Message 20 of 28


@marcial.blasutto wrote:

@TheCADWhisperer thank you for your reply. Do you have an idea why Fusion will not display the colors? Or is there may be a workaround?


Looks like they broke Fusion 360.

I tried the same files that I illustrated in Message 12 and it no longer works.

 

If you are a student you can get Autodesk Inventor Professional for free.  It works without issue in Inventor Professional.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums