Community
Fusion Support
Report issues, bugs, and or unexpected behaviors you’re seeing. Share Fusion (formerly Fusion 360) issues here and get support from the community as well as the Fusion team.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Gsync Compatibility setting causes screen blackout.

9 REPLIES 9
Reply
Message 1 of 10
r3deag1e.rzr
3951 Views, 9 Replies

Gsync Compatibility setting causes screen blackout.

Hi.  I recently got an ultrawide freesync monitor (MSI MAG341CQ) which is gsync compatible.  I'm also using a Nvidia GTX 1080Ti.   When I have the Gsync Compatibility enabled, working in Fusion 360 is near impossible sometimes.  This doesn't happen ever time I open up F360 but it does seem to happen a lot.  As soon as I click on anything in F360, the screen goes black for a few seconds.  Once it returns to normal, it blacks out again as soon as I click on something else within F360.   After several days of frustration, I finally figured out it was due to the Gsync Compatibility setting I had enabled.  Once disabled, F360 works fine as usual.   Is this something Autodesk folks can resolve?  I'd like to keep the setting enabled.   Thanks.

9 REPLIES 9
Message 2 of 10

Howdy @r3deag1e.rzr - Grats on the new display!

 

Let me begin with a disclaimer: Freesync on Nvidia GPUs is still new, and there might not be much we can do on our end just yet since this is a fairly young feature in Nvidia's drivers, and very hardware-dependent. Nvidia themselves have stated that "unsupported" Freesync displays used with Gsync compatibility can often exhibit quirks like you describe, even on AMD cards. But I totally get wanting to keep adaptive sync enabled 24/7, so let's walk through a few areas to check.

 

The black screen sounds like Windows or the display changing modes. Does this happen with other apps, like games? Say, when starting them up or closing them from fullscreen mode? Does it happen with any other non-games?

 

One way we might be able to mitigate this is enabling Gsync for Fullscreen only. If you see the last screenshot in this How To Geek article - you can toggle whether Gsync is enabled for both windowed and fullscreen, or just fullscreen only. Does the behavior go away or change if you do this? (Even if it does, I will do my best to investigate why it's not working for Windowed apps).

 

Note also that, while true G-sync can operate from 1-240hz, the VESA Adaptive Sync standard (which Nvidia uses for Freesync panels) only works from about 48hz-144hz, which makes me wonder if your issues are triggered by framerate drops or spikes as Fusion redraws the interface when you interact with it.

 

Finally, just to cover all our bases - make sure also that you've enabled FreeSync in the monitor's Onscreen Display (OSD), as it's often off by default. If you wish to read a bit more on Gysnc Compatible and its real world performance, this overview from Rtings is a good read.


Lance Carocci
Fusion 360 QA for UI Framework/Cloud Workflows, and fervent cat enthusiast
Message 3 of 10

Hi Lance. Thanks for the response.

Interesting point about it changing modes. I thought that initially but
even within fusion (being the active window) it still blacks out when i
just move the mouse that causes a change in the app like highlighting a
face or opening a menu, etc. Also should note this doesn't happen in games
or any other apps I use on this pc whether they are fullscreen or
windowed. Also, in games, even when the fps drops to below 40hz (every
setting is maxed or with gpu tests), the screen doesn't black out.. I just
see screen tears and lag. I rarely see the framerate drop below 80 during
normal gameplay.

I looked into setting the gsync compatibility to fullscreen only but fusion
360 is working fine now so I won't be able to tell if it fixes the issue.
I'll keep it in mind the next time it happens. As I mentioned before, it
doesn't happen all the time but when it does, I just can't do anything in
fusion.

I also tried using fraps to show the fps while using fusion but it doesn't
seem to work like it does in games where it shows the active fps. It only
shows a static number. In this case, a 1, which I don't think is correct.

And yes, I do have FreeSync enabled on the monitor.

Regards,
James
Message 4 of 10

Just thought I'd update the post.  The issue appeared again and setting gsync compat only to fullscreen didn't fix the issue.  Only disabling it fixed the black outs. 

Message 5 of 10

Thanks @r3deag1e.rzr,

 

I've documented the issue, but unfortunately we don't see a lot of Adaptive Sync hardware, let alone sync-based hardware issues, so this may be difficult to track down. In the event the behavior changes, or maybe a newer driver fixes it down the road, please let us know. And vice versa, if I find something new, you'll hear it.

 

Best regards,

Lance


Lance Carocci
Fusion 360 QA for UI Framework/Cloud Workflows, and fervent cat enthusiast
Message 6 of 10

@r3deag1e.rzr just wanted to check in and see if there have been any changes on your end, or if you've noticed any extra behavior or problem conditions worth noting.

 

For our part, the nature of this problem unfortunately makes it difficult to diagnose, but as Adaptive Sync becomes more widespread, obviously we want that to be a pleasant end user experience. If anything comes to mind, feel free to continue to post it here.


Lance Carocci
Fusion 360 QA for UI Framework/Cloud Workflows, and fervent cat enthusiast
Message 7 of 10

I haven't been using it much lately so I couldn't tell you but I did try it
today and it was working fine.
Message 8 of 10

This is repost of my reply to the other "solved" gsync post.:
I just found out that if I have Gsync enabled, it will stutter when orbiting. It is very noticeable with a 3d mouse. I do not crash however. I have an FPS counter enabled and it drops to a low 30fps as well after the stutter. If I click out of the program onto my second screen, If I hover back over a sketch, it doesn't drop at all. Nothing in diagnostics or display performance will fix. It was hard to search for this and just found out on my own by enabling and disabling nvidia settings using the control panel. I think I might be able to create a profile for fusion to disable. Looking for the program to create the profile isn't straight forward. Now that it's disabled, It is a dream to use fusion with 144hz 2k monitor.

Message 9 of 10
jmcleodYNLLJ
in reply to: r3deag1e.rzr

Just stumbled across this thread and I'm having the same issues with every release of AutoCAD I've used lately (2020-2024). Same issue that the OP has described, simply clicking and navigating around in AutoCAD and the screen blacks out for a few seconds every time I do anything. I've rebuilt my home machine a few times over the past few years and it's been a constant regardless of hardware and drivers. This includes: i9 10900k w/ a 3080ti, i9 12900k w/ a 3090ti, and currently an i9 13900k w/ a 4090. I always run the latest Nvidia drivers and it issue persists regardless if it's the Game Ready or Studio.

I've adjusted frame rates, color settings, etc. I've toggled G-Sync for windowed & full screen along with just full screen. The only thing that gets this issue to stop is completely turning off G-Sync. This has been true over the multiple displays I've had over the years and currently running an ASUS PG42UQ 4k display at 138hz.

Autodesk needs to do something about this...

Message 10 of 10

@jmcleodYNLLJ, to my knowledge, Gsync performance issues from the era of this thread were fixed after NVidia released a new driver version (517.40), so if it is indeed the same behavior, it should have been fixed with a driver update.

 

That said, the issue as reported applied to Fusion 360 - I would reach out to the AutoCAD team with a new thread and along with some application logs and graphics driver info (such as a DXdiag report).


Lance Carocci
Fusion 360 QA for UI Framework/Cloud Workflows, and fervent cat enthusiast

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums