Community
Fusion Support
Report issues, bugs, and or unexpected behaviors you’re seeing. Share Fusion (formerly Fusion 360) issues here and get support from the community as well as the Fusion team.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Fusion 360 Installation Issue - Errno 22 Invalid Argument

11 REPLIES 11
Reply
Message 1 of 12
renato.v.michel
204 Views, 11 Replies

Fusion 360 Installation Issue - Errno 22 Invalid Argument

Hi,

I have tried all the suggestions from the forum but I'm still not able to install/reinstall/uninstall my Fusion 360 after I had a Windows issue.

Please check attached my logs

11 REPLIES 11
Message 2 of 12

Message 3 of 12

Hey @RajkumarIlanchelian yes, I did, I even deleted the registry associated with Autodesk

Message 4 of 12

@renato.v.michel What was the windows issue you had and how did you address that? I am sure you did this but I assume you did a machine restart and that is also not helping? 

Currently do you have Fusion installed that you are trying to update of are you trying to install fresh version of Fusion? 

Rajkumar Ilanchelian
Autodesk Fusion

Join Fusion Insider

Message 5 of 12

Hey @RajkumarIlanchelian 

So I don't exactly know what happened, but my PC was stuck on the booting process and never wanted to leave it, so I had to reset Windows, as SafeMode and all possible solutions were not working.

So I just had to reset Windows maintaining all my files, but I did not format my PC!

I just reset Windows and keep my personal files. similar to the process from this video 

Message 6 of 12

@renato.v.michel Thank you for the details. 

So right now on your machine do you have Fusion 360 installed? Or are you trying to uninstall and reinstall? 

Rajkumar Ilanchelian
Autodesk Fusion

Join Fusion Insider

Message 7 of 12

@RajkumarIlanchelian I don't have it installed, as when I did the reset of Windows I lost all the apps installed!

I tried to install Fusion 360 but at 99% it gives me the errno 22 Invalid Argument (without further information)

Message 8 of 12

@renato.v.michel Can you go to the below location:

1.  C:\Users\YOUR ID\AppData\Local\Autodesk\webdeploy\production\6a0c9611291d45bb9226980209917c3d\FusionLauncher.exe

2. Do you see this folder and this launcher? If you do this launcher does launching from here start Fusion 360? 

3. IF you do not see this exe can you grab a screen shot of what you see in C:\Users\YOUR ID\AppData\Local\Autodesk\webdeploy\production\

Rajkumar Ilanchelian
Autodesk Fusion

Join Fusion Insider

Message 9 of 12

@RajkumarIlanchelian 

As you can see below I have the Launcher but when I try to launch it this error occurs

renatovmichel_0-1697061455296.png

 

Message 10 of 12

@renato.v.michel Can you try the below article related to this error, please? 

https://www.autodesk.com/support/technical/article/caas/sfdcarticles/sfdcarticles/Error-Configuratio...

I am also going to look at one other possibility here based on the error. 

Rajkumar Ilanchelian
Autodesk Fusion

Join Fusion Insider

Message 11 of 12

Hey, @RajkumarIlanchelian thank you for the assistance, but this morning I decided to just reset Windows again and also remove all personal files. 

This way I do not risk having the same error with other apps that I might come to install.

I just to let you know that I have install Fusion again after this second reset and it installed correctly!

Message 12 of 12

@renato.v.michel @Glad to know the install completed fine. Our engineering team took a look at the logs and it seemed like the install was having issues to create the desktop shortcut. Was going to do for a couple more info here but glad you have it installed now. 

Rajkumar Ilanchelian
Autodesk Fusion

Join Fusion Insider

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums