Community
Fusion Support
Report issues, bugs, and or unexpected behaviors you’re seeing. Share Fusion (formerly Fusion 360) issues here and get support from the community as well as the Fusion team.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Feedback on High DPI scaling in latest update (2.0.15775)

14 REPLIES 14
Reply
Message 1 of 15
Bjanders
758 Views, 14 Replies

Feedback on High DPI scaling in latest update (2.0.15775)

(Sorry, I didn't initially notice the other post on the same subject: high DPI scaling completely broken with most recent update)

 

To me the High DPI setting degraded in the latest update. For example the rotation gizmo looks jagged:

Bjanders_0-1681155567911.png

and some tool icons as well:

Bjanders_1-1681155618228.png

In the previous release they were perfectly smooth. It looks the same with both the HighDPIScaling preview feature and the Windows High DPI scaling override. (Previously I have only used the Windows method, but now tried the preview feature to see if it was any better; but it wasn't.)

 

I'm using 125% scaling on a 4k 27" monitor.

 

Edit: And sketches and 3D objects look horrible:

Bjanders_0-1681156317967.png

 

Bjanders_0-1681156637823.png

 

Some things are perfectly sharp, other are horribly jagged like the above.  For example the hole icon is sharp:

Bjanders_1-1681156432741.png

It seems like certain angled lines are causing problems.

It's so bad, that I want to revert to the previous version. Is that possible?

 

Edit2: I get motion sickness using it:

fusion.gif

14 REPLIES 14
Message 2 of 15
mbelusa.mail
in reply to: Bjanders

The many users report it to folks from autodesk but still without any answer like ok we fix it soon .... really nice support!

Message 3 of 15
Bjanders
in reply to: Bjanders

It's fixed now in v.2.0.15995. Thanks for the quick fix!

 

Edit: I removed the "accept solution" as it seems to be still broken. It only worked temporarily for some reason. See below for more feedback.

Message 4 of 15
Bjanders
in reply to: Bjanders

The jagged lines are back! For me it now again looks exactly the same in 2.0.15995 as in 2.0.15775. I maybe rebooted Windows in between. It looked fine after the updated to 2.0.15995, but now when I started Fusion 360 it again looks bad with scaling.

Message 5 of 15
MAS.DPL
in reply to: Bjanders

Yep ...   I was super excited when I applied  update  2.0.15995 x86_64 - rebooted Fusion and it seemed to have fixed the issue with the 4K monitor scaling at 125% and high DPI preview working.

BUT 
When  next rebooted the whole PC,  the issue was back MASDPL_0-1681729503307.png

 

  - and now to get fusion working Ok I am back to 100% scaling on a 4K monitor and having to wear glasses 👓 !
sorry to bear bad news - looking forward to a proper fix. 
Message 6 of 15
Bjanders
in reply to: Bjanders

Could this have anything to do with the latest Windows update? I just noticed I received the Fusion update on Friday April 14th, and scaling worked as expected. Then later that same day I received 2023-04 Cumulative Update for Windows 10 Version 21H2 (KB5025221). Rebooted, and after this Fusion scaling did not work anymore.

Message 7 of 15

@Bjanders @MAS.DPL When this original problem occurred do you remember setting up an environmental variable as workaround? IF you did can you remove that and see if this help? We are testing this again internally to see if just a restart of a machine undo the changes. 

Rajkumar Ilanchelian
Autodesk Fusion

Join Fusion Insider

Message 8 of 15

TBH , No I didn't 'touch environmental variable' as workaround  - as we prefer  not to mess with system stuff if possible, as a working PC is 'mission critical'. All other apps work fine without such tweaks.  

Message 9 of 15

I haven't tried any special workarounds like setting environment variables, either now or earlier. The only settings related to this that I have used:

- The High DPI scaling override:

Bjanders_0-1681982600397.png

- The HighDPIScaling preview feature in Fusion 360

 

I've tried all combinations of enabling/disabling those two. I had the override off in Windows and the preview feature on in Fusion when it stopped working after the reboot.

 

Message 10 of 15
mainarx
in reply to: Bjanders

I wonder how they did QA on this?

 

mainarx_0-1681982878747.png

mainarx_1-1681983031613.png

 

Message 11 of 15
MAS.DPL
in reply to: Bjanders

Here is a work-a-round solution to get BOTH 125% scaling on a 4K monitor (which is the default for people with normal eyesight) AND sharp Fusion360 - WITHOUT  'Jaggy' (no anti alias)  ..OR.. Fuzzy (low rez). 

The issue seems to be that Windows resets the 'High DPI set' in preview, preferences on every boot up.

 

SO:

1. Use 125% scaling on the 4K monitor - which will work well for all other apps, desktop (and now fusion).

2. Set Fusion to start with windows (or manually start)  (eg put a shortcut to Autodesk  fusionlauncher.exe into startup folder0

[ Fusion is:  in C:\Users\XXXXX\AppData\Local\Autodesk\webdeploy\production\6a0c9611291d45bb9226980209917c3d\FusionLauncher.exe  and Startup is: C:\Users\XXXX\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup ] 

3. With Fusion booted without  'High DPI set' in preview - now set  'High DPI' in preview to ON (tick) .. and restart as asked. 

4. Fusion is Sharp (no jaggy or fuzzy screen) - as it did before April 23 update. Remember to turn off 'High DPI set' in preview before Fusion is shut down, ready for next day .. 1. 2. 3. 

 

I  hope this helps until the issue is fixed without windows messing with 'High DPI' in preview 

Message 12 of 15

I can get it looking good in 125% scaling in 4k by doing the following:

- Disable HighDPIScaling preview feature

- Restart Fusion

- Enable HighDPIScaling

- Restart Fusion

 

 After this scaling looks as it should. It's sharp with no jagged lines.

 

I only tried the above once after the latest update, 2.0.16007, so I can't say for sure if it is repeatable. But it seems to align with what MAS.DPL says, that the HighDPIScaling setting seems to reset itself (even though it is set in the Fusion settings), and that you have to reenable it to take effect.

 

Edit: I can now confirm, this is repeatable. I have to disable and reenable HighDPIScaling every time, and then it works. So this is basically what MAS.DPL suggested as well.

 

Message 13 of 15
MAS.DPL
in reply to: Bjanders

Glad it worked for you too 👍

Message 14 of 15

I hope this is still being investigated. It's really frustrating to restart Fusion three times every time I start using it.

Message 15 of 15

The problem persists in the latest update as well (2.0.16265), but it now looks slightly different, compared to the previous release, when it doesn't work, i.e., when first starting Fusion. The lines are not as jagged as before, but the scaling does not work. This is how it looks with HighDPIScaling enabled when you exit Fusion and start it again:

Bjanders_0-1685866437953.png

Bjanders_1-1685866528362.png

 

Bjanders_2-1685866560550.png

Then when you disable HighDPIScaling, restart Fusion, then enable HighDPIScaling again, and Fusion asks to restart then looks like it should:

Bjanders_3-1685866847025.png

Bjanders_4-1685866881174.png

 

If there is anything you want me to do to help resolve this issue, please ask. I'm willing to help and test things out.

 

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report