Community
Fusion Support
Report issues, bugs, and or unexpected behaviors you’re seeing. Share Fusion (formerly Fusion 360) issues here and get support from the community as well as the Fusion team.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Exporting to STEP file and loading into Solidworks, does not show bodies

7 REPLIES 7
SOLVED
Reply
Message 1 of 8
chrismerrell
168 Views, 7 Replies

Exporting to STEP file and loading into Solidworks, does not show bodies

I am having a major issue with Fusion when I am importing projects, which have originally come from Revit to DWG to Fusion. When I export as a STEP file and load into SolidWorks the walls, floors, roofs and any Model in Place families are not showing up. They appear in STEP file viewers but not Solidworks. 
I have worked out that any element categorised as a Body by Fusion is not exporting. I have to drag all the bodies and drop to combine with another part, for the export to work.

Model in place families in Revit also do not show, I am now having to convert all of them to normal families to show.

 

I have done this method several times before and not had these issues. Has the recent update caused this?

7 REPLIES 7
Message 2 of 8

@chrismerrell 

Can you File>Export your *.f3d file to your local drive and then Attach it here to a Reply?

(Only need example of one of each type that does not translate.)

 

What version of STEP is the SOLIDWORKS set to import?

Message 3 of 8

Here is a trimmed down version of it. 
As mentioned, anything under the category of Bodies and from Revit model in place families (which an example is the large blue boxes on the attached) do not appear in SolidWorks when exported as a STEP.

 

But when I drag any Bodies and drop onto another non-body element they do appear in the export. I have learnt that if I move all of the Bodies, then nothing appears in the export. I have to leave one body in the list for anything to export..... so I am having to copy and paste the last body to the same place so no element is missing.

 

Thank you

Message 4 of 8

@chrismerrell 

First thing I notice is that your geometry is at least 954 Meters from the Origin.

Can you move the geometry to centered about the Origin (more or less) and try again?

Message 5 of 8

Ah thank you, having moved it to 0,0 it seems to have resolved the issue with the bodies (walls, floors, roofs), but still any MiP families are not showing through. 

Message 6 of 8
jeff_strater
in reply to: chrismerrell

Can you point out which components/bodies/etc are not exported?  I tried a quick round-trip (Fusion->STEP->Fusion), and I did not see anything obvious missing, but there are a lot of components/bodies here.  I did notice that the F3D contains sketches, which are not exported to STEP in Fusion (by design).  Is that the issue?

 


Jeff Strater
Engineering Director
Message 7 of 8
chrismerrell
in reply to: jeff_strater

Hi,

 

When I export the STEP from Fusion, the items highlighted red are missing in SolidWorks.

The ones in green were those that were initially missing, but when I changed them from Model in Place families to normal Families in Revit, they came through, which is currently my only work around. Thank you.
[image attached]

Message 8 of 8
jeff_strater
in reply to: chrismerrell

I know that this will not be satisfying, and does not help you, but those components do exist when I re-import the STEP into Fusion.  So, they are in the STEP file.  Which seems to indicate that the problem is on the Solidworks import, not the Fusion export.

 

Screenshot 2024-02-14 at 10.05.32 AM.png


Jeff Strater
Engineering Director

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report