Community
Fusion Support
Report issues, bugs, and or unexpected behaviors you’re seeing. Share Fusion (formerly Fusion 360) issues here and get support from the community as well as the Fusion team.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Custom Drawing Template not Saving

9 REPLIES 9
Reply
Message 1 of 10
CaducatorSupport
907 Views, 9 Replies

Custom Drawing Template not Saving

There appears to be an issue with the creation and save of a custom drawing template.  I have not been able to identify any specifics about what is causing it but here is what I have done and the results.

 

1. Created a custom multi-sheet drawing template from a created/saved drawing.  This was multi-sheet and contained a a few custom title blocks as well as views from the assembly and storyboard.  The original drawing was 3 sheets and i added a sheet to the template.  When trying to save this in the project location it just hangs saying that it is uploading and then disappears from the data panel.

2. Create a custom multi-sheet drawing template from a created/saved drawing sames as (1.).  Saved this to a sub-folder in a project but it just hangs saying it is uploading and then disappears.

3. Create a custom single sheet drawing template from a created/saved drawing of a single component with no custom titleblock. This one saves just fine.

4. Created a custom multi-sheet drawing template from a created/saved drawing same as (1.), but without the addition of a 4th sheet not shown in the basis file for the template.  This one just hangs.

5. Created a simple single sheet drawing from the storyboard of the assembly(used in 1.) and made a drawing template off that.  Saves just fine.

6. Created a custom drawing template from scratch using a single sheet/single view.  This one saves just fine no matter the location.

7. Created a custom drawing template from the storyboard of the assembly (1.) that saves just fine but with a custom titleblock and it saves just fine.  

8. Create a custom drawing template same as 7. but with the addition of an image/logo.  Saves just fine.

 

I haven't been able to identify the root cause.  It doesn't appear to be the assembly itself, the file name or the save location.  The addition of a custom title block with or without logo image(.png) doesn't seem to affect new templates ability to save.  I have tried with and without a parts lists, multiple sheets, different views. custom title blocks.  Here are the specifics of the original drawing file that appear to be hanging up.  For what it's worth i did try this before and after the update yesterday with the same results.  Cleared my non-data cache and neither have affected the results.

 

Sheet 1 - Assembly view with 9 components suppressed.  Custom title block created in Fusion with text, lines and a logo(png) added.

Sheet 2 - Storyboard exploded view with 9 components suppressed.  Custom title block and a parts table with balloons renumbered.

Sheet 3 - Storyboard exploded view with all but 1 component(including sub components) suppressed.  Custom title block and a parts table.

 

I can't currently share the files as they are not public and i can get around this issue but was hoping to shed some light on a potential hang-up.

Tags (2)
9 REPLIES 9
Message 2 of 10
belstain
in reply to: CaducatorSupport

Drawings in Fusion are still a joke. I have the same problem trying to create drawing templates. Template fails to save and eventually causes warnings when I try to close Fusion that a file is not uploaded yet. Quite pathetic that they continue to add new advanced features but can't get basic functionality to work even after years. 

Message 3 of 10
Naureka
in reply to: CaducatorSupport

This issue is still not fixed...

I try to save a custom drawing template made from previous drawing and any attempt to upload fails. In my case I'm unable to save any template, no matter what it contains. Upload takes forever and then dissapears.

 

When I created a new template from scratch it was uploaded without problems.

 

Then I tried to copy-paste a title block from another drawing to newly created one and it crashed the whole application. I had to kill it with Windows Task Manager. That's pathetic. 😂

Message 4 of 10
g-andresen
in reply to: Naureka

Hi,

try this way:

1. create custom template with your titleblock > save

2. open existing drawing

3. add new sheet > "my new template" 

4. change titleblock of your first (existing) drawing

 

No Copy / Paste!

 

Screencast

 

günther

Message 5 of 10
Naureka
in reply to: g-andresen

Thanks for help. But it won't do in my case.

 

I created a drawing with my custom company title block. It literally took me a few hours of swearing. Gently speaking - title block editor in Fusion 360 is not the best quality and using it is far away from pleasure. But I managed. 😉

 

I naively assumed that I'll be able to easily create a template later on, based on this initial drawing. And yes - I can. But for some reason I'm unable to save it afterwards. Opening a drawing and saving it as a template also does not work. So there is no way I can now extract a title block from an existing drawing to drawing template. Copy/paste crashes the whole application.

 

Is there a way to do that wihout redrawing everything from scratch?

Message 6 of 10

I have the exact same issue. I cannot save any drawing template for future use, or use a saved title block between projects. So, I have to redraw the template from scratch every time I make a drawing. This is pretty silly, something so basic as a template is unusable. 

Message 7 of 10

Hi,

1. The creation of your own templates is not possible with the Personal license.

2. DWG title blocks can only be inserted if they are not referenced (XRef).

 

günther

Message 8 of 10
Naureka
in reply to: edwardh_elginusa

I can't exactly tell you what is the cause of your problems, but mine seemed to be triggered by non-english characters inside the title block template. They caused a file corruption that was propagated forward to every other drawing trying to derive this particular title block. It caused unpredictable behaviour and crashes during every save(upload) attempt. Surprisingly, the root file, which was the source of the original title block, works and saves just fine.

 

After I removed all these characters and used only US letters in the title block all the problems were gone. I was able to generate a template file based on it without any issues. Looks like some obvious software bug.

Message 9 of 10

This is my Fusion Bug Of The Day (well, actually it's my second...). I created a drawing from a custom template, modified the title block and a few other things slightly, and tried to save out a new template (the new drawing saved just fine), and it just hangs there and refuses to upload. I've canceled it and tried again with the same result. I've saved project files within that time frame and they uploaded with no problem, so it's not an internet issue.

 

There are no images or non-English letters in my template. Fusion - please fix this bug!

Message 10 of 10
jlarsonLP454
in reply to: jlarsonLP454

I did some testing and found that even if I deleted the title block, note, and placeholder projection from the template (leaving a blank sheet with nothing on it), I still couldn't get it to upload. Let's call this template the "stupid template" since that's what I eventually named it.

 

I then took my previous custom template, saved it as a new version (which uploaded fine), and then copy/pasted the title block and notes from the Stupid Template to this new version so that it was an exact duplicate of the Stupid Template. This saved just fine and after wasting 3 hours I can get back to work.

 

Note that you have to right click on the title block and select "edit title block", then select all the geometry using a window select in order to copy it. Do the same thing to delete the other title block and paste in the one you want. 

 

I'd happily post up the Stupid Template for the Fusion team to debug, but since there's no way to save or export it that's impossible...

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report