Community
Fusion Support
Report issues, bugs, and or unexpected behaviors you’re seeing. Share Fusion (formerly Fusion 360) issues here and get support from the community as well as the Fusion team.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Configurations working extremely slow, am I doing something wrong?

13 REPLIES 13
SOLVED
Reply
Message 1 of 14
steve3957T
324 Views, 13 Replies

Configurations working extremely slow, am I doing something wrong?

Hi everyone,

 

I've been trying to test out some configurations and have been finding them frustratingly slow.  Maybe I'm doing something wrong, here are the steps I'm taking:

 

1. Start a new file, make 2 parameters; length and width.

2. Draw a rectangle using these parameters and extrude into a block

3. Add these parameters to the table and make a few configurations. Change dimensions for each.

4. Start a new design, drag/drop the configured file into the new file (Things start to slow down here. First one takes a couple seconds, second takes 10-15 seconds and it keeps taking longer from there)

5. Go back to configured file and change some dimensions in the configuration table.  Save and close

6. Components in assembly are now expectedly out of date.  Right click and "get latest version".  Fusion now hangs for 2-3 minutes. Maybe it updates the component, maybe I get an error saying "configuration temporarily unavailable".  Seems about 50/50 shot of actually working and always takes over a minute to think about.

 

Is anyone else seeing this slow down?  I'm excited to start using configurations in my designs, but it's pretty much unusable right now unless I can figure out what I'm doing wrong.  Any suggestions are greatly appreciated.

 

-Steve

 

13 REPLIES 13
Message 2 of 14
karina.harper
in reply to: steve3957T

Hi @steve3957T 

 

  • It is expected that the first insert of a Configuration is a little slow - the design basically is being built for the first time in the back end on first insert. Your point about it taking longer each time is interesting. It makes me wonder if there is an improvement we need there specifically.
  • We have had some other folks report that Get Latest is pretty slow as well, we have an improvement coming on this soon.
  • If you can share your log files, that might allow us to isolate which aspect of the workflow is causing the slowdown. how to collect log files

 

Cheers,

Karina

 


Karina Harper

Software QA Engineer, Fusion 360

Fusion 360 Webinars | Contact Support | EDU Support | Support Board Best Practices


Message 3 of 14
steve3957T
in reply to: karina.harper

Hi Karina,

Thanks for the feedback.  One thing I noticed is that after changing some numbers and saving the configured part, the upload progress bar is stopping.  It looks like it's taking several minutes (10-15?) to upload the part after it's saved.  Maybe this is some kind of network issue?  I've attached the log files, so maybe there will be a clue in there.   

 

-Steve

 

Message 4 of 14
karina.harper
in reply to: steve3957T

Hi @steve3957T ,

 

Huh. Your logs show quite a few errors, and it does seem like many of them may be problems accessing ADSK service URLs. Are you using an antivirus? A proxy?The network diagnostic you shared shows that Fusion isn't able to access some critical services. I would recommend following some of these articles to try and make sure Fusion is able to access the services necessary. In particular, How to configure proxy server and firewall for Fusion 360 (Windows). 

 

Have you had issues with Fusion outside of Configurations?

 

Cheers,

Karina

 

 

 


Karina Harper

Software QA Engineer, Fusion 360

Fusion 360 Webinars | Contact Support | EDU Support | Support Board Best Practices


Message 5 of 14
steve3957T
in reply to: karina.harper

I am not using a proxy or antivirus outside of Windows Defender.  I added the exceptions in the article you linked to the Firewall.  I have tried turning off the Firewall and Windows Defender completely and it doesn't seem to make a difference.  Other than the occasional crash, or small slowdown on larger files, I haven't had any other issues with Fusion at all.  These simple configurations are 10x slower than my most complicated designs.

 

I am connected to a LAN that I don't know much about, but if there is anything on that side we should look into, I can pass that information along to our IT guy.

 

-Steve

Message 6 of 14
steve3957T
in reply to: steve3957T

Also should note that the Network Diagnostic Test in Fusion shows no issues
Message 7 of 14
karina.harper
in reply to: steve3957T


I am connected to a LAN that I don't know much about, but if there is anything on that side we should look into, I can pass that information along to our IT guy.


If you're on a corporate network, sometimes they have more restrictive firewalls. Here are some of the problem URLs from the network diagnostic you shared - I'm not sure why it would all be showing green on your end but be throwing these errors in what you sent 🤔

 

{
	"NetworkDiagResults":	[{
			"severity":	"Critical",
			"url":	"https://accounts.autodesk.com",
			"status":	200
		}, {
			"severity":	"Warning",
			"url":	"https://staging.appstreaming.autodesk.com/health",
			"status":	200
		}, {
			"severity":	"Warning",
			"url":	"https://js.prd.fusionapi.autodesk.com/hds/fusion360.json",
			"status":	200
		}, {
			"severity":	"Warning",
			"url":	"https://notifications.api.autodesk.com/health",
			"status":	200
		}, {
			"severity":	"Critical",
			"url":	"https://developer.api.autodesk.com/health",
			"status":	200
		}, {
			"severity":	"Warning",
			"url":	"https://ui-dls360.autodesk.com",
			"status":	200
		}, {
			"severity":	"Critical",
			"url":	"https://www.autodesk.com/products/fusion-360/collaborator",
			"status":	200
		}, {
			"severity":	"Warning",
			"url":	"https://status.launchdarkly.com/",
			"status":	200
		}, {
}

 


Karina Harper

Software QA Engineer, Fusion 360

Fusion 360 Webinars | Contact Support | EDU Support | Support Board Best Practices


Message 8 of 14

Hi Steve
Could you let know if you see a design repair required UI when opening your configured design?

DesignRepairRequired.png

Thanks

Pierre-Yves Monarque
Autodesk Fusion 360 Team
Message 9 of 14

Yes, I have seen this box when opening, but it does not pop up every time. I've only seen it maybe 2-3 times.  I also get a "cloud save failed" message in the Job Status screen sometimes (see attached)

Message 10 of 14

Ok that helps, thanks
If you save new versions of the configured design with modifications to configuration 1, does it now continuously fails to publish in the cloud?
If this is a design you would not mind sharing for investigation, could you share it with me (pierre-yves.monarque@autodesk.com)

Thank you

Pierre-Yves Monarque
Autodesk Fusion 360 Team
Message 11 of 14

Hi, I sent an email with the link as well, but will attach here too for reference.  

https://a360.co/3rC6kEK

 

To answer your question, after changing and saving again, it uploaded to cloud, just really slowly.

 

-Steve

Message 12 of 14

Thanks again Steve for helping us investigating this issue on a call.
Please let know if you hit this again, meanwhile we will investigate generated logs and try to find root cause.
I forgot to ask during the call but if you still have the backup Autodesk Fusion 360 folder could you zip it and send it by email. It would help investigating.

Hope you enjoy configuration now that performances are back to normal.

 

Regards

Pierre-Yves Monarque
Autodesk Fusion 360 Team
Message 13 of 14

Thanks for your help with this, I will be sure to let you know if I see things slowing down again.  I still have the backup, but it is 1gb after compression so I can't send via email, is there another way to send that you would prefer?

Message 14 of 14

If you have one drive sharing there would work for me.
Or you could also create a Fusion Team Project, invite me to it and upload the file there.
Thanks

Pierre-Yves Monarque
Autodesk Fusion 360 Team

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report