Community
Fusion Support
Report issues, bugs, and or unexpected behaviors you’re seeing. Share Fusion (formerly Fusion 360) issues here and get support from the community as well as the Fusion team.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Compute failed "Position calculation failed due to initialization error"

5 REPLIES 5
SOLVED
Reply
Message 1 of 6
pczerwonka98
301 Views, 5 Replies

Compute failed "Position calculation failed due to initialization error"

I'm creating a multifunctional robot, at this point, I worked 520 hours on this model (yes, I'm counting). The problems started when I created a sketch on the top plate of the robot to project faces of other components to later create mounting holes. After I projected the faces on the sketch, I closed the sketch to be able to isolate the top plate and take a look (you can't isolate when in edit in place mode). After I closed the edit in place mode, suddenly every joint broke, like in the screenshot I attached, for some reason, there was no new assembly context with the sketch. Obviously, the first thing I did was try to Ctrl+z the problem. Unfortunately, when I Ctrl+z to the point before the edit in place, the model was still broken, and hitting Ctrl+b changed nothing. Afterwards, I tried to open a version of my main model and the model containing the top plate from before the editing in place, save them as the latest, and update the components. To my surprise, it also didn't fix the problem, I even tried to open assemblies from 2 months ago. I also tried to create a new main assembly, but new joints are having the same problem, and I tried even components that weren't involved in the edit in place operation, like the axis 4 and axis 5 components. I tried to restart Fusion as well as my computer, reinstal Fusion, open the model on another computer. At this point, I don't even know which component or functionality is causing the problem. I'm stressed out because my engineering thesis presentation should at least contain an animation of the model, and now the joints don't work at all. I can't order the aluminum plate because I can't finish it by placing all the mounting holes. I've been trying to solve this problem for a week.

 

Link to the model ( 350 Mb) https://drive.google.com/drive/folders/1t9LI8hepddhcriRRUmiRNN0Z-pQdtMK-?usp=sharing

 

Please let me know what else I could try to solve this problem.

 

With best regards Peter.

 

This is how the model looks when it is working

Working model.PNG

This is how the model looks when it is not working

Broken model.png

 This is the face I wanted to project other faces on.

Face for edit in place sketch.PNG

 

EDIT 12.05

I noticed that when i try to build the robot arm from the end, so from axis 6 all the way to axis 2, it doesn't brake. I can update components, and the joints aren't having a compute error, but they don't work. I can't make the revolute joints move even with the drive joint option.

 

And here is a video that might narrow down the root of the problem. When I try to delete the very first joint, it doesn't really delete, it disappears from the timeline but stays on the list. When I press the motion limit button, Fusion crashes. I don't know if it's related to my main problem, but I found it concerning.

 

5 REPLIES 5
Message 2 of 6

Hi @pczerwonka98 ,

 

We are working to reach the root cause of this issue. In the meantime can you please try the following and see if this fixes the joints in your Full Assembly.

 

1. Open Axis3 assembly.

2. Traverse to Axis3 worm gear -> Nema 17 38mm assembly -> Nema 17 38mm -> Stepper motor -> Joints -> RigidGroup 1

3. Edit in Place "Nema 17 38mm"

4. Delete RigidGroup 1

5. Save Axis3 assembly.

6. Get All Latest in "FULL Assembly".

 

Is the first joint in your timeline error free now?

Message 3 of 6

Hi @pczerwonka98 ,

  

I tried to repair your file , here is the repaired file - https://autode.sk/3OggBj2 

I no longer see the joint errors. Please let me know if this works for you.

Message 4 of 6
pczerwonka98
in reply to: pczerwonka98

Hi @mayank.malukani 

After deleting the rigid group the first joint was indeed error free.

The link didn't work for me so i tried to rework all stepper motors in my assembly by changing rigit groups to as-built joint. And it worked !!! Right now everything works.

 

Have I done something wrong? I mean, rigid group is a useful feature, and now I'm afraid to use it.

Message 5 of 6

Hi @pczerwonka98 ,

 

Glad to hear the design works for you now.

As I mentioned, we are working on finding the root cause of this issue, and I don't think there is anything wrong done from your side. You can continue to use RigidGroup, they are stable and are similar to Rigid As Built joint, just with multiple participants.

 

 

Message 6 of 6
pczerwonka98
in reply to: pczerwonka98

Hi @mayank.malukani, 

Thank you very much for your help.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report