Community
Fusion Support
Report issues, bugs, and or unexpected behaviors you’re seeing. Share Fusion (formerly Fusion 360) issues here and get support from the community as well as the Fusion team.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Bug Report - adding a dimension to a sketch line makes it swap to the wrong direction

21 REPLIES 21
Reply
Message 1 of 22
OceanHydroAU
940 Views, 21 Replies

Bug Report - adding a dimension to a sketch line makes it swap to the wrong direction

My Left-to-right line swaps to being right-to-left (wrong way) when I try to add a dimension to it.

 

Screenshot shows example:

https://autode.sk/3219Atc

 

Attached file is the component in case you need to know how to replicate this problem.

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Tags (1)
Labels (1)
21 REPLIES 21
Message 2 of 22
davebYYPCU
in reply to: OceanHydroAU

Your sketch is so unstable I can get it to work if, 

You delete the other two lines under / over it, but that may not suit.

Not unexpected with undefined sketches, but got to start somewhere.

There are duplicate sketch points over the origin, so had trouble with those too. 

Centre line is not related to the origin.

wspoi.PNG

Might help.....

Message 3 of 22
OceanHydroAU
in reply to: davebYYPCU

Hi Dave - this is a bug report: something for the Fusion360 team to fix.

 

I shared the component so it makes it easy for them to find where their mistake is.

 

And yes - I'm aware the sketch is a mess - I was experimenting with stuff - it's not a production project !

Message 4 of 22
davebYYPCU
in reply to: OceanHydroAU

Catch 22.  Not a bug, if the outcome is legitimate, but unwanted.

Robust sketching will not lead to multiple outcomes.  

 

Will await the devs outlook on it.

Message 5 of 22
OceanHydroAU
in reply to: davebYYPCU

Of course this IS A BUG.  Adding a dimension to an EXISTING line should NEVER make the line swap directions and become totally unusable (as you know, negative dimensions are not allowed).

 

It is totally irrelevant any underlying sketch objects - when the UI screws up an existing line, that's a bug.

Message 6 of 22
davebYYPCU
in reply to: OceanHydroAU

I am not going to argue the definition of a bug.

Unwanted result, yes, unexpected behaviour, yes, legitimate result, yes.

Your line is correct length, still coincident to the anchor point, horizontal, but not fully defined.  You have three overlapping lines connected to the spline curve, on the same point.

 

My experience is that Fusion gets confused with such multiples that are undefined.

 

Removing the multiples, did not remove the first dimension, it did behave as expected, still is a legitimate result, albeit with an unwanted process.

 

Bug or not you can proceed, if you are wishing to.

10 / 10 undefined Sketches is not worth shouting about, your 11th sketch is empty but fully defined.

 

Might help....

 

 

 

 

Message 7 of 22

Yes I experience this issue pretty often. It seems that Fusion stores no data about what "side" of a line or feature something is relative to it. If you sketch vertical line, then sketch a circle to the right side and make a 5mm dimension from the circle to the line, Fusion is unable to know whether the circle should be 5mm to the right side of the line or the left side. Sometimes it just decides it  should be on the other side from where you want it when you add the dimension. I have found no pattern to when this will happen or how to keep it from happening. It can happen even if everything else is fully constrained. You could try to fix it by making another, horizontal construction line between the first vertical one and the circle but again, Fusion doesn't know if that construction line should be on the right or left side so it still won't help. I've had entire sketches with many (fully constrained) entities completely flip upside-down after changing the value of a parameter.

I agree that it's a bug, or rather a pretty fundamental flaw in the design of the software. If they could add some metadata to internally capture the relative positioning of sketch entities it would solve the problem, though I know that would not be an easy thing to implement.

Message 8 of 22

 Just to reiterate, this has happened to me multipe times on sketches that were 100% fully constrained. Every entity was defined and constrained, everything showing white. But then I change a dimension or a parameter that controls some dimensions and the whole sketch flips upside down. Because I believe Fusion does not store any data about the relative positions of any two sketch entites, there are two possible solutions for every coicident constraint or dimension and this ambiguity leads to unexpected and unwanted behavior.

Message 9 of 22

Fully defining sketches as you create them is best practise and will help in most cases, as always rules are meant to be broken, and it is not always possible.

 

If it flips, I take it as the warning, - I have to add more work to prevent it. 

 

Might help...

Message 10 of 22

Yes I always fully define and constrain all of my sketches, and this flipping behavior still happens. I have attached a screencast showing this. In the screencast, I have some projected edges in my sketch. I create a construction circle with a defined diameter, and an offset with a defined value. I add a dimension of 8mm to a horizontal projection line. Then to finally constrain it completely, I add another dimension of 8mm to a (more or less) vertical projected line, but when I do this, the circle flips over to be above the horizontal projected line instead of below it as it was originally defined. This shows that Fusion doesn't know whether it should be above or below, so there are two possible solutions to all of the constraints and dimensions. This is the issue, there should only ever be one solution to a fully constrained sketch entity.

 
<iframe width="640" height="620" src="https://screencast.autodesk.com/Embed/Timeline/0e4f418f-565b-4519-a458-c8b58f233012" frameborder="0" allowfullscreen webkitallowfullscreen></iframe>
 
 
 
 
 
 
 
 
 
 
 
Message 11 of 22

This bug has been born by someones arbitrary decision in the past to ban negative dimensions.

 

Ideally - the Fusion 360 team should get rid of that idea, and remove every hack and kludge they've since added that attempted to enforce this poorly-thought-out rule.

 

In parametric designs, it can often make sense for something that's +1 in one direction to need to adjust to be -1 (i.e. +1 in the opposite direction) to satisfy whatever parameter adjustments are taking place.

 

I have to keep "working around" that annoyance by creating giant (e.g. 100 units) lines in the wrong direction, then defining things to be themselves plus that line (so 101 can become 99 instead of +1 breaking when it tried to become -1).

Message 12 of 22

I agree that negative dimensions would be very useful for parametric design and I think there isn't really a good reason to not allow them, but I think that there's an even deeper underlying issue that would make enabling negative dimensions impossible. If Fusion does not capture the relative positions of the sketch entities (which it seems like is the case), then it wouldn't be able to even tell the difference between a negative and positive dimension. If you look at my screencast above, I entered a value for the first dimension to be below the line and yet when I added another dimension, the first dimension flipped to the opposite side above the line it was originally set to, basically making it a negative dimension. They at least need to first overhaul the sketch code to capture the relative positions of sketch entities, then they would at least have the foundation to be able to implement negative dimensions.

Message 13 of 22

Hello @OceanHydroAU 

 

Thank you for reporting the bug. I have logged the ticket for the team to take a look at.

 

@therealsamchaney can you please share the model which showed flipping in your screencast video? That will help us debugging the issue.

 

Thank you,

Best Regards

Rohit Bapat

(Product Owner)





Rohit Bapat
Product Owner
Message 14 of 22
zielonkaNA797
in reply to: rohit.bapat

@rohit.bapatAny update on this one? Maybe some workaround?

Message 15 of 22
rohit.bapat
in reply to: OceanHydroAU

Hello @zielonkaNA797 

 

We have fixed the issue mentioned in the original post in this thread. Are you facing any flipping issues?

Can you please share the dataset and some steps to reproduce the issue?

 

Thank you,

Best Regards

Rohit Bapat





Rohit Bapat
Product Owner
Message 16 of 22
kfenyvesi
in reply to: rohit.bapat

Hi,

I'm facing a similar issue with a parametric sketch. Changing D beyond a few mms makes a line and all the elements linked to it flip 180 degrees so relative position capturing might be the issue as someone mentioned. Yes, it's the same angle between two lines but it computes for minutes until it can draw the completely messed up spline pattern whenever it flips because it has to draw a much more complex spline on the flipped geometry. This is really annoying. I've tried recreating it and constraining it in different ways but this issue plagues parametric fusion360 designs. 

I've attached the f3d file. Changing the parameter D by 10 mm or so should recreate the bug. 

I'll attach a before-after image below. I changed D from 130mm to 140mm, it took my crappy notebook about 4 minutes to compute. When it's not flipping, recomputing takes only a second or so. Changing the dimension gradually in 2-3mm increments works fine. 5mm change also seems to be fine. It's around 8-9mms of change when the flipping happens. 

kfenyvesi_0-1627304957622.png

kfenyvesi_1-1627305150209.png

Thank you for looking into these bugs, keep it up!

Best Regards,

Kaba

 

Message 17 of 22
jeff_strater
in reply to: OceanHydroAU

@kfenyvesi - we will investigate the flipping issue, and appreciate your sharing the file.  However, if you are looking for advice here (how to get better results, and more efficient compute), I would recommend doing the patterning in the solid instead of the sketch.  Model one set of the geometry, and pattern that instead.  Bug FUS-87612 created for this model


Jeff Strater
Engineering Director
Message 18 of 22
kfenyvesi
in reply to: jeff_strater

Great advice and thank you for looking into it!

 

Message 19 of 22
TrippyLighting
in reply to: kfenyvesi

@kfenyvesi looking a the timeline, you have created a bit of a mine field.

A mechanical design such as your should not include any move commands and you probably don't want to convert bodies into components, but start by creating a component. See Fusion 360's R.U.L.E #1

Peter Doering
Message 20 of 22
roskamxa
in reply to: OceanHydroAU

Hello,

 

I think the problem is still there in the latest version.

 

(I'm a beginner, I may be missing something). I'm playing with it for one hour and half and it always move to the other side if I enter the value 0 once. It's probably a border case but still worth to report it I think.

Feel free to point me to the right direction if I'm wrong. And don't hesitate to tell me if more info are needed.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report