Community
Fusion Support
Report issues, bugs, and or unexpected behaviors you’re seeing. Share Fusion (formerly Fusion 360) issues here and get support from the community as well as the Fusion team.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

BUG: Microsoft WebView2 required to sign in. WebView2 Runtime is already installed. Update* More serious issues.

31 REPLIES 31
Reply
Message 1 of 32
NathanNation
4405 Views, 31 Replies

BUG: Microsoft WebView2 required to sign in. WebView2 Runtime is already installed. Update* More serious issues.

Frequent and fluent F360 user, never had any serious issues over the last year.  Opening F360 today and was greeted with a fresh login which doesn't happen often, usually I'm just right back in. Upon hitting "Sign In" I get a warning :

"To sign into Fusion 360, you need the Microsoft WebView2 component which is missing from your computer. You can download it directly from Microsoft using the Evergreen Standalone Installer method appropriate for your device."

I acquired the Evergreen Standalone Installer for the latest MS WebView2 component. Upon running it, the software reports WebView2 is already installed on this machine. The fact that I've signed in before- I can't help but wonder if this may have been caused by an update somewhere? Tried all the basics. Any help greatly appreciated.

 

Capture.PNG



Tags (2)
31 REPLIES 31
Message 2 of 32
NathanNation
in reply to: NathanNation

A lovely development. I have uninstalled and reinstalled F360 twice, and on the second try "Sign In" magically worked. How great. Now that I'm back in the software- It say's I have no license and I sure that's not the case. What the actual heck is going on @Anonymous 

AA.PNG

BB.PNG

  

Message 3 of 32
JaneFan
in reply to: NathanNation

Hi @NathanNation ,

 

The first WebView2 issue seems to be caused by the initial WebView2 not being installed correctly, but looks like you've already got it worked afterwards.

Does the expiration issue still exist? If it still exists, how about log out and log in again? Besides, would you please provide log files so that we can look into what happened?
Fusion 360 logs location:

  • Windows:
    • C:\Users\(username)\Appdata\Local\Autodesk\Autodesk Fusion 360\(Alphanumeric Folder)\logs  (Look for all *.log files.)
    • C:\Users\(username)\Appdata\Local\Autodesk\Autodesk Fusion 360\logs  (Look for all *.log files. Logs here when login is unsuccessful.)
  • macOS:
    • Macintosh HD>Users>(username)>Library>Application Support>Autodesk>Autodesk Fusion 360>(Alphanumeric Folder)>logs  (Look for all *.log files)
    • Macintosh HD>Users>(username)>Library>Application Support>Autodesk>Autodesk Fusion 360>logs  (Look for all *.log files. Logs here when login is unsuccessful.) 

Id Services Log File location on version 2.0.15775 or newer:

  • Windows OS: %localappdata%\Autodesk\Identity Services\Log\IdServices.log
  • macOS: ~/Library/Application Support/Autodesk/Identity Services/Log/IdServices.log



Jane Fan
Inventor QA Engineer
Message 4 of 32
NathanNation
in reply to: NathanNation

Here are all available logs.

Message 5 of 32
NathanNation
in reply to: NathanNation

Bumping for any help. No access still to any of my paid products.

Message 6 of 32

I have the same Problem. cannot login! Tells me I need Webview2 after downloading and installling it says its already installed. cannot use Fusion360! 

Message 7 of 32
JaneFan
in reply to: NathanNation

Hi Nathan,

I am asking the team why your paid account shows as expired. WIP.

Thanks for providing Fusion logs, other than that, would you please provide identity service logs?

Id Services Log File location on version 2.0.15775 or newer: Windows OS: %localappdata%\Autodesk\Identity Services\Log\IdServices.log macOS: ~/Library/Application Support/Autodesk/Identity Services/Log/IdServices.log




Jane Fan
Inventor QA Engineer
Message 8 of 32

Hi Joseph,

Does it help if you uninstall Webview2 from control panel and reinstall it with the new download from https://developer.microsoft.com/en-us/microsoft-edge/webview2/#download-section with anyone that matches your OS?



Jane Fan
Inventor QA Engineer
Message 9 of 32
ethan_ungerb
in reply to: NathanNation

extremely odd, having the same issue on my personal computer and my macbook, im in bootcamp for mac which allows me to boot into windows no issues whatsoever and my personal computer runs windows pro version and seem to get the same error message on both devices. i also noticed this has only popped up 5 days ago and every reply has been recent, no windows updates or software changes. im wondering if im wasting my money with this software, whether they dont care about their customers or whatever the case is, fix it.

Message 10 of 32
JaneFan
in reply to: ethan_ungerb

Hi @ethan_ungerb,

Wondering if uninstall and reinstall can get WebView2 install successfully. If it doesn't work, probably some unexpected DLLs left or missing on the system that blocks WebView2 installation. Would you find WebView2 install log so that we can see why it fails to be installed?




Jane Fan
Inventor QA Engineer
Message 11 of 32
DevWolf
in reply to: NathanNation

Same issue here. It worked 2 weeks ago, nothing has changed. Now it says webview2 is not installed. Yes it is. And when I try to reinstall it, it says as such. This is something new. It didn't happen till that last update was pushed. This needs to be addressed.

Message 12 of 32
DevWolf
in reply to: JaneFan

Tried that, didnt work for me. Even tried rolling back windows updates, no luck. Why is webview even a factor here??? Nobody uses Edge, we cant stand that thing. Why is Fusion using it? Get it off...

Message 13 of 32
ethan_ungerb
in reply to: DevWolf

Yeah bro, its totally fine though. I understand that developers make
mistakes sometimes i do too, just make sure that something fixes it soon as
i need it for a project and have relied on fusion 360 for the past few
years on another account. Im using my school enterprise account and
downloaded it on my windows bootcamp, i tested it in a virtual machine on
my pc with all drivers updated and still didnt work 😞 . Hope something
happens soon, have a good day.
Message 14 of 32
JaneFan
in reply to: NathanNation

Hi @ethan_ungerb  and @DevWolf ,

 

Fusion requires webview2 to be installed for the new sign in method. Would you please try to uninstall WebView2 from control panel before installing new version from https://developer.microsoft.com/en-us/microsoft-edge/webview2/#download-section?
The WebView2 in control panel which you need uninstall if old version exists before install new:
Image 2023-4-17 at 19.37.jpeg




Jane Fan
Inventor QA Engineer
Message 15 of 32
ethan_ungerb
in reply to: JaneFan

I have already tried that, after that didn’t work i opened up a completely
new windows 10 virtual machine with WebView2 and it still didn’t work. I’m
using sketchup 2017 for now 🙂
Message 16 of 32
vtu11882
in reply to: NathanNation

Hey,

i am also facing same issue. if you got any solution, can you tell me

Message 17 of 32
mancuso99NVD
in reply to: NathanNation

I am also having the same problem.  I am currently running Windows 11.  I could login to Fusion with no issue up until about a week ago. I can't login until I install WebView2 but it is already installed.  I can't uninstall Edge or the existing WebView2 program??  Don't know how to proceed.

Message 18 of 32
yongjie_teng
in reply to: NathanNation

I have the same issue as well on Windows 10.

 

This was how I fixed the problem.

 

1. Go to 'Add and remove programs' 
2. Search for 'Microsoft Edge WebView2 Runtime'

3. Click on 'Modify'

4. Click 'Repair'

5. You should be able to use Fusion360 now.

 

 

Tags (1)
Message 19 of 32
mancuso99NVD
in reply to: yongjie_teng

Thank you for your help.
I could not find webview2 anywhere on my computer running windows 11. I the downloaded the evergreen standalone installer x64 version of webview2 but got an error message it would not install because the program is already installed on my computer.
However, if you run the evergreen version as an administrator, it now will install as directed. Fusion 360 should now work again like mine did.
Message 20 of 32
andrei_utkin
in reply to: mancuso99NVD

Thank you very much.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report