Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

WCS Offsets - Disable post if 0

10 REPLIES 10
Reply
Message 1 of 11
raul.prodan
418 Views, 10 Replies

WCS Offsets - Disable post if 0

Hello.

 

I was wondering if there is a way to always force the user to input a WCS Offset, and not leave it on 0.

This as an option of course, cause I understand that a lot of people do not use it.

 

I basically never use G54. And I always have to input something at WCS Offset. I would appreciate an option to stop me posting code if WCS is 0.

Unfortunately my G54 Z is always set to machine table height. And sadly I managed to crash the machine due to the height.

 

I did went to the WCS tab, and input a number. But it did not input unfortunately, and remained 0. This happens often. Probably some keyboard problems on my part. This time all the stars aligned and I managed to crash.

 

Also I use WCS in 2 places. I use it during setup, multiple WCS, etc.

And a special case that most people probably don't use, inside the setup, I'm using patters on operations, and on the patters I often use WCS override.

 

It would be great to get an error, opposed to the warning that is now. Or simply refuse to post.

As I was writing this I got a solution of not using G54 on my machine, by setting X and Y to 9999. This should prevent the machine running on 99% of the cases.

 

Thank you.

10 REPLIES 10
Message 2 of 11
a.laasW8M6T
in reply to: raul.prodan

You can set the WCS in the setup to what ever number you want and right click and set save as default

wcs.png

 

What post do you use, because it could likely be modified to error if the WCS is set to zero

Message 3 of 11
raul.prodan
in reply to: a.laasW8M6T

Thank you.

 

 

I do no want to set it default to something that I use by default. I need to be forced to input every time the WCS I need.

This can be a work around what I actually need.

 

I did set it to 9999 by default, and this does fail to post, with an error out of range. I did this on both setup, and pattern. Are there any more places that I can change this just to be sure? Or maybe some global value setting?

raulprodan_0-1683439148682.png raulprodan_2-1683439310063.png

 

 

If anyone has an better solution please pitch in.

 

@a.laasW8M6T The post processor I use is Fanuc v43363 with a home return added by me.

 

Thank you.

Message 4 of 11
engineguy
in reply to: raul.prodan

@raul.prodan 

 

From readng your Posts my understanding is that you just want to never post a G54 due to the way that you have your CNC Control set.

There are probably a number of ways to do what you need but here is a short video of what I think may be a fairly simple solution to what you need, you can set a "user default" to anything you want as @a.laasW8M6T has suggested and get the "out of range" error which stops you posting, or, you can leave it set to the original 0 default and just get a warning and automatically posting a G55 as shown in the video below. Couple of options that are easy to do in your PP if it is the same as the one I used, just make sure that you save a copy of the PP before making any modifications 🙂 🙂

Hope this is of some use to you 🙂

Message 5 of 11
raul.prodan
in reply to: engineguy

Thank you for your answer and your dedication of making a video.

 

This is a workaround to the issue. I might what to use G54 actually. I know I did say that I never use it. But I do not want to disable it.

I would like to disable posting if WCS is 0. Like I said in my previous post I did managed to default to 9999 instead of 0 and this works. But I am not certain that that 0 will not appear again.


The original issue is that sometimes I do enter a number in the WCS but it does not input (retain). I blame it on my keyboard, as I move fast through that section and do no look if I actually input it or not. So going to G55 instead of G54 does not solve my problem if I wanted G56 or G59 or G54.2 etc.

 

Thank you.

Message 6 of 11
engineguy
in reply to: raul.prodan

@raul.prodan 

 

If that is the situation then I do not think that I can help more with your issue, what I did was in a way guesswork as I did not have a copy of the Post Processor that you use.

You may be able to get one of the Fusion Post Processor "wizards" to modify a PP for you but I think that they will still need a copy of the PP that you are using.

With respect, it would seem that some of your problems are indeed due to your workflow maybe not being the best it could be 🙂

Apologies if I was not able to solve your issue 🙂

 

Message 7 of 11
raul.prodan
in reply to: raul.prodan

Hello again guys.

 

I have been trying something with while inputting the WCS numbers. If I input it very quickly (less than 1 second) it will not register the WCS.

 

Steps to recreate:

New Setup -> Post Process -> Move mouse above OK -> Input WCS number and click OK in less that 1 second.

 

If you check again the number I have inputted is not there. I see the number that I input clearly in the box.

 

If I press enter instead of left mouse click, the number does input corectlly.

 

Anyone else has the same issue?

 

Thank you.

Message 8 of 11
barney15e
in reply to: raul.prodan

There should be a line in the post processor code that looks for 0 and changes it to a 1, and creates a warning. You would need to change that line to error out, instead. There should be other sections that error out you could use as an example. 

Message 9 of 11
a.laasW8M6T
in reply to: raul.prodan

I can replicate this bug.

 

@seth.madore can you log this one?

Message 10 of 11
seth.madore
in reply to: a.laasW8M6T

@a.laasW8M6T yeah, I'll get it logged when I have a chance to replicate this on my end. Sorry for the absence, I've been on "vacation" this week. (in actuality, doing a 3,200 mile road trip to pick my son up from college)


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 11 of 11
seth.madore
in reply to: raul.prodan

I've logged the speed limitation as CAM-45347


Seth Madore
Customer Advocacy Manager - Manufacturing

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report