Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

VSCode plugin for Visual Studio code issue

6 REPLIES 6
SOLVED
Reply
Message 1 of 7
DarthBane55
641 Views, 6 Replies

VSCode plugin for Visual Studio code issue

I doubt I am in the right place to ask questions about the VSCode Plugin for editing posts, but I don't know where to post the question.  If someone can guide me to the correct forum that would be greatly appreciated.

The issue is that we have some posts with string manipulations like this for example:

 

var programIdNCSIMUL = programName.slice(0, programName.indexOf("-")).slice(0,2) + "00";

 

And the plugin is not dealing with them (fails to post).  I had to copy my post and comment out all these string manipulation lines, then it works. But that forces me to make changes to my copied post, then transfer them in my real post, which is 1 step extra.  It works, but it's a bit of a pain.

If there is support for this plugin, I would like to know if they can look into adding these strings manipulations functions in it.

Thanks!

6 REPLIES 6
Message 2 of 7

Have you had VS Code working with this plugin previously or have you only just installed it?

Message 3 of 7
Tomek.G
in reply to: DarthBane55

Hi @DarthBane55,

 

I seems to me, that files exported to VSCode are always 1005 as programName.

VSCode treats this value as a number and it caused an error in functions that can be used to manipulate strings.

Converting programName to string before manipulation solves this problem

 

  var p = String(programName);
  var programIdNCSIMUL = p.slice(0, p.indexOf("-")).slice(0, 2) + "00";

 

 


Tomek.G
Sr. Technical Consultant
Message 4 of 7
DarthBane55
in reply to: Tomek.G

Wow, that worked perfectly, you've just saved me so much pain!!!  I was hesitant to use the plugin for my other posts (I have 8 posts), but this fixed the issue, I can now use the plugin directly.  Awesome, thank you so much!

PS: to answer your previous question, I just installed it, just discovered that this thing existed.

Message 5 of 7
DarthBane55
in reply to: Tomek.G

Hi!  Again, I cannot get it to work today, see below, that's the log I get...  any idea?
 
Information: Size of intermediate NC data: 738kb
Debug: Loading intermediate NC data from 'c:\Users\frankl\.vscode\extensions\autodesk.hsm-post-processor-3.4.0\res\CNC files\Custom\9423-M1.cnc'.
Debug: Loading intermediate NC data as CNC.
Error: Failed to load intermediate NC data.
Failed to load intermediate NC data.
Code page changed to '1252  (ANSI - Latin I)'
 
Thanks!
Message 6 of 7
DarthBane55
in reply to: DarthBane55

Ok nevermind, I got it working again.

Message 7 of 7
olhT8MNY
in reply to: DarthBane55

Hello,

I've been having the same problem for a few days now, but only with drilling and milling operations. No problem at all as long as it only involves turning operations.

That said, it only affects my work PC.
I ran a test on my private PC, no problems at all, everything as it should be.

 

That's why I reinstalled Fusion 360 and "Visual Studio Code" on my work PC in the hope that it would help, but it didn't.

The proposed solution does nothing.
And since it's only my work PC that has the problem, I suspect that it's something else as a possible cause.
But apart from reinstalling Windows I can't think of anything🙁
Does anyone have another idea?
 
Thanks.
 

 

 

This is the error message;

----------------------------

Information: Loading post configuration from 'c:\Users\xxxxx\AppData\Local\Autodesk\Autodesk Fusion 360\3X5CP9HBJDZS\W.login\M\D20210810433457381\CAMPosts\xxxx\xxxx\xxxxxx.cps'.
Information: Size of intermediate NC data: 25.5kb
Debug: Loading intermediate NC data from 'c:\Users\xxxx\.vscode\extensions\autodesk.hsm-post-processor-4.1.3\res\CNC files\Custom\Mill2D.cnc'.
Debug: Loading intermediate NC data as CNC.
Error: Failed to load intermediate NC data.
Failed to load intermediate NC data.
Code page changed to '1252  (ANSI - Latin I)'
--------------------------------------------------
info: I exchanged sensitive information with “xxxx”.
 
 
-------------
Edition Windows 10 Business
Version 22H2
OS build 19045.3448

Experience Windows Feature Experience Pack 1000.19044.1000.0
 
 
 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report