Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

updates changed units of measure?

22 REPLIES 22
Reply
Message 1 of 23
leo.castellon
619 Views, 22 Replies

updates changed units of measure?

Weird problem. We recently had a few Fusion updates in the last week. Today when I opened this part in Fusion, which was a step file originally, in design, the units of measure were in millimeters. So, in design I changed it to inch units. I then go to manufacture, measure the turned down section, and it is measuring in millimeters?? I do not see anywhere to change units under the manufacturing folder. Under preferences, in the section marked "default units", I have inch selected for both design and manufacture. What is going on? I need to make this part today.

 

LeoC

22 REPLIES 22
Message 2 of 23
DarthBane55
in reply to: leo.castellon

Hi, this issue is strange, but will not prevent you from making this part today is any way.

If your post is in inches, it will output your code in inches.

If you are just worried about the dimensions, you can do a direct conversion and will see that the actual size of the part did not change.  You can also, enable the secondary units when you do a measure, and set it to inches.  This way in the results window you will get the cm units (weird) and the inches units.  You'll then see that the part did not change.

 

This is not a fix for this issue, but a method to verify that it's all good, so that you can confidently make this part today.  Hopefully the issue gets resolved soon!

Message 3 of 23
leo.castellon
in reply to: DarthBane55

Another part of this issue, is when you go to set up to set up the stock, all the units of measure are in millimeters. ARGH!

We are a quick turn shop, so a lot of stress to get parts turned around quickly, issues like this sure don't help.

 

LeoC

Message 4 of 23

Found a work around. Open the file in Solidworks, under options, make sure to save default units as inches. Save the file as a Solidworks file. Open the file in Fusion and lo and behold, units are in inches. I strongly feel that this needs to be investigated as it is not normal behavior. Something is not correct. If in Design space units are selected as inches, why in Manufacture is it in metric? And why is it ignoring what is selected in preferences? 

 

LeoC

Message 5 of 23
engineguy
in reply to: leo.castellon

@leo.castellon 

 

Some things do get changed during updates which is not best but in this case easily remedied, see image below, in Manufacturing just "mouse over" the Units shown in Red in the image, to the right a small "Edit" icon will appear that if you click on will open the dialog shown in Blue, you should then be able to re-set the Default Units there.

Manufacture Active Units.jpg

 

Message 6 of 23
leo.castellon
in reply to: engineguy

Thanks for both of your replies, I know that you both contribute a lot. But in response to engineguy, I had already tried that, see attached pictures. When I opened the parasolid file, I did not have that option.

 

LeoC

Message 7 of 23
engineguy
in reply to: leo.castellon

@leo.castellon 

 

See your problem, that would be a "bug" IMHO, it seems OK in the SW format so are you not able to work with that ??

Message 8 of 23
leo.castellon
in reply to: engineguy

I can work with the Solidworks file yes, but I didn't realize that when I originally posted.

 

LeoC

Message 9 of 23
jeff.pek
in reply to: leo.castellon

This is an interesting one. I'm not yet sure what explanation there would be about why we wouldn't show this information in the Manufacturing for models created from STEP vs. from SWX.

 

Time to put my Sherlock Holmes hat on and get sleuthing!

 

Jeff

Message 10 of 23
jeff.pek
in reply to: leo.castellon

I just tried this myself:

 - Exported a .step file from the model you posted

 - Opened the .step file

What I see is that it does show the units in the Manufacture space.

 

So, I don't know what is different. Can you document the steps you're using to get into this situation? Posting a screencast video would be ideal.

 

Thank you!

  Jeff

Message 11 of 23
leo.castellon
in reply to: jeff.pek

The following is my usual routine:

Step 1)    Open customer provided XT file, parasolid

Step 2)    Opens in Design, check a couple of measurements. About 99% of the time, it opens with inch units as that is what I have set up in preferences. If not, then I go to documents settings in Design and change units to inch.

Step 3) Go to manufacture and initialize a set up. If the change to units "stuck", then everything I do in manufacture is also in inches. On this part, the units were stuck in metric. If I flipped back to Design, units were in inches.

 

OK, try this, having the same problem with this part, same exact issue. Customer provided XT file, open in Fusion 360, goes directly to Design window. Document settings shows it is in metric units. Change units to inch. Save file. Open in Manufacture and is stuck in metric. I had to zip the file as it would not allow me to attach an XT file directly.

 

Thanks all for looking, LeoC 

Message 12 of 23
engineguy
in reply to: leo.castellon

@leo.castellon 

 

Hmm, slightly different workflow seems to work OK here, same as you with one small difference.

 

1) Open the XT file in Fusion, shows Metric in Design

2) Change Units to Inch in Design

3) Move to Manufacture and change Units to Inch  This is the different bit !!

4) Now save out.

5) Now open the saved Fusion f3d file and both the Design and Manufacture Units are "stuck" to the new Inch setting.

 

Just a small workflow change, change both the Design and Manufacture Units before saving out as the Fusion f3d file seems to work OK here.

Give it a try your end, might also work for you 🙂 🙂

 

Reckon there is still a small "bug" although it may be intended/expected behaviour by the developers 🙂 🙂

Message 13 of 23
leo.castellon
in reply to: engineguy

Still not working for me engineguy. See attached screen shots. I always turn off my computer at the end of the day. I started up my computer this morning, started Fusion. Opened the test file in xt format, opens in design, change units to inch. I immediately saved the file, then closed it. Opened the Fusion file, opens in design, confirmed that units were in inch. Go to manufacture, no option available to change units as shown by the tree. Used inspect, only units available are mm. Go to set up and stock options are only available in metric. So something is corrupt somewhere. Perhaps I need to uninstall Fusion and do a clean install? If I knew which registry keys to delete would even be better for a clean install.

 

I can confirm that if I open this part in Solidworks first, make sure under options that inch units are selected, and then save the file as a Solidworks file, when I open it in Fusion, it is in inch units in both design and manufacture. The only problem with this method is that I have to wait for a seat to open up for a license to be available, we do not have enough seats of software for all of our staff. 

 

I have been a CNC programmer for over 30 years. Have lots of experience with Gibbs, lots of versions of Mastercam and also used Surfcam. I have also used Solidworks since their 1999 version. Been using Fusion at my current employer for 1.5 years. I do not pretend to be an expert at anything, but this is wonky. If we didn't have a seat of Solidworks, I would be a bit screwed on these parts.

 

LeoC

Message 14 of 23

Hi @leo.castellon 

 

I just reported this same issue to Autodesk last week.  Not sure why this only affects some people and not all the masses.  Autodesk could replicate it with one of my Parasolid files and is looking into this for me.

 

As a workaround,  Try opening a new project (empty).  Then, right click on the file in the data panel and select "Insert into Current Design".

 

2022-02-02_12-30-32.jpg

 

You can then change the units in the Manufacture space.  Also, if needed, just break the link to the imported file.

 

Hope this helps you until Autodesk finds a fix to this odd issue.

 

Cheers,

 

 

Christopher Marion
Technical Specialist - CAM
SolidCAD - Canada





Message 15 of 23
engineguy
in reply to: leo.castellon

@leo.castellon 

 

It will work if you use the workflow that I listed, which you did not do, DO NOT SAVE after changing the Units in Design, what I do is load the XT file and in Design change the Units to what I want and then go straight to Manufacture and change the Units there and THEN SAVE THE WHOLE THING !

 

I have tested this workflow a number of times and when I open the saved Fudion f3d file it has the correct Units as I set then in both Design and Manufacture, works every time here as you can see in the Screencast. I will also attach the Fusion f3d file so anyone can try it out their end and see if the Units are still set to Inch when they open it.

 

As previously mentioned, not a "workaround", just do a logical step by step workflow 🙂 🙂 🙂

 

P.S. I forgot to mention and show in the Screencast that the Fusion f3d file that I created yesterday and opened up again today after the PC being shut down overnight still opened and showed the correct Units in both Design and Manufacture 🙂

 

Screencast link :-  https://autode.sk/32VsDcg

Message 16 of 23
engineguy
in reply to: engineguy

@ChristopherMarion 

 

Christopher, IMHO the reason why only a few users have a problem could just be down to simple workflow, user "shortcutting" ??  🙂

 

Have you tried the workflow that I have outlined ? If yes what did it do for you ?

Message 17 of 23

Thanks Christopher. I just tried it and at first I was confused about how you started a new project and got that option. So I played around with it, and ended up just selecting "New Design". Gave it a name and saved it. Then went to my recent data folder, and right clicked it to get the option of inserting the troublesome part into the design. That worked correctly, have options in both the design and manufacture space to change units. 

 

Thanks to all for looking at this. Can really hinder the workflow when we run into relatively minor problems, specially since we all all so busy, at least I hope we all are.

 

LeoC

Message 18 of 23

Engineguy, yesterday I tried your suggestion, both saving and not saving. I also just watched your screen cast, thanks for taking the time to do that. But, see, that is my frustration with this issue. I always follow the same workflow as you have shown, from day one of me using this software. But, I just don't get the option to change units in manufacture with this part.  I expanded the tree and there isn't an option that I see or am I not looking in the correct spot. I attached a picture of what my screen shows when I switch to manufacture. 

 

LeoC

Message 19 of 23

Hi @engineguy 

 

I can agree with @leo.castellon on this.  It isn't a workflow issue, there is something broke here and I can't pinpoint where.  I've sent this into Autodesk through a support case and they are looking into it.  

 

Take a look at this video describing our issue..... https://www.screencast.com/t/DYxx2U2J4

 

@leo.castellon - If you want to report your issue to Autodesk through a support case.  Reference this development case CAM-34535

 

Christopher Marion
Technical Specialist - CAM
SolidCAD - Canada





Message 20 of 23
jeff.pek
in reply to: leo.castellon

I looked into this earlier today, and have to say that I'm stumped. So far I haven't reproduced it, and I understand that even those who can do not see it consistently.

 

There's really no reason, looking at the code, that the unit system information, which is what should be represented in the browser, should not be there.

 

If anyone can identify some specific steps or conditions that seem to make this happen, I'm happy to hear about them -- maybe we can find a way to make this happen here.

 

Thanks,

  Jeff

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report