Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to post code

20 REPLIES 20
SOLVED
Reply
Message 1 of 21
jeremywilson1
609 Views, 20 Replies

Unable to post code

Im having a problem trying to post process any code. Iam using the personal version of fusion 360 My machine is set to a generic xy table using mach3 post processor and have brackets installed and set to external editor. While posting nothing happens, i don't get an error or any files in selected output folders. I have tried setting my machine to a haas with required post processor and still end up with the same results. 

20 REPLIES 20
Message 2 of 21
seth.madore
in reply to: jeremywilson1

Would you be able to capture this behavior in a video/screen recording?


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 3 of 21

Screenshot 2024-03-25 121931.pngScreenshot 2024-03-25 122034.pngScreenshot 2024-03-25 122127.png

Message 4 of 21
seth.madore
in reply to: jeremywilson1

And what do you see when you navigate to here?

2024-03-25_12h23_56.png


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 5 of 21

When i click post the editor doesn't open and don't end up with any files in selected folder.

 

Message 6 of 21
jeremywilson1
in reply to: seth.madore

Empty

Message 7 of 21
seth.madore
in reply to: jeremywilson1

Would you be able to share your Fusion file here?
File > Export > Save to local folder, return to thread and attach the .f3d/.f3z file in your reply.


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 8 of 21
jeremywilson1
in reply to: seth.madore

file

Message 9 of 21
seth.madore
in reply to: jeremywilson1

In the file you shared, the machine you've attached to the project had no post processor selected. I do see in your image above that you've selected the Mach3 post processor.

However, the NC Program that was in the file also shows that no Post Processor was selected:

2024-03-25_12h51_25.png

Furthermore; does your machine actually have an A axis table in a 3 axis format, or is a 4 axis machine?


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 10 of 21
seth.madore
in reply to: jeremywilson1

I'm seeing some really weird behavior in your file. I'm going to need to investigate some more. For example, once I try to post out your code, Fusion Manufacture essentially becomes unresponsive, although I can change to Design workspace without issue...


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 11 of 21

I just tryed deleting the ncprogram created a new one with my xy table machine and mach 3 post processor and the same thing happens. Im also unsure how to view Ncprograme like show because right clicking wont open anythingScreenshot 2024-03-25 130411.png

Message 12 of 21
seth.madore
in reply to: jeremywilson1

Try turning off the "Use Machine Configuration" in the top left corner of the screen you are showing.


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 13 of 21

Deleted program and made a new one with machine config unselected and mach3 post processor and the same thing happens

Message 14 of 21
seth.madore
in reply to: jeremywilson1

And you're using the Mach 3 post processor from the library, or is this one of your own that's been modified?


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 15 of 21

I have also tried loading the model on a different pc and end up with the same problem 

Message 16 of 21

I have discovered that after closing fusion and relaunching and loading the model again I am able to right click and edit the ncprogram but after trying to post nothing happens and I am unable to edit tool paths or the ncprogram/setup anymore  

Message 17 of 21
seth.madore
in reply to: jeremywilson1

Could you try importing this file back into your computer (preferably in a new folder/project so as not to confuse yourself or Fusion) and follow the steps I show in the video below:

 


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 18 of 21
seth.madore
in reply to: jeremywilson1


@jeremywilson1 wrote:

I have discovered that after closing fusion and relaunching and loading the model again I am able to right click and edit the ncprogram but after trying to post nothing happens and I am unable to edit tool paths or the ncprogram/setup anymore  


Yes, that is some of the weirdness I was seeing. Unsure what the cause of that is, but I did open CAM-52614 to investigate.


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 19 of 21
jeremywilson1
in reply to: seth.madore

The one i'm using is directly from the library and unmodified 

Message 20 of 21
jeremywilson1
in reply to: seth.madore

This seems to fix the problem and got it to post thank you so much for the help!

Am i unable to input a machine and can only post this way?  

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report