Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Trouble with Z-axis fault on ProtoTrak SMX

3 REPLIES 3
SOLVED
Reply
Message 1 of 4
rhawthorne73UZ5
213 Views, 3 Replies

Trouble with Z-axis fault on ProtoTrak SMX

The machinist in our shop has run into a problem using Fusion on our ProtoTrak SMX - the mill keeps getting a Z-axis fault (see attached) for this particular part. There is a spot drill and then a drilling cycle, and we have had both fault out at different times, almost always just above the part before it starts drilling.

 

We had the equipment and motors inspected, and the technician said that it appears to be an issue with the program since it can be manually moved without faulting, and only when running the code does it fault out. We have also tried talking to ProtoTrak, and they believe the issue is with Fusion... at this point I'm not sure.

 

The part is attached, as well as the code - if someone could check out the code and see if anything sticks out, that would be very helpful. Been stuck on this part for two days now and tried a bunch of things, but so far without success.

 

Has anyone else dealt with something like this? Any experience on the best way to troubleshoot?

3 REPLIES 3
Message 2 of 4

From what you say it does dill some holes OK but occasionally faults?

The peck drill op seems to look correct, this is from the manual.

HughesTooling_0-1713359850052.png

 

Have you tried programming several peck drill ops on the control, not G code? Drilling a lot of holes is going to stress the Z axis more than manually moving the Z up and down. May be setup a pattern with 100 holes or more just air cutting.

 

Mark Hughes
Owner, Hughes Tooling
Did you find this post helpful? Feel free to Like this post.
Did your question get successfully answered? Then click on the ACCEPT SOLUTION button.

EESignature


Message 3 of 4

Hello Mark,

 

Thank you for reviewing the code and your suggestions. I created a conversational program (.PT4) on the ProtoTrak, like you suggested, and we ended up having the same problem as with using the g-code - the machine would rapid in the z-axis, begin feeding for ~.100-.200", then fault out on the z-axis.

 

It seems clear now that the problem must be with the machine itself... Time to go back and talk to the technician... 

Message 4 of 4

It ended up being that the Z-axis servomotor brushes were very worn out. We got them replaced and now it works like a charm - no issue with Fusion.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums