Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Through Tool Coolant

5 REPLIES 5
Reply
Message 1 of 6
patrizio.costa
175 Views, 5 Replies

Through Tool Coolant

Hi,

i use a standard Fanuc post (with kinematic definition and some other little customization) on our Yasda 5 axis milling machine.

When i use through Tool Coolant, the machine requires a M116 before the coolant activation, a kind of "function authorization".

Any idea on how to get this?

Thank you!!!

5 REPLIES 5
Message 2 of 6

Hi @patrizio.costa 

In the coolant definition object in setting you can change this to get what you have wanted

    coolants: [
      {id:COOLANT_FLOOD, on:8},
      {id:COOLANT_MIST},
      {id:COOLANT_THROUGH_TOOL, on:88, off:89},
      {id:COOLANT_AIR},
      {id:COOLANT_AIR_THROUGH_TOOL},
      {id:COOLANT_SUCTION},
      {id:COOLANT_FLOOD_MIST},
      {id:COOLANT_FLOOD_THROUGH_TOOL, on:[8, 88], off:[9, 89]},
      {id:COOLANT_OFF, off:9}
    ],

 

On the COOLANT_THROUGH_TOOL you can change like this

    coolants: [
      {id:COOLANT_FLOOD, on:8},
      {id:COOLANT_MIST},
      {id:COOLANT_THROUGH_TOOL, on:[116, 88], off:89},
      {id:COOLANT_AIR},
      {id:COOLANT_AIR_THROUGH_TOOL},
      {id:COOLANT_SUCTION},
      {id:COOLANT_FLOOD_MIST},
      {id:COOLANT_FLOOD_THROUGH_TOOL, on:[8, 88], off:[9, 89]},
      {id:COOLANT_OFF, off:9}
    ],

 

If you want to add any codes while turning off you can add it in the off.


Boopathi Sivakumar
Senior Technology Consultant

Message 3 of 6

Hi,

thank you for your quick answer.

This is not what i need. In fact, i've already changed this line

 

{id:COOLANT_THROUGH_TOOL, on:88, off:89},
in
{id:COOLANT_THROUGH_TOOL, on:50, off:9},
 
The M116 code must be added in a separate line just before the tool change. I did'nt write it in the question (sorry 🙂)
 
Thank you
Message 4 of 6

try adding a 

writeBlock(mFormat.format(116)); 

 

to whever you need, probably right before the Coolant Enable command

Please click "Accept Solution" if what I wrote solved your issue!
Message 5 of 6

This is correct. I wanted to add the M116 just with through tool coolant.

But in fact, i could add it before every tool..

Message 6 of 6

yes so try what I said... 

Please click "Accept Solution" if what I wrote solved your issue!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums